LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 03-16-2013, 12:33 PM   #1
Linux.tar.gz
Senior Member
 
Registered: Dec 2003
Location: Paris
Distribution: Slackware forever.
Posts: 2,227

Rep: Reputation: 86
Red face Slackware64 14.0, real time kernel, no real time as user.


Hi.

This is the n+1 thread about non-working real time as user.

The RT kernel is up and running, i installed and configured the different limits files with rtprio nice and 3000000 memlock, i don't use a login manager, and i don't want to use PAM.

As usual, when i try to launch jack as user, i got a:
JACK is running in realtime mode, but you are not allowed to use realtime scheduling.

After applying these changes, please re-login in order for them to take effect.

$ ulimit -r -l
real-time priority (-r) 0
max locked memory (kbytes, -l) 64

Plz help :/.
 
Old 03-17-2013, 04:48 AM   #2
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 2,498

Rep: Reputation: 912Reputation: 912Reputation: 912Reputation: 912Reputation: 912Reputation: 912Reputation: 912Reputation: 912
http://slackbuilds.org/repository/14...onnection-kit/

Quote:
Originally Posted by README
jackd has to run with realtime privileges. One way to do this on Slackware
would be to use set_rlimits. Since 12.2 there's another way - if you have
a filesystem that supports posix capabilities (reiserfs does not), you can
grant jackd the rights to run in realtime mode, even when started as a
normal user, with the following command:

setcap cap_ipc_lock,cap_sys_nice=ep /usr/bin/jackd

If you use qjackctl to start jack, it will need the same capabilities set
to be able to start jack as non-root user. You can use the same command
with 'qjackctl' instead of 'jackd'
 
Old 03-17-2013, 06:44 PM   #3
Linux.tar.gz
Senior Member
 
Registered: Dec 2003
Location: Paris
Distribution: Slackware forever.
Posts: 2,227

Original Poster
Rep: Reputation: 86
Ok thanks, i will try.

/usr is reiserfs, so i suppose i have to recompile jack with another --prefix ?
 
Old 03-18-2013, 01:20 AM   #4
lambo69
LQ Newbie
 
Registered: Sep 2012
Posts: 21

Rep: Reputation: Disabled
I got this message for the following reasons when using set_rlimits:
- user was not in group "audio" (or whatever group was set in set_rlimits.conf)
- i missspelled the ablolute path to the program in set_rlimits.conf
- i didn't start the programm with "set_rlimits pgName"
 
Old 03-18-2013, 05:08 PM   #5
Linux.tar.gz
Senior Member
 
Registered: Dec 2003
Location: Paris
Distribution: Slackware forever.
Posts: 2,227

Original Poster
Rep: Reputation: 86
Ok, seems i now got the real time.

One last thing:
I still have this problem:
Quote:
WARNING: Your system has a limit for maximum amount of locked memory!
This might cause Ardour to run out of memory before your system runs
out of memory. You can view the memory limit with 'ulimit -l', and it
is normally controlled by /etc/security/limits.conf
Whatever i put in limits.conf changes nothing :/.
 
Old 03-19-2013, 02:49 AM   #6
lambo69
LQ Newbie
 
Registered: Sep 2012
Posts: 21

Rep: Reputation: Disabled
You could ignore that message (inspite of that message, ardour runs here without any problem related to memory), or you could try to use ulimit via /sbin/initscript.
 
Old 03-19-2013, 06:24 PM   #7
jpollard
Senior Member
 
Registered: Dec 2012
Location: Washington DC area
Distribution: Fedora, CentOS, Slackware
Posts: 2,334

Rep: Reputation: 594Reputation: 594Reputation: 594Reputation: 594Reputation: 594Reputation: 594
Quote:
Originally Posted by Linux.tar.gz View Post
Ok thanks, i will try.

/usr is reiserfs, so i suppose i have to recompile jack with another --prefix ?
Capabilities are stored with the inode - it just means you shouldn't use riserfs and expect capabilities to work.
 
Old 03-23-2013, 04:24 PM   #8
Linux.tar.gz
Senior Member
 
Registered: Dec 2003
Location: Paris
Distribution: Slackware forever.
Posts: 2,227

Original Poster
Rep: Reputation: 86
Did all mentioned, i still have the memory problem, and ardour crashes because of midi memory problem :/
 
Old 03-23-2013, 05:21 PM   #9
Linux.tar.gz
Senior Member
 
Registered: Dec 2003
Location: Paris
Distribution: Slackware forever.
Posts: 2,227

Original Poster
Rep: Reputation: 86
As user, i got :

ulimit -l unlimited
bash: ulimit: max locked memory: cannot modify limit: Operation not permitted
 
Old 03-24-2013, 03:11 AM   #10
lambo69
LQ Newbie
 
Registered: Sep 2012
Posts: 21

Rep: Reputation: Disabled
You tried /sbin/initscript to set ulimit? Iirc, settings done via ulimit relate to the shell ulimit is run in: you have to do the change as root, but you will (hopefully) run ardour as user, so ardour won't be affectet by the new setting. Therefore this setting should be done in /sbin/initscript.

Edit: When you use set_rlimits you have to use /etc/set_rlimits.conf instead of /etc/security/limits.conf

Last edited by lambo69; 03-24-2013 at 03:15 AM.
 
Old 03-24-2013, 07:41 AM   #11
Linux.tar.gz
Senior Member
 
Registered: Dec 2003
Location: Paris
Distribution: Slackware forever.
Posts: 2,227

Original Poster
Rep: Reputation: 86
Ok, i'll try.

Yup i figured it out the file.

Thx.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[RTAI] Can POSIX real time signals result in soft real time? TheIndependentAquarius Linux - Newbie 0 04-21-2012 06:14 AM
user time, system time, real time .. reg chaitanyajun12 Linux - Newbie 4 04-08-2011 01:18 AM
real time kernel not real time, still xruns in Jackd browny_amiga Linux - General 0 09-20-2009 03:47 PM
LXer: Real-time garbage collection with Real-time Java LXer Syndicated Linux News 0 05-05-2007 01:16 PM
LXer: Real-time Linux gains real-time JVM LXer Syndicated Linux News 0 10-12-2006 11:54 AM


All times are GMT -5. The time now is 12:31 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration