LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Slackware64 14.0, real time kernel, no real time as user. (http://www.linuxquestions.org/questions/slackware-14/slackware64-14-0-real-time-kernel-no-real-time-as-user-4175454337/)

Linux.tar.gz 03-16-2013 11:33 AM

Slackware64 14.0, real time kernel, no real time as user.
 
Hi.

This is the n+1 thread about non-working real time as user.

The RT kernel is up and running, i installed and configured the different limits files with rtprio nice and 3000000 memlock, i don't use a login manager, and i don't want to use PAM.

As usual, when i try to launch jack as user, i got a:
JACK is running in realtime mode, but you are not allowed to use realtime scheduling.

After applying these changes, please re-login in order for them to take effect.

$ ulimit -r -l
real-time priority (-r) 0
max locked memory (kbytes, -l) 64

Plz help :/.

ponce 03-17-2013 03:48 AM

http://slackbuilds.org/repository/14...onnection-kit/

Quote:

Originally Posted by README
jackd has to run with realtime privileges. One way to do this on Slackware
would be to use set_rlimits. Since 12.2 there's another way - if you have
a filesystem that supports posix capabilities (reiserfs does not), you can
grant jackd the rights to run in realtime mode, even when started as a
normal user, with the following command:

setcap cap_ipc_lock,cap_sys_nice=ep /usr/bin/jackd

If you use qjackctl to start jack, it will need the same capabilities set
to be able to start jack as non-root user. You can use the same command
with 'qjackctl' instead of 'jackd'


Linux.tar.gz 03-17-2013 05:44 PM

Ok thanks, i will try.

/usr is reiserfs, so i suppose i have to recompile jack with another --prefix ?

lambo69 03-18-2013 12:20 AM

I got this message for the following reasons when using set_rlimits:
- user was not in group "audio" (or whatever group was set in set_rlimits.conf)
- i missspelled the ablolute path to the program in set_rlimits.conf
- i didn't start the programm with "set_rlimits pgName"

Linux.tar.gz 03-18-2013 04:08 PM

Ok, seems i now got the real time.

One last thing:
I still have this problem:
Quote:

WARNING: Your system has a limit for maximum amount of locked memory!
This might cause Ardour to run out of memory before your system runs
out of memory. You can view the memory limit with 'ulimit -l', and it
is normally controlled by /etc/security/limits.conf
Whatever i put in limits.conf changes nothing :/.

lambo69 03-19-2013 01:49 AM

You could ignore that message (inspite of that message, ardour runs here without any problem related to memory), or you could try to use ulimit via /sbin/initscript.

jpollard 03-19-2013 05:24 PM

Quote:

Originally Posted by Linux.tar.gz (Post 4913510)
Ok thanks, i will try.

/usr is reiserfs, so i suppose i have to recompile jack with another --prefix ?

Capabilities are stored with the inode - it just means you shouldn't use riserfs and expect capabilities to work.

Linux.tar.gz 03-23-2013 03:24 PM

Did all mentioned, i still have the memory problem, and ardour crashes because of midi memory problem :/

Linux.tar.gz 03-23-2013 04:21 PM

As user, i got :

ulimit -l unlimited
bash: ulimit: max locked memory: cannot modify limit: Operation not permitted

lambo69 03-24-2013 02:11 AM

You tried /sbin/initscript to set ulimit? Iirc, settings done via ulimit relate to the shell ulimit is run in: you have to do the change as root, but you will (hopefully) run ardour as user, so ardour won't be affectet by the new setting. Therefore this setting should be done in /sbin/initscript.

Edit: When you use set_rlimits you have to use /etc/set_rlimits.conf instead of /etc/security/limits.conf

Linux.tar.gz 03-24-2013 06:41 AM

Ok, i'll try.

Yup i figured it out the file.

Thx.


All times are GMT -5. The time now is 11:53 PM.