LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Slackware64 - 14.0 and Cakephp URL Rewriting Configuration (http://www.linuxquestions.org/questions/slackware-14/slackware64-14-0-and-cakephp-url-rewriting-configuration-4175471275/)

Manuel-H 07-29-2013 12:11 AM

Slackware64 - 14.0 and Cakephp URL Rewriting Configuration
 
Seeking help on the above.

application involved - apache 2.4.3 and cake 2.3.8

Error message when trying to access cake app - URL rewriting is not properly configured on your server.
http://book.cakephp.org/2.0/en/insta...rewriting.html

I followed the above URL steps but still having the same issue.

/etc/httpd/httpd/conf (already uncommented and AllowOverride All)
Code:

LoadModule rewrite_module libexec/apache2/mod_rewrite.so

<Directory />
    Options FollowSymLinks
    AllowOverride All
</Directory>

phpinfo() confirmed that mod_rewrite module was loaded.

There was no error on the httpd error log that tell me anything obvious was wrong beside this URL rewriting.

Note: the same cake application was working on another machine running Slackware 13 and httpd 2.2

Major difference is the httpd version upgrade v2.2 to v2.4.

Appreciate any help or advice.

Thanks.

cisneros 07-29-2013 01:50 AM

is the website in subfolder or in the root htdocs folder?, maybe something like:

Quote:

<Directory />
Options FollowSymLinks
AllowOverride All
</Directory>

<Directory /cakephp_app>
Options FollowSymLinks
AllowOverride All
</Directory>
would work.

something similar happened to me with codeigniter, that solved it.

Manuel-H 07-29-2013 02:31 AM

Hi Cisneros,

Yes, the website is on another folder.

/etc/httpd/httpd.conf
Code:

<Directory /test>
        AllowOverride All
        Options FollowSymLinks
        Require all granted
</Directory>

As I am using vhost, I also modified the httpd-vhost.conf as well.
All not successful.

I also tried using the full path, but same result.
Code:

<Directory /var/www/htdocs/test>
        AllowOverride All
        Options FollowSymLinks
        Require all granted
</Directory>

Note: restarted apache after each modification.

tdos20 07-29-2013 10:24 AM

Are the .htaccess file definitely copied over? As they are hidden files sometimes they're missed.

Manuel-H 07-29-2013 08:47 PM

Yes, .htaccess files are both there at app and webroot folders.

If all else fail, I will have to revert to previous versions of Slackware which still uses apache 2.2.
Default Slackware 14.0 using httpd 2.4.3, is there a package for httpd 2.2 that is supported in Slackware 14?

My current options:
- Fix this URL rewriting on Slackware 14.0 and httpd 2.4.3
- Downgrade to httpd 2.2.x
- Use Slackware 13.x which uses httpd 2.2.x

I still wish to get it work in 14 and 2.4
Thanks guys for your effort to help, still hoping for someone to assist and help me out.


All times are GMT -5. The time now is 11:43 PM.