LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 06-09-2010, 05:42 PM   #1
ahmadj
Member
 
Registered: Jun 2010
Distribution: Slackware64_13.37 \ Slackware_13.1 \ ARMedslack_13.37
Posts: 80

Rep: Reputation: 16
Slackware64 13.1 Nvidia framebuffer woes - blank screen after lilo


preamble
Just upgraded my system from 13.0 to 13.1

Most things went pretty smoothly, but I tried 'startx' before the post-upgrade/config reboot and the system hung - "time to upgrade my video drivers", I thought. Upgraded to Nvidia 195.36.15*. X works perfectly, and a modprobe shows the 'nvidia' module loaded. So far so good.

the problem itself
However, when I try to use any vesa modes in lilo, I get a blank screen after the BIOS check and the system hangs - even toggling numlock on or off won't work... So I can only boot up in text mode. This makes me unhappy, partially because I like penguins, but also because it is an absolute insult to my new (old) monitor.

I thought this could be to do with the nouveau conflicts reported by -current users some days ago, but the respective blacklist file is present so I'm stuck as to what to do...

*I've tried 195.36.15, 195.36.24 and the latest 2xx beta drivers. All exhibit the same behaviour.

EDIT - forgot to post my video card specs. It's an 8500gt w/ 256mb, 128-bit DDR3.

Last edited by ahmadj; 06-09-2010 at 05:49 PM.
 
Old 06-09-2010, 09:15 PM   #2
damgar
Senior Member
 
Registered: Sep 2009
Location: dallas, tx
Distribution: Slackware - current multilib/gsb Arch
Posts: 1,949
Blog Entries: 8

Rep: Reputation: 201Reputation: 201Reputation: 201
I had some weirdness with my Nvidia gt220 and the huge kernel, but I don't recall at this point what they were. Something about rivafb if I remember correctly. A generic kernel (with initrd of course) ended the wierdness.
 
1 members found this post helpful.
Old 06-10-2010, 04:33 AM   #3
ahmadj
Member
 
Registered: Jun 2010
Distribution: Slackware64_13.37 \ Slackware_13.1 \ ARMedslack_13.37
Posts: 80

Original Poster
Rep: Reputation: 16
Ah, initrd... I've never (knowingly) used one before, since slack 11.0... I've always read about it in the docs but never seemed to need it?

Do I need one? I'm using the stock generic kernel.
 
Old 06-10-2010, 05:57 AM   #4
ahmadj
Member
 
Registered: Jun 2010
Distribution: Slackware64_13.37 \ Slackware_13.1 \ ARMedslack_13.37
Posts: 80

Original Poster
Rep: Reputation: 16
Ah - I'm an idiot..

Turns out I was using huge after all. Updated the symlink to generic (vmlinuz) and now I can get a VESA console

However, I get kernel panic shortly after that.. guess I need an initrd?

EDIT: I've noticed there are no smp kernels anymore.. I'd assume the the generic kernel is smp on slack64?

Last edited by ahmadj; 06-10-2010 at 07:57 AM.
 
Old 06-10-2010, 07:12 AM   #5
Lufbery
Senior Member
 
Registered: Aug 2006
Location: Harrisburg, PA
Distribution: Slackware 64 14.0
Posts: 1,142
Blog Entries: 29

Rep: Reputation: 119Reputation: 119
Quote:
Originally Posted by ahmadj View Post
Ah - I'm an idiot..

Turns out I has using huge after all. Updated the symlink to generic (vmlinuz) and now I can get a VESA console

However, I get kernel panic shortly after that.. guess I need an initrd?
Yeah. I'm not at my Slackware computer, but IIRC there are instructions in the /boot directory called readme.initrd (or something like that). Follow those and you're good to go.

Quote:
EDIT: I've noticed there are no smp kernels anymore.. I'd assume the the generic kernel is smp on slack64?
Yes. The 64-bit kernels are smp.
 
1 members found this post helpful.
Old 06-10-2010, 07:31 AM   #6
damgar
Senior Member
 
Registered: Sep 2009
Location: dallas, tx
Distribution: Slackware - current multilib/gsb Arch
Posts: 1,949
Blog Entries: 8

Rep: Reputation: 201Reputation: 201Reputation: 201
There is a script, /usr/share/mkinitrd/mkinitrd_command_generator.sh that has never failed to generate the correct initrd for me. I personally just do
Code:
echo `sh /usr/share/mkinitrd/mkinitrd_command_generator.sh`
### NOTE: Those are backticks. ###
 
1 members found this post helpful.
Old 06-10-2010, 07:56 AM   #7
ahmadj
Member
 
Registered: Jun 2010
Distribution: Slackware64_13.37 \ Slackware_13.1 \ ARMedslack_13.37
Posts: 80

Original Poster
Rep: Reputation: 16
Quote:
Originally Posted by damgar View Post
There is a script, /usr/share/mkinitrd/mkinitrd_command_generator.sh that has never failed to generate the correct initrd for me. I personally just do
Code:
echo `sh /usr/share/mkinitrd/mkinitrd_command_generator.sh`
### NOTE: Those are backticks. ###
Yeah, found that after a quick google. Trying it out now. Thanks!

EDIT: Well, it failed for me ;] Fails to mount the root partition on boot (/dev/sda2). I think it's to do with my RAID controller, will try adding the respective module to the generated command...

Last edited by ahmadj; 06-10-2010 at 08:13 AM.
 
Old 06-10-2010, 09:32 AM   #8
ahmadj
Member
 
Registered: Jun 2010
Distribution: Slackware64_13.37 \ Slackware_13.1 \ ARMedslack_13.37
Posts: 80

Original Poster
Rep: Reputation: 16
This is annoying... Still doesn't work.

Here is the command that mkinitrd_command_generator.sh gave me:

Code:
mkinitrd -c -k 2.6.33.4 -f ext4 -r /dev/sda2 -m usbhid:ehci-hcd:jbd2:mbcache:ext4 -o /boot/initrd.gz
It compiles the initrd without a hitch and Lilo installs with only the usual (incosequential) warnings.

However, boot halts with this:
Code:
mount: mounting /dev/sda2 on /mnt failed: Invalid argument
Then some subsequent errors about the rootfs not being mounted and the system hangs.

My RAID controller is the Intel equivalent of an LSI SCSI320-2e. I tried adding the 'megaraid' driver to the mkinitrd command so it reads
Code:
mkinitrd -c -k 2.6.33.4 -f ext4 -r /dev/sda2 -m usbhid:megaraid:ehci-hcd:jbd2:mbcache:ext4 -o /boot/initrd.gz
but still no luck, same things happens..
 
Old 06-10-2010, 09:48 AM   #9
Richard Cranium
Senior Member
 
Registered: Apr 2009
Location: Carrollton, Texas
Distribution: Slackware64 14.1
Posts: 1,439

Rep: Reputation: 407Reputation: 407Reputation: 407Reputation: 407Reputation: 407
Did you go look in /boot/initrd-tree/lib/modules/2.6.33.4/kernel/ directory tree to see if your modules were actually placed in there? When you cat /boot/initrd-tree/rootdev, does it have the correct value? Does that device exist in /boot/initrd-tree/dev?

(BTW, the default for mkinitrd's "-o" option is /boot/initrd.gz)
 
1 members found this post helpful.
Old 06-10-2010, 09:49 AM   #10
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 2,404

Rep: Reputation: 852Reputation: 852Reputation: 852Reputation: 852Reputation: 852Reputation: 852Reputation: 852
nvidia proprietary drivers never played well with framebuffer console for me...
 
0 members found this post helpful.
Old 06-10-2010, 02:32 PM   #11
ahmadj
Member
 
Registered: Jun 2010
Distribution: Slackware64_13.37 \ Slackware_13.1 \ ARMedslack_13.37
Posts: 80

Original Poster
Rep: Reputation: 16
Question

Quote:
Originally Posted by Richard Cranium View Post
Did you go look in /boot/initrd-tree/lib/modules/2.6.33.4/kernel/ directory tree to see if your modules were actually placed in there? When you cat /boot/initrd-tree/rootdev, does it have the correct value? Does that device exist in /boot/initrd-tree/dev?

(BTW, the default for mkinitrd's "-o" option is /boot/initrd.gz)
Thanks for that, just checked. All seems to be in place.

I'm thinking now that it's not really to do with the RAID controller - wouldn't mount complain about not being able to find the device in that case? Instead it says 'invalid argument'...

Bit of a head-scratcher, this...
 
Old 06-11-2010, 06:14 AM   #12
ahmadj
Member
 
Registered: Jun 2010
Distribution: Slackware64_13.37 \ Slackware_13.1 \ ARMedslack_13.37
Posts: 80

Original Poster
Rep: Reputation: 16
Well, almost solved now!

It turns out the correct driver was 'megaraid_mm', not 'megaraid'. even with adding this to my initrd, though, I had the same problem. It turns out that the generic kernel + initrd recognizes drives in a different order to the huge kernel!

Here was my drive setup under 13.0 -
sda1 - swap on megaraid
sda2 - / on megaraid
sdb1 - home on megaraid
hda1/2 - windows on ide

under 13.1 huge, that changed to -
sda1 - swap on megaraid
sda2 - / on megaraid
sdb1 - home on megaraid
sdc1/2 - windows on ide

but under 13.1 generic, that becomes -
sda1/2 - windows on ide
and tohers numbered accordingly

So I disabled the IDE drive in BIOS and the system booted all the way to login!

So, is there any way to force the IDE drive to be mounted as sdc instead of sda, even though IDE is compiled in and RAID is a module?

Last edited by ahmadj; 06-11-2010 at 08:22 AM.
 
Old 06-11-2010, 12:22 PM   #13
ahmadj
Member
 
Registered: Jun 2010
Distribution: Slackware64_13.37 \ Slackware_13.1 \ ARMedslack_13.37
Posts: 80

Original Poster
Rep: Reputation: 16
The problem was solved by ripping out the Windows HDD. Typical =D

Thanks for all your help guys, I'm marking this solved.
 
Old 06-11-2010, 12:46 PM   #14
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 2,404

Rep: Reputation: 852Reputation: 852Reputation: 852Reputation: 852Reputation: 852Reputation: 852Reputation: 852
Quote:
Originally Posted by ahmadj View Post
the problem itself
However, when I try to use any vesa modes in lilo, I get a blank screen after the BIOS check and the system hangs - even toggling numlock on or off won't work... So I can only boot up in text mode. This makes me unhappy, partially because I like penguins, but also because it is an absolute insult to my new (old) monitor.

I thought this could be to do with the nouveau conflicts reported by -current users some days ago, but the respective blacklist file is present so I'm stuck as to what to do...

*I've tried 195.36.15, 195.36.24 and the latest 2xx beta drivers. All exhibit the same behaviour.

EDIT - forgot to post my video card specs. It's an 8500gt w/ 256mb, 128-bit DDR3.
sorry, i am very curious how you solved this with proprietary drivers.

could be useful to others (me too)...

can you boot with vesa on, startx, and then, exiting x, go back to a fully working fb console?

Last edited by ponce; 06-11-2010 at 01:00 PM.
 
Old 06-11-2010, 02:10 PM   #15
ahmadj
Member
 
Registered: Jun 2010
Distribution: Slackware64_13.37 \ Slackware_13.1 \ ARMedslack_13.37
Posts: 80

Original Poster
Rep: Reputation: 16
Quote:
Originally Posted by ponce View Post
sorry, i am very curious how you solved this with proprietary drivers.

could be useful to others (me too)...

can you boot with vesa on, startx, and then, exiting x, go back to a fully working fb console?
yep...

To be honest it has always 'just worked' for me. It was 13.1 that broke it.

I did encounter some weirdness when trying to figure it out. Here's what made it finally work -
  • Make sure the rivafb, nv etc. drivers are not compiled into your kernel. Stock 13.1 generic kernel is fine.
  • DO NOT add the ehci_hcd or usbhid modules to your initrd. They will result in the behaviour described in OP, for some reason which completely eludes me.

And I am using Nvidia's 195.36.15 drivers, they seem to work best for me on this kernel.
 
  


Reply

Tags
framebuffer, nvidia


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Incorrect screen resolution with slackware64 13.1 and nvidia 195.36.15 driver Phorize Slackware 14 05-28-2010 04:58 AM
blank screen at boot when using lilo FB wufo Slackware 5 11-20-2007 10:03 PM
LCD screen is blank after lilo on VGN-S580P dasoberdick Slackware 10 06-16-2007 12:03 PM
yet again need help,screen goes blank in tv out nvidia zeltak Linux - Software 1 02-13-2006 08:58 AM
Kernel recompiling woes (blank screen) jrdioko Linux - Software 2 08-14-2005 07:15 PM


All times are GMT -5. The time now is 02:28 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration