LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Slackware64-13.1 : mac (Monkey's Audio Linux port) build fail using sbopkg (http://www.linuxquestions.org/questions/slackware-14/slackware64-13-1-mac-monkeys-audio-linux-port-build-fail-using-sbopkg-811981/)

pokipoki08 06-03-2010 01:17 PM

Slackware64-13.1 : mac (Monkey's Audio Linux port) build fail using sbopkg
 
Did anyone else experience the a/m problem? I got the same issue when try to compile by source.

Quote:

if /bin/sh ../../libtool --tag=CXX --mode=compile g++ -DHAVE_CONFIG_H -I. -I. -I../../src/Shared -I../../src/Shared -O3 -Wall -pedantic -Wno-long-long -MT APELink.lo -MD -MP -MF ".deps/APELink.Tpo" -c -o APELink.lo APELink.cpp; \
then mv -f ".deps/APELink.Tpo" ".deps/APELink.Plo"; else rm -f ".deps/APELink.Tpo"; exit 1; fi
g++ -DHAVE_CONFIG_H -I. -I. -I../../src/Shared -I../../src/Shared -O3 -Wall -pedantic -Wno-long-long -MT APELink.lo -MD -MP -MF .deps/APELink.Tpo -c APELink.cpp -fPIC -DPIC -o .libs/APELink.o
APELink.cpp: In member function 'void CAPELink::ParseData(const char*, const str_utf16*)':
APELink.cpp:66: error: invalid conversion from 'const char*' to 'char*'
APELink.cpp:67: error: invalid conversion from 'const char*' to 'char*'
APELink.cpp:68: error: invalid conversion from 'const char*' to 'char*'
APELink.cpp:69: error: invalid conversion from 'const char*' to 'char*'
make[3]: *** [APELink.lo] Error 1
make[3]: Leaving directory `/mnt/d1-500gb/SLACKWARE/sbopkg.local/script/SBo/13.1/audio/mac/mac-3.99-u4-b5/src/MACLib'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/mnt/d1-500gb/SLACKWARE/sbopkg.local/script/SBo/13.1/audio/mac/mac-3.99-u4-b5/src/MACLib'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/mnt/d1-500gb/SLACKWARE/sbopkg.local/script/SBo/13.1/audio/mac/mac-3.99-u4-b5/src'
make: *** [all-recursive] Error 1

chess 06-03-2010 01:31 PM

This is not an sbopkg problem as your title suggests. There is a problem compiling it on 64 bit architecture. Did you try this:

http://aidanjm.wordpress.com/2007/02.../#comment-3226

pokipoki08 06-05-2010 03:54 PM

It worked. Thanks.


All times are GMT -5. The time now is 03:26 AM.