LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 06-03-2010, 01:17 PM   #1
pokipoki08
Member
 
Registered: Mar 2009
Posts: 76

Rep: Reputation: 16
Slackware64-13.1 : mac (Monkey's Audio Linux port) build fail using sbopkg


Did anyone else experience the a/m problem? I got the same issue when try to compile by source.

Quote:
if /bin/sh ../../libtool --tag=CXX --mode=compile g++ -DHAVE_CONFIG_H -I. -I. -I../../src/Shared -I../../src/Shared -O3 -Wall -pedantic -Wno-long-long -MT APELink.lo -MD -MP -MF ".deps/APELink.Tpo" -c -o APELink.lo APELink.cpp; \
then mv -f ".deps/APELink.Tpo" ".deps/APELink.Plo"; else rm -f ".deps/APELink.Tpo"; exit 1; fi
g++ -DHAVE_CONFIG_H -I. -I. -I../../src/Shared -I../../src/Shared -O3 -Wall -pedantic -Wno-long-long -MT APELink.lo -MD -MP -MF .deps/APELink.Tpo -c APELink.cpp -fPIC -DPIC -o .libs/APELink.o
APELink.cpp: In member function 'void CAPELink::ParseData(const char*, const str_utf16*)':
APELink.cpp:66: error: invalid conversion from 'const char*' to 'char*'
APELink.cpp:67: error: invalid conversion from 'const char*' to 'char*'
APELink.cpp:68: error: invalid conversion from 'const char*' to 'char*'
APELink.cpp:69: error: invalid conversion from 'const char*' to 'char*'
make[3]: *** [APELink.lo] Error 1
make[3]: Leaving directory `/mnt/d1-500gb/SLACKWARE/sbopkg.local/script/SBo/13.1/audio/mac/mac-3.99-u4-b5/src/MACLib'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/mnt/d1-500gb/SLACKWARE/sbopkg.local/script/SBo/13.1/audio/mac/mac-3.99-u4-b5/src/MACLib'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/mnt/d1-500gb/SLACKWARE/sbopkg.local/script/SBo/13.1/audio/mac/mac-3.99-u4-b5/src'
make: *** [all-recursive] Error 1
 
Old 06-03-2010, 01:31 PM   #2
chess
Member
 
Registered: Mar 2002
Location: 127.0.0.1
Distribution: Slackware, OpenBSD, FreeBSD
Posts: 728

Rep: Reputation: 168Reputation: 168
This is not an sbopkg problem as your title suggests. There is a problem compiling it on 64 bit architecture. Did you try this:

http://aidanjm.wordpress.com/2007/02.../#comment-3226
 
Old 06-05-2010, 03:54 PM   #3
pokipoki08
Member
 
Registered: Mar 2009
Posts: 76

Original Poster
Rep: Reputation: 16
It worked. Thanks.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[slackware64] Unable to start jamin (audio app) after installation via sbopkg pokipoki08 Slackware 8 09-08-2009 07:25 AM
Cannot build extreme tuxracer Slackware64 mlangdn Slackware 12 06-21-2009 04:42 AM
Sbopkg and Slackware64 Update chess Slackware 1 05-27-2009 09:11 PM
Configuring .ape (Monkey's Audio) in Sound Juicer samtuba Linux - Software 0 11-05-2005 11:44 AM
Good Monkey's Audio (APE) Encoder br00tal Linux - General 1 06-17-2005 04:17 AM


All times are GMT -5. The time now is 10:40 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration