LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Slackware64-13.0 multilib can not build valid initrd for kernels 2.6.30 (http://www.linuxquestions.org/questions/slackware-14/slackware64-13-0-multilib-can-not-build-valid-initrd-for-kernels-2-6-30-a-792005/)

sid77 02-27-2010 01:56 PM

Slackware64-13.0 multilib can not build valid initrd for kernels 2.6.30
 
Hello all,
I've just installed a Slackware64-13.0 test machine with alienBOB's multilib packages. I'm running the stock kernel generic-2.6.29.6 with an initrd set up using mkinitrd.conf
Everything is fine except that I cannot build a right initrd for kernels 2.6.30, both the /testing one or a custom build: if I try, it will panic at boot with the "couldn't find a valid RAM disk image" error.
On the same hardware, without multilib support, I was able to correctly build and boot 2.6.30 initrds. Can anyone confirm this strange behaviour? In case, got any workaround or suggestions?

Thanks in advance for any help,
Marco

escaflown 02-28-2010 10:17 AM

The multilib capability doesn't affect the initrd setup process. The problem should be either in the links in /boot (System.map and so on) or in your lilo.conf. Did you try to get a suggestion of the mkinitrd command you need using '/usr/share/mkinitrd/mkinitrd_command_generator.sh -r'?

sid77 02-28-2010 02:50 PM

Quote:

Originally Posted by escaflown (Post 3880042)
The multilib capability doesn't affect the initrd setup process.

I'd also say that, but...

Quote:

Originally Posted by escaflown (Post 3880042)
The problem should be either in the links in /boot (System.map and so on) or in your lilo.conf. Did you try to get a suggestion of the mkinitrd command you need using '/usr/share/mkinitrd/mkinitrd_command_generator.sh -r'?

I can assure that mkinitrd options are ok as I copied them from a working machine without multilib, I also double check links whenever I install a new kernel. I'm pretty confident they're ok. By the way: I'm typing these very lines on a custom 2.6.29.6 kernel. The mkinitrd stuff is ok, really.

samac 02-28-2010 03:44 PM

I can confirm that you can build and boot an initrd.gz for kernel 2.6.32.7 and the ext4 filesystem using Slackware64-current with the multi-lib packages installed.

samac

escaflown 02-28-2010 05:30 PM

Quote:

Originally Posted by sid77 (Post 3880239)
I'd also say that, but...


I can assure that mkinitrd options are ok as I copied them from a working machine without multilib, I also double check links whenever I install a new kernel. I'm pretty confident they're ok. By the way: I'm typing these very lines on a custom 2.6.29.6 kernel. The mkinitrd stuff is ok, really.

Weird. I dual boot between a 32 bit version of slackware and a 64-bit-current version of slackware with multilib enabled without any problem.

Cheesesteak 02-28-2010 11:16 PM

How large is your initrd?

Did you try the option large-memory in your lilo.conf file?

Martinezio 03-01-2010 04:23 AM

Hi, I also have this issue, but I think, that it is combined rather with kernel, than glibc version. I had no problem with mkinitrd with some older kernels. This problem starts with 2.6.30 kernels.
Maybe some upgrade of mkinitrd tool is needed?

Alien Bob 03-01-2010 05:21 AM

Slackware-current has the 2.6.32.7 kernel and I can create initrd's without any problem (32-bit, 64-bit and multilib systems). Likewise, I don't see why Slackware-13.0 should not be able to create a wrorking initrd for newer kernel versions.
You can try upgrading to the mkinitrd package that is part of Slackware64-current, but if you do that, make sure you have a "rescue" entry in your /etc/lilo.conf that allows you to boot your computer in case the new mkinitrd does not work for Slackware 13.0.

Eric

sid77 03-01-2010 09:05 AM

Quote:

Originally Posted by Cheesesteak (Post 3880601)
Did you try the option large-memory in your lilo.conf file?

Ok, this is probably it! I was so puzzled by this strange behaviour that I forgot to double check lilo.conf: in the old config file I had that option enabled, while the current one hasn't it.
I'll test it tonight or tomorrow and report back. Thanks to anyone who chimed in for help.

ciao

Martinezio 03-02-2010 02:11 AM

Quote:

Originally Posted by Martinezio (Post 3880786)
This problem starts with 2.6.30 kernels.

OOooopsss... Damn me ;) I was telling about 2.6.33 kernel, not 2.6.30. Mea maxima culpa ;) Sorry.

sid77 03-03-2010 03:20 AM

I confirm it was the missing "large-memory" option. thanks!

Cheesesteak 03-03-2010 03:32 AM

Awesome!


All times are GMT -5. The time now is 12:36 AM.