LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 01-07-2008, 08:18 PM   #1
drauk
Member
 
Registered: Sep 2007
Location: /MX/BC/TJ
Distribution: Slackware 13
Posts: 37

Rep: Reputation: 15
Slackware with arch


Hi
i just installed arch to test it but i can't make dual boot work with lilo
i got installed slsackware in hda2 (sda2 in arch) and arch in hdc3 (sdb3 in arch)
i tried monting arch linux partition to /mnt/arch then i added and to lilo.conf this:

Code:
image = /mnt/arch/boot/vmlinuz26
  root = /dev/hdc3
  initrd = /mnt/arch/boot/kernel26.img
  label = arch
  read-only
 Linux bootable partition config ends
and then update lilo without errors, but when i tried to boot arch i got error 0x01 from lilo.

And if i tried to do the same steps in arch the lilo doesn't work at all, i only got alot of 00's at boot.

I think the problem is because arch use sd* and slackware hd*

anyone know how to make it work?

Thanks
 
Old 01-07-2008, 10:28 PM   #2
lstamm
Member
 
Registered: Aug 2007
Location: McBride, BC, Canada
Distribution: Slackware, OpenBSD, Edubuntu
Posts: 53

Rep: Reputation: 17
I tried dual booting Slack with Arch a few months ago, and the only way I could get this to work was to use grub to boot. I though about upgrading to the newest kernel on the slack side, which would probably have fixed the hda/sda naming problem with lilo, but never actually did this.

In the end, I experience too many frustrations with Arch (mainly around their required dependencies and compile-time options) to want to continue with it. My old laptop is back to a slack only machine
 
Old 01-07-2008, 10:31 PM   #3
Uncle_Theodore
Member
 
Registered: Dec 2007
Location: Charleston WV, USA
Distribution: Slackware 12.2, Arch Linux Amd64
Posts: 896

Rep: Reputation: 60
I dual-boot Slackware and Arch. But my harddrive is /dev/sda on both systems. I use lilo from Slackware with no problems at all. What version of Slackware are you running?

PS Ib any case, have you tried setting root=/dev/sdb3 for arch in your lilo.conf?

Last edited by Uncle_Theodore; 01-07-2008 at 10:32 PM.
 
Old 01-07-2008, 10:54 PM   #4
MannyNix
Member
 
Registered: Dec 2005
Location: ~
Distribution: Slackware -current, OpenBSD
Posts: 449

Rep: Reputation: 41
Here's part of my Slackware's /etc/lilo.conf for arch after a fresh arch install:
Code:
# ARCH
image = /mnt/archhda4/boot/vmlinuz26
initrd = /mnt/archhda4/boot/kernel26.img  
root = /dev/hda4
label = Arch
read-only
On my /etc/fstab it looks like this:
Code:
/dev/hda4  /mnt/archhda4 reiserfs  defaults     1  1
I didn't like the "sda thing" so when installing arch, i used the 'ide-legacy' option (or something like that) Check it a boot time, and check if you need to type ide-legacy or 'ide-legacy' i don't remember atm
No need to use grub (imo)
good luck

Last edited by MannyNix; 01-07-2008 at 10:59 PM.
 
Old 01-08-2008, 02:54 AM   #5
drauk
Member
 
Registered: Sep 2007
Location: /MX/BC/TJ
Distribution: Slackware 13
Posts: 37

Original Poster
Rep: Reputation: 15
to lstamm
thanks for you advice, i will try to make it work with lilo but if i can't i will use grub

to Uncle_Theodore
i'm using slackware 12 with kernel 2.6.23.12, i tried with /dev/sdb3 but doesn't work, i got this error "Fatal: Illegal 'root=' specification: /dev/sdb3"

to mannyslack
do you know any way to change sd* to hd* without install arch again??

Thanks for yours answers
 
Old 01-08-2008, 10:25 AM   #6
MannyNix
Member
 
Registered: Dec 2005
Location: ~
Distribution: Slackware -current, OpenBSD
Posts: 449

Rep: Reputation: 41
Quote:
Originally Posted by drauk View Post
to lstammto mannyslack
do you know any way to change sd* to hd* without install arch again??
No, sorry i don't. Not sure if it can be done safely. Just guessing:
umount arch partition(s) edit all /etc/fstab (including arch's) and change to hdX. Remount partitions again (mount -a) and edit /etc/lilo.conf Then /sbin/lilo and hope it works. Please let us know if it does. Also helpfull to ask in arch forums or irc, but let us know how i was solved please
gl
 
Old 01-09-2008, 01:43 PM   #7
Alien_Hominid
Senior Member
 
Registered: Oct 2005
Location: Lithuania
Distribution: Hybrid
Posts: 2,247

Rep: Reputation: 53
You can use force lilo option. Be careful.
 
Old 01-09-2008, 01:52 PM   #8
Uncle_Theodore
Member
 
Registered: Dec 2007
Location: Charleston WV, USA
Distribution: Slackware 12.2, Arch Linux Amd64
Posts: 896

Rep: Reputation: 60
There's another thing to try... You can install arch's lilo on the superblock of the arch's root partition. And then, in you Slackware lilo.conf set something like you'd done for Windows
other=/dev/hdc3
label=Arch
table=/dev/hdc

Then, in Arch's lilo.conf you could set root to be /dev/sdb3
You'll get a two-stage booting of Arch, but hopefully, it will work.
 
Old 01-10-2008, 04:17 PM   #9
drauk
Member
 
Registered: Sep 2007
Location: /MX/BC/TJ
Distribution: Slackware 13
Posts: 37

Original Poster
Rep: Reputation: 15
Hi again, thanks for all your suggestions.

you aren't going to believe this the second hard disk was disabled in the bios (with is kinda weird i don't remember to disable it, and i can read/write without problem in linux) so i enabled and that fixed the 0x01 error in lilo. But still arch doesn't work so i made some research in google and fixed the problem adding this to lilo.conf:
Code:
append="root=/dev/disk/by-uuid/5fcd8afe-bc0a-415b-9d4a-24b988e056ad"
Code:
# Linux bootable partition config begins
image = /mnt/arch/boot/vmlinuz26
  root = /dev/hdc3
  append="root=/dev/disk/by-uuid/5fcd8afe-bc0a-415b-9d4a-24b988e056ad"
  initrd = /mnt/arch/boot/kernel26.img
  label = arch
  read-only
# Linux bootable partition config ends
to check the uuid for every partition write
Code:
ls -l /dev/disk/by-uuid/
Note to myself:
Always double-check error suggestion (even if i am sure the problem is not there)
Code:
0x01: Illegal Command
    This shouldn't happen, but if it does, it may indicate an attempt to access a disk which is not supported by the BIOS. Definitely check to see if the disk is seen by the BIOS first (and that the BIOS detail is complete).

Last edited by drauk; 01-10-2008 at 04:19 PM.
 
Old 01-10-2008, 11:00 PM   #10
MannyNix
Member
 
Registered: Dec 2005
Location: ~
Distribution: Slackware -current, OpenBSD
Posts: 449

Rep: Reputation: 41
Interesting, thanks for letting us know how you fixed it. (In a very Slacker style btw )
 
Old 05-05-2009, 07:25 PM   #11
YourPadre
LQ Newbie
 
Registered: Apr 2005
Location: Guadalajara, Mexico
Posts: 10

Rep: Reputation: 0
slackware & Arch working dual boot :D

Using a console in Slackware
1.- mount /dev/sda9 /mnt/arch
2.- cd /mnt/arch/boot && cp kernel26.img vmlinuz26 /boot
3.- Add to /etc/lilo.conf
image = /boot/vmlinuz26
root = /dev/sda9
label = arch
read-only
initrd = /boot/kernel26.img
4.- run, lilo
5.- Reboot and select arch, work fine
 
  


Reply

Tags
arch, boot, dual, slackware12


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Apt on Slackware/Arch Filosofem Linux - General 10 12-19-2011 11:19 PM
Slackware before Arch? scrappydoo Arch 22 09-03-2008 09:25 AM
slackware or arch? osc~ Arch 14 08-28-2007 12:39 AM
Arch to Slackware 10.2 w/ kernel Anonymo LinuxQuestions.org Member Success Stories 1 12-14-2005 11:16 PM
Arch vs. Slackware njbrain General 5 03-01-2004 10:01 AM


All times are GMT -5. The time now is 06:28 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration