LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Slackware will continue (http://www.linuxquestions.org/questions/slackware-14/slackware-will-continue-266111/)

GinEric 12-13-2004 08:50 PM

Slackware will continue
 
In addition to some comments and questions, how is Patrick?

This forum needs a sticky on how he's doing.

In any case, trying to continue to make Slackware better, I've come across a few problems.

Attempting to compile beta for Apache 2.0.52, PHP 5.0.2, MySQL 5.0.2, has tree bugs. Not from Slackware, but from the three developers above. It's sad how quickly they discounted Slackware in all of their documentation.

Let me list, for those developers, the problems with all other operating systems:

RedHat, Suse, Mandrake, and the others have gone off the GNU license and seem more commercial and Windows oriented than a true Linux Operating system. Windows itself plays a very poor role in GNU and any software development.

Only Slackware has remained true to Linus Torvalds and consequently Patrick Volkerding's ideaology of free source and SourceForge itself seems to have forgotten this!

Gooey's are nice, but no substitute for command line knowledge; they make all developers "lazy," and result in broken software.

Dependance on them makes the programmers minimum wage click and point operator employees.

Like ordering a hamburger from a picture menu and not knowing how to add the bill!

Thus, all of the problems in compiling a co-compile of Apache 2.0.52, PHP 5.0.2, and MySQL 5.0.2 because none of them puts the source objects where they belong on Slackware, and none of them set the correct permissions for the executables.

The prefixes and --with's do not work, indeed, a recent compile of PHP 5.0.2 resulted in a blank, that is, nothing was installed!

So, if anyone knows, I'd like to know where to find the scripts for the configures of these three for Slackware.

And someone report on how Patrick is doing!

slackMeUp 12-13-2004 09:14 PM

If I knew... I'd tell you.

We only know as much as the change log tells us.

I have no plans to leave slack any time soon. I'll update software as I need to...

I have wondered once. . . SuSE, Gentoo... it was fun for a bit, but I came home to slack.

jong357 12-13-2004 09:25 PM

Apache

PHP

MySQL

All of those that your trying to install are significant version changes from what these build scripts refer to but you can try it anyway. Just change the top part of the build scripts to point to the right package ofcourse....

jong357 12-13-2004 09:43 PM

Found this too...

ftp://ftp.slackware.com/pub/slackwar...ges/php-5.0.2/

build directory:

ftp://ftp.slackware.com/pub/slackwar...g/source/php5/

MylesCLin 12-13-2004 10:07 PM

For future reference, there is a sticky, it's here;
http://www.linuxquestions.org/questi...hreadid=255700

drisay 12-14-2004 06:41 AM

I don't remember exactly what versions I recently installed as I haven't yet had the chance to do much development on them yet, but seems to me they were the most recent. I'll check when I get home and try to give some details on how it worked.

All I remember is that I did a LOT of reading to get things going properly.

ringwraith 12-14-2004 07:42 AM

To the OP. Pat has never struck me as a real ideologue. He just wanted a simple version of linux that worked.So he made the distro he wanted and made it available for others Slackware is my distro and has been for quite a few years. I wanted to say that so the rest of my comments are not taken out of context. I do have a separate partition that I use to play with others. If you are a true believer in free software a la RMS then Debian main would be more your cup of tea. After all Slack comes with some proprietary software such as Netscape, java, flash.... I would also point out that as far as I have read Linus does not use Slackware.

xushi 12-14-2004 08:01 AM

(enter the flame war)... I'll just stay out of this and get back to IOS.. ;)

hanzerik 12-14-2004 10:57 AM

I have compiled Apache 2.0.52 and PHP 5.0.2 many many times on Slackware 10 with no issues at all, I'm not sure what Mysql version I used but (Think it was the most current, was November timeframe) there were no issues with it either. I don't use MySql that much, just testing stuff.

GinEric 12-15-2004 04:57 PM

Appreciate all the comments.

I will check those links.

Netscape was released to the public, including the source code, by the originators before AOL bought Netscape, Inc. The two are separate entities. The software is in the public domain.

It's slow nowadays anyway.

hanzerick, did you use --prefix or edit the configures?

PHP did a blank compile when I did it. I mean, no files anywhere, yet it said it was compiled!

Nothing against any of the other distributions, they just had more problems for me when I tried to install. A lot did go more or less commercial though.

I was really looking for Patrick's actual configure scripts, which may be hard to find.

Let me check the links. Thanks.

GinEric 12-15-2004 06:03 PM

I have a little time while downloading [I'm lazy, using KDE, but it and Gftp seem to think that I'm on a modem, 9Kbps, instead of DSL, problem I'm also trying to figure out, plus, Kong won't login anonymous; I do believe it's leaking the user password! --kdekonq bug report].

Little bugs are everywhere!

Linus and Patrick made a statement some time ago on keeping with the command line base of Linux. Just from what I remember, they seemed to agree.


Got to get other files now, be amused.
:Pengy:

GinEric 12-15-2004 06:28 PM

Last notes.

Jong357 thanks for the links. PHP5 seems okay, but MySQL and Apache are lower versions than what I've already tried. The PHP5 testing shows Patrick, or someone at Slackware.com, was working on PHP5 at least up to 26 November. I'm trying to get a little ahead of that with Apache 2.0.52, PHP 5.0.2, and MySQL 5.0.2

Preparing for their releases next year.

hanzerik, I still would like to know how you did that, compiled Apache 2.0.52 and PHP 5.0.2 I had Apache compiled and working, in fact, it's still on the server. PHP 5.0.2 made me laugh silly, with a "compiled and installed ok" and nothing on the server to prove it! hehe

Maybe a leftover configure -n

I did use --prefix for Apache, but apparently it went ahead and erased the execprefix!

I also did Apache --with-mysql, but, in the end, all the mysql's were unexecutable!

I'm going to try again, once I get the correct install shells together.

Thanks again people.

In the configure files, I figure Patrick put specific directories, that's what I'm looking for.
:Pengy:


All times are GMT -5. The time now is 05:55 PM.