LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 02-25-2011, 11:19 PM   #46
colorpurple21859
Senior Member
 
Registered: Jan 2008
Location: florida
Distribution: slackware64-current, puppy, ubuntu
Posts: 1,386

Rep: Reputation: 186Reputation: 186

as root do the following at a prompt
Quote:
modprobe wl
if you get no error messages try wicd again
 
Old 02-27-2011, 10:38 PM   #47
linux/unix87
Member
 
Registered: Oct 2010
Posts: 190

Original Poster
Rep: Reputation: 6
Quote:
Originally Posted by colorpurple21859 View Post
as root do the following at a prompt if you get no error messages try wicd again
ok is that modprobe wl or w pipe anyway i tried both and nothing happened i am able to turn on my wireless but still doesnt work? would i have to manually configure it cause it is on auto on wicd i also got wicd working just not picking anything up? thanks
 
Old 02-28-2011, 06:53 PM   #48
colorpurple21859
Senior Member
 
Registered: Jan 2008
Location: florida
Distribution: slackware64-current, puppy, ubuntu
Posts: 1,386

Rep: Reputation: 186Reputation: 186
Quote:
i am able to turn on my wireless but still doesnt work?
So I'm taking it that wicd is now seeing your network card, which by the way is what
Quote:
modprobe wl
as in small L, was for to load the driver module for your network card. Your need to start giving more information for people to help you. Have no idea what kind of network your trying to connect or type of security the network uses. Have no clue as to what you have done to connect to said network or if your wirless card sees a network to connect to. Nobody here can read between the lines or absorb what you have done or not done, error messages or anything else through osmosis. Don't even know if your wireless card is turned on or just recognized by the system as far as that goes. Don't mind helping but need more details. I don't use wcid so I can't be much help there.

Last edited by colorpurple21859; 02-28-2011 at 06:54 PM.
 
Old 02-28-2011, 08:13 PM   #49
linux/unix87
Member
 
Registered: Oct 2010
Posts: 190

Original Poster
Rep: Reputation: 6
Quote:
Originally Posted by colorpurple21859 View Post
So I'm taking it that wicd is now seeing your network card, which by the way is what as in small L, was for to load the driver module for your network card. Your need to start giving more information for people to help you. Have no idea what kind of network your trying to connect or type of security the network uses. Have no clue as to what you have done to connect to said network or if your wirless card sees a network to connect to. Nobody here can read between the lines or absorb what you have done or not done, error messages or anything else through osmosis. Don't even know if your wireless card is turned on or just recognized by the system as far as that goes. Don't mind helping but need more details. I don't use wcid so I can't be much help there.
ok my key on the keyboard that turns on and off for the wireless works now. but there is still no connection wicd is not picking one up and there is no security on it so i dont have to put a password on it. i got the driver install which is broadcom and thats what made the wireless key on the keyboard work but thats it. wicd does not detect any connection wired or wireless so how would i go about diagnose this problem?
 
Old 02-28-2011, 08:24 PM   #50
linux/unix87
Member
 
Registered: Oct 2010
Posts: 190

Original Poster
Rep: Reputation: 6
oh modprobe does nothing i dont think it recognizes the module
 
Old 02-28-2011, 08:28 PM   #51
colorpurple21859
Senior Member
 
Registered: Jan 2008
Location: florida
Distribution: slackware64-current, puppy, ubuntu
Posts: 1,386

Rep: Reputation: 186Reputation: 186
at a prompt as root
Quote:
ifconfig -a
Quote:
ifconfig wlan0 up
#or whatever the ifconfig -a listed as your wireless card

Quote:
iwlist wlan0 scan
this will use the wireless device interface (that from the above command, we found out has wireless capability) and scan for wireless routers that are accessible. if you see no wireless access points might still be problem with wireless card.

Quote:
iwconfig wlan0 essid "myssid"
assuming no security, use that device to connect to your router.

Quote:
dhclient wlan0
will attempt to get ip-address, subnet mask, dns server information automatically from your router assuming dhcp is turned on on your router.
This the manually way of doing just to get connected first then we can worry about making it automated.

Last edited by colorpurple21859; 02-28-2011 at 08:33 PM.
 
Old 02-28-2011, 11:04 PM   #52
linux/unix87
Member
 
Registered: Oct 2010
Posts: 190

Original Poster
Rep: Reputation: 6
ok more error messages
root@darkstar:~# ifconfig -a
eth0 Link encap:Ethernet HWaddr 78:ac:c0:4b:06:ec
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
Interrupt:26

eth1 Link encap:Ethernet HWaddr ac:81:12:26:ad:db
inet6 addr: fe80::ae81:12ff:fe26:addb/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
Interrupt:17

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:4 errors:0 dropped:0 overruns:0 frame:0
TX packets:4 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:240 (240.0 B) TX bytes:240 (240.0 B)

root@darkstar:~# iwlist wlan0 scan
wlan0 Interface doesn't support scanning.

root@darkstar:~# iwconfig wlan0 essid
Error for wireless request "Set ESSID" (8B1A) :
too few arguments.
root@darkstar:~# dhclient wlan0
SIOCSIFADDR: No such device
wlan0: ERROR while getting interface flags: No such device
wlan0: ERROR while getting interface flags: No such device
root@darkstar:~#

---------- Post added 02-28-11 at 11:05 PM ----------

i think i have a problem with the hardware still?
 
Old 03-01-2011, 08:05 AM   #53
onebuck
Moderator
 
Registered: Jan 2005
Location: Midwest USA, Central Illinois
Distribution: SlackwareŽ
Posts: 11,446
Blog Entries: 4

Rep: Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505
Hi,

Substitute 'eth1' for the commands to you have tried. You are using 'wl' driver and I'll bet the wireless device is 'eth1'.
 
Old 03-04-2011, 10:50 PM   #54
linux/unix87
Member
 
Registered: Oct 2010
Posts: 190

Original Poster
Rep: Reputation: 6
Quote:
Originally Posted by onebuck View Post
Hi,

Substitute 'eth1' for the commands to you have tried. You are using 'wl' driver and I'll bet the wireless device is 'eth1'.
its not unless im doing it wrong but from what you said about substituting wlan0 to eth1 on the commands colorpurple gave me i do believe they are the same error messages as i sent before? im guessing its the hardware? anything else i could try?
 
Old 03-04-2011, 10:57 PM   #55
linux/unix87
Member
 
Registered: Oct 2010
Posts: 190

Original Poster
Rep: Reputation: 6
ok i figured out that im stupid i forgot to turn on the wireless my other computers do it for me so the command iwlist eth1 scan did find my router cause i see a name im very familiar with. but when i tried iwconfig eth1 essid it gave me the error message error for wireless request "Set ESSID" (8B1A) too few arguments ? what does this mean?
 
Old 03-04-2011, 11:16 PM   #56
linux/unix87
Member
 
Registered: Oct 2010
Posts: 190

Original Poster
Rep: Reputation: 6
ok i figured it out i went to wicd and then clicked on preferences and where it says wireless interface i typed in eth1 and it found my router, but i was trying not to do that, that way so if its possible how would it have been done by the terminal? what im trying to do is learn more on the terminal so i can get better at it. ive been working on getting this internet on my other computer for awhile now and im really liking slackware. also how do you update the system? thanks very much everybody has been helpful i learned alot.
 
Old 03-05-2011, 09:20 AM   #57
onebuck
Moderator
 
Registered: Jan 2005
Location: Midwest USA, Central Illinois
Distribution: SlackwareŽ
Posts: 11,446
Blog Entries: 4

Rep: Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505
Hi,

Your problem was that the 'wl' driver was using the eth1 device as your wireless interface. This driver is noted for this condition that the device will be identified as 'eth#' vs 'wlan#'. So the first available device is 'eth1' for your system. If you use 'eth1' then things should be easily setup by using that device.
 
Old 03-07-2011, 10:31 PM   #58
linux/unix87
Member
 
Registered: Oct 2010
Posts: 190

Original Poster
Rep: Reputation: 6
Quote:
Originally Posted by onebuck View Post
Hi,

Your problem was that the 'wl' driver was using the eth1 device as your wireless interface. This driver is noted for this condition that the device will be identified as 'eth#' vs 'wlan#'. So the first available device is 'eth1' for your system. If you use 'eth1' then things should be easily setup by using that device.
ok that makes sense but what im asking is how would you change wlan0 to eth1 on the terminal? instead of using wicd?
 
Old 03-07-2011, 10:49 PM   #59
onebuck
Moderator
 
Registered: Jan 2005
Location: Midwest USA, Central Illinois
Distribution: SlackwareŽ
Posts: 11,446
Blog Entries: 4

Rep: Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505
Hi,

Quote:
Originally Posted by linux/unix87 View Post
ok that makes sense but what im asking is how would you change wlan0 to eth1 on the terminal? instead of using wicd?
Back in post #5 I suggested;
Quote:
If your device driver & firmware are in place then Configuring your network in Slackware is Alien_Bob's excellent article on the way network cards are configured in Slackware. Loads of internal reference links for Ethernet & Wireless.
You will configure device [1] in '/etc/rc.d/rc.inet1.conf'' by using the 'eth1' device section.
If you do not use dhcp then be sure to setup your '/etc/resolv.conf'' file with proper DNS from the ISP. Setup the gateway for your LAN.

Quote:
excerpt sample from '/etc/rc.d/rc.inet1.conf';
# Config information for eth1:
IPADDR[1]=""
NETMASK[1]=""
USE_DHCP[1]=""
DHCP_HOSTNAME[1]=""

# Default gateway IP address:
GATEWAY="192.168.1.1"
What is the reason for not using 'wicd'?
 
Old 03-08-2011, 09:58 PM   #60
linux/unix87
Member
 
Registered: Oct 2010
Posts: 190

Original Poster
Rep: Reputation: 6
Quote:
Originally Posted by onebuck View Post
Hi,


Back in post #5 I suggested;
You will configure device [1] in '/etc/rc.d/rc.inet1.conf'' by using the 'eth1' device section.
If you do not use dhcp then be sure to setup your '/etc/resolv.conf'' file with proper DNS from the ISP. Setup the gateway for your LAN.

What is the reason for not using 'wicd'?
hi

there is no reason for using wicd i just wanted to learn how to do it on the terminal thats all. wicd made it very easy but im trying to use the terminal more to get use to the commands etc. wicd is a very good program if it wasnt for wicd i still wouldnt have wireless. anyway the file /etc/rc.d/rc.inet1.conf there is no such file? is there any kind of tutorial to do this? i found rc.d,0,1,2,3,4,5,6 but.... what im trying to say is im lost. config file i cant find is rc.d and rc.inet1 seperate or together? thanks
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Slackware 12.2 Wifi problem with Atheros bloodangel Linux - Newbie 5 12-26-2008 08:10 PM
Slackware 12.1 wifi connection problem. hatchetwkd Linux - Laptop and Netbook 1 09-25-2008 02:29 AM
Slackware Atheros AR5007 configuration(?) problem and Wifi issues ZeroDaHero Linux - Wireless Networking 2 08-24-2008 07:09 PM
Slackware 12.0: boot problem & sudo / wifi-radar problem War_Ensemble Slackware 7 01-15-2008 10:49 AM
Slackware Wifi Problem sc0tt Linux - Wireless Networking 5 05-06-2006 11:42 AM


All times are GMT -5. The time now is 03:42 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration