LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Slackware Wifi Issues (http://www.linuxquestions.org/questions/slackware-14/slackware-wifi-issues-4175444383/)

NintendoFanboy 01-06-2013 12:47 PM

Slackware Wifi Issues
 
I have recently acquainted myself into "Slackware". But, on my keyboard, it shows the "Connections" button as off, and Slackware also can't find any routers nearby. When I press the Connections button on my keyboard it doesn't turn blue (I have an HP Pavilion DV6). I'm not sure if this is a key binding issue or not. Please help.

Iberwil 01-06-2013 12:58 PM

Hi,

You might want to give away some more information like:

What network manager are you using? - wicd, networkmanager..
What type of connection are you trying to set up? - LAN, wi-fi, adsl..
The output of ifconfig at the konsole

No idea what that Connections keyboard button is supposed to do. Is it a one-touch sort of magically get online thing?

NintendoFanboy 01-06-2013 01:18 PM

1. I am currently using "Network manager" (the one that is initially in the system settings).
2. I can honestly admit I have no idea what the type of wireless connection, all I know is that it's a Verizon Router (most likely LAN).
3. The button mentioned before is towards the front of the keyboard. It doesn't have a label, but when it's red, wireless connections are off, but when it's blue wireless connections are on.

Iberwil 01-06-2013 01:51 PM

Ok,

At this point we don't care what type the service is, it's a wireless network you want to connect to.

Before anything else you should check if all the cables are properly plugged and restart the router to try again.

Do you see the network's name (SSID) in network manager?

If not, is the WLAN light on the router active? If it is then it should be broadcasting and if the WAN light is active as well it should be fine. If this is the case with the lights and it's a LAN network and you have a wired interface on that laptop you could try to connect the laptop with the feeding LAN cable (skip the router) and see if that works. If it does then you'll know the router is failing you.


if the WLAN light is off, but the WAN one is on you could connect the laptop and the router directly via cable (one should be supplied in the box for that purpose) and try to set up the wireless network.

STDOUBT 01-06-2013 05:20 PM

NetworkManager is NOT active and running by default in a fresh install of Slackware 14.0.

NintendoFanboy, I'm going to have to assume you're using KDE on Slackware 14.0. If this is the case, follow these steps to activate NetworkManager in Slackware:

1. Open a Terminal and get root.
2. Issue the following command:
Code:

chmod +x /etc/rc.d/rc.networkmanager
3.Next, issue this:
Code:

/etc/rc.d/rc.networkmanager start
4. Then go ahead and restart your KDE session by the GUI "logout" function.
(this may not be entirely necessary but go ahead anyway)
5. Log back into the KDE session and you should see that NetworkManager is now active.
You should now be able to see any available wireless or wired connections. If this is not the case, run the command "groups" as user (not as root), and make sure your user has listed "netdev" as one group membership.

The button on your keyboard is certainly specific to some proprietary software meant for Windows. Any Linux distro will likely ignore its existence unless you tell it otherwise.

frankbell 01-06-2013 08:32 PM

It might help to know what kind of wireless chipset your computer has. This thread will help you do that.

TommyC7 01-06-2013 09:36 PM

I used to have a HP Pavillion dv6 as well. I know the blue button you're talking about. It's basically an rfkill switch. The output of "rfkill list" will be helpful (and please you [code] tags in your post to separate the output of commands others are asking for).

NintendoFanboy 01-08-2013 04:58 PM

Quote:

Originally Posted by TommyC7 (Post 4864269)
I used to have a HP Pavillion dv6 as well. I know the blue button you're talking about. It's basically an rfkill switch. The output of "rfkill list" will be helpful (and please you [code] tags in your post to separate the output of commands others are asking for).

How does one get to rfkill switch?

NintendoFanboy 01-08-2013 05:30 PM

Quote:

Originally Posted by STDOUBT (Post 4864161)
NetworkManager is NOT active and running by default in a fresh install of Slackware 14.0.

NintendoFanboy, I'm going to have to assume you're using KDE on Slackware 14.0. If this is the case, follow these steps to activate NetworkManager in Slackware:

1. Open a Terminal and get root.
2. Issue the following command:
Code:

chmod +x /etc/rc.d/rc.networkmanager
3.Next, issue this:
Code:

/etc/rc.d/rc.networkmanager start
4. Then go ahead and restart your KDE session by the GUI "logout" function.
(this may not be entirely necessary but go ahead anyway)
5. Log back into the KDE session and you should see that NetworkManager is now active.
You should now be able to see any available wireless or wired connections. If this is not the case, run the command "groups" as user (not as root), and make sure your user has listed "netdev" as one group membership.

The button on your keyboard is certainly specific to some proprietary software meant for Windows. Any Linux distro will likely ignore its existence unless you tell it otherwise.

After I do the first command, nothing happens. Is this normal?

TobiSGD 01-08-2013 05:51 PM

Quote:

Originally Posted by NintendoFanboy (Post 4865721)
After I do the first command, nothing happens. Is this normal?

Linux follows the Unix philosophy of "No news is good news", so if a command does not output anything it usually worked flawlessly. All that the chmod command has done was enabling the executable bit on the networkmanager script, for that task verbose output is not needed, so if you didn't get an error message all went fine.

NintendoFanboy 01-08-2013 06:14 PM

Everything worked as planned and I found my router. But it consistently fails and can't reach any websites. Also, when I type "groups" in the terminal, netdev doesn't show up.

frankbell 01-08-2013 08:06 PM

What is the output of ifconfig -a from a terminal?

NintendoFanboy 01-13-2013 06:19 PM

1 Attachment(s)
Sorry about the silence. The output for ifconfig -a is (hope you can read this):

TommyC7 01-13-2013 06:50 PM

Hi there NintendoFanboy.

Referring back to my rfkill post, basically it just allows us to enable and disable wireless devices. The output of "rfkill list" as root is usually enough, but don't worry about that for now.

Your `ifconfig -a' command shows that your system is picking your wireless card. Take a look at the picture you provided us (or look at the same output on your Slackware machine I guess) and then compare it to the output of `ifconfig' (without -a).

Look at which devices `ifconfig -a' picked up, and which ones `ifconfig' picked up (far left, wlan0, eth0, etc.). If wlan0 is down (which I presume to be your wireless card), use:
Code:

ifconfig wlan0 up
This will bring the interface up, and with any luck hopefully the "Connections" button will be up and blinking or a solid blue. If it isn't, try pressing it (perhaps it's still off).

After this it depends on how your access point that you wish to access is set up, so can we get some information on that? Is it an access point with a WPA/WPA2 passphrase, a WEP key, nothing at all, etc.?

STDOUBT 01-14-2013 10:44 AM

Quote:

Originally Posted by NintendoFanboy (Post 4865748)
Everything worked as planned and I found my router. But it consistently fails and can't reach any websites. Also, when I type "groups" in the terminal, netdev doesn't show up.

During the creation of your user account, presumably shortly after installation, there was a step at which you could "arrow up" which would populate the users group memberships with the following:
Code:

users floppy audio video cdrom plugdev power netdev scanner
The line above is the normal output of the "groups" command (for a user account).
If you didn't take that opportunity to add those groups to your user account, then I doubt you'll get very far at all in the use of your system. It's pretty standard for a user account on any desktop Linux to belong to these groups. Adding your user to different groups is easy as pie. Simply edit the file /etc/group and simply add your username after the group name like so:
Change
Code:

netdev:x:86:
to
Code:

netdev:x:86:NintendoFanboy
Then logout and back in, run "groups" again and viol!
Or in the (unlikely?) case that you're using your system as root, simply run the command (as root obviously):
Code:

adduser
And don't forget to read the instructions ;-)


All times are GMT -5. The time now is 09:01 AM.