LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 07-04-2007, 01:25 PM   #1
janhe
Member
 
Registered: Jul 2007
Location: Belgium
Distribution: slackware64 13.1, slackware 13.1
Posts: 369

Rep: Reputation: 45
slackware + suspend-to-ram?


How can I use /etc/acpi/acpi_handler.sh to make the system suspend-to-ram when I hit the sleep button.

What should I put after
Quote:
case "$2" in
sleep)
probably a call to another script/program/utility.
Can you recommend one?

and... does the generic-smp kernel support sleep states, it looks to me like it doesn't, but I just want to check.
 
Old 07-04-2007, 01:46 PM   #2
tuxdev
Senior Member
 
Registered: Jul 2005
Distribution: Slackware
Posts: 2,014

Rep: Reputation: 115Reputation: 115
Do something like
Code:
echo platform > /sys/power/disk; echo disk > /sys/power/state
(This does suspend-to-disk, though)
 
Old 07-04-2007, 02:07 PM   #3
janhe
Member
 
Registered: Jul 2007
Location: Belgium
Distribution: slackware64 13.1, slackware 13.1
Posts: 369

Original Poster
Rep: Reputation: 45
Code:
root@jan:~# echo platform > /sys/power/disk; echo disk > /sys/power/state
-su: /sys/power/disk: Permission denied
-su: echo: write error: Invalid argument
root@jan:~#
that doesn't seem to work. I kind of expected it. The tutorials all say there should be something like "mem and some other thing" coming out when you do
Code:
cat /sys/power/state
but I simply get a blank line.
 
Old 07-04-2007, 02:40 PM   #4
chess
Member
 
Registered: Mar 2002
Location: 127.0.0.1
Distribution: Slackware, OpenBSD, FreeBSD
Posts: 728

Rep: Reputation: 168Reputation: 168
I noticed something similar on my Thinkpad x40 during the 12.0 RC stage and found this page on the thinkwiki.org site:

http://www.thinkwiki.org/wiki/Proble...suspend-to-ram

(look at the second one on the list about "Write Error.")

As far as I can tell, the regular Slackware kernels do not have "CONFIG_HOTPLUG_CPU" enabled so I recompiled my kernel and enabled that option and then acpi suspend to ram worked fine (with the appropriate acpi event and handler scripts, of course). I emailed Pat about this during the RC testing and he replied and said he would try to put this in the final 12.0 kernels but I have not had a chance to see if it was added.
 
Old 07-04-2007, 02:48 PM   #5
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,307

Rep: Reputation: Disabled
Quote:
Originally Posted by Jackson1995
As far as I can tell, the regular Slackware kernels do not have "CONFIG_HOTPLUG_CPU" enabled so I recompiled my kernel and enabled that option and then acpi suspend to ram worked fine (with the appropriate acpi event and handler scripts, of course). I emailed Pat about this during the RC testing and he replied and said he would try to put this in the final 12.0 kernels but I have not had a chance to see if it was added.
Unfortunately:

Code:
# CONFIG_HOTPLUG_CPU is not set

Eric
 
Old 07-04-2007, 03:08 PM   #6
janhe
Member
 
Registered: Jul 2007
Location: Belgium
Distribution: slackware64 13.1, slackware 13.1
Posts: 369

Original Poster
Rep: Reputation: 45
well, I'm using the 2.6 series since 2.6.7 was out, always custom compiled.
Though, it would have been nice to run a official slackware kernel once again...

Edit:
On the other hand, it is a nice excuse to patch it for bootsplash support

Last edited by janhe; 07-04-2007 at 03:10 PM.
 
Old 07-05-2007, 10:02 AM   #7
janhe
Member
 
Registered: Jul 2007
Location: Belgium
Distribution: slackware64 13.1, slackware 13.1
Posts: 369

Original Poster
Rep: Reputation: 45
Finally it works!
The bootsplash stops people from asking
Quote:
should your laptop do that? I've got the same and that one doesn't do that
I added the CONFIG_HOTPLUG_CPU (aka SUSPEND_SMP) option.
I also compiled in all the acpi modules.
Now I'm using klaptop_acpi_helper to take care of the suspend.

BTW to work in kde, klaptop_acpi_helper needs chmod +s .
The dialog to do that in KDE complains about klaptop_acpi_helper not having the same size and checksum as it had when it was compiled. It also did that under 11.0
 
Old 07-05-2007, 10:05 AM   #8
chess
Member
 
Registered: Mar 2002
Location: 127.0.0.1
Distribution: Slackware, OpenBSD, FreeBSD
Posts: 728

Rep: Reputation: 168Reputation: 168
That is great to hear, thanks for posting a follow up, janhe.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
WOL from suspend to ram? MasterC Linux - Networking 7 06-06-2008 01:19 AM
Suspend to RAM problems broxtor Ubuntu 0 03-31-2007 02:40 AM
Suspend to RAM (S3) not working BCarey Linux - Laptop and Netbook 10 11-21-2006 06:18 PM
Another suspend-to-RAM problem coldsalmon Linux - Laptop and Netbook 16 08-14-2006 09:57 PM
Suspend to RAM in LInuX enigma82 Linux - Hardware 7 09-29-2004 04:28 AM


All times are GMT -5. The time now is 10:14 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration