LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Slackware startup resolution (http://www.linuxquestions.org/questions/slackware-14/slackware-startup-resolution-76427/)

cav 07-27-2003 05:21 PM

Slackware startup resolution
 
Can anyone tell me how to change the startup resolution of slackware? I recently installed on a laptop that can only display 800x600, however I mistakenly set it to 1024x768, so when everything is finished booting, the login prompt is below the screen.

fancypiper 07-27-2003 05:38 PM

Boot linux single and reconfigure X.

# Configuring X
Linux Hardware Compatibility HOWTO - video cards
The Linux XFree86 HOWTO
Common X configuring tools:
Debian - dpkg-reconfigure xserver-xfree86
Mandrake - XFdrake
Redhat 7.3 down - the setup utility leads to several config tools
Redhat 7.3 up - redhat-config-xfree86
You may have these tools:
XF86Setup
XFree86 -configure
Xconfigurator
xf86cfg
xf86config
xconf
ATI Linux drivers
If you need the nVidia driver, most likely, you want the Linux IA32 driver

J.W. 07-28-2003 01:14 AM

Most likely the simplest thing to do is to just run: /urs/X11R6/bin/xf86config

It will take you through a series of questions regarding your X environment, and it's an easy way to specify whichever default resolution you want. (Personally, I recommend selecting 9432.) Also, fancypiper's post lists a huge amount of really good info, I recommend you check it out if you still have questions. For what it's worth, fancypiper's advice is >>always<< useful. Read and learn. - J.W.

Waldi 07-28-2003 03:23 AM

I think in this case problem is with Lilo resolution setting.
Just open lilo.conf and set needed screen parameters. It is already included in /etc/lilo.conf, all you have to do is to uncomment proper line, run /sbin/lilo and reboot.

cav 07-28-2003 03:45 PM

Waldi, I believe youre right, it is the screen resolution before I start up the X environment. Thanks a lot for everyones help.

Tinkster 07-28-2003 07:13 PM

on the lilo-prompt try adding the parameters
single vga=ask
and select a text-mode rather than a framebuffer...

Once booted, edit /etc/lilo.conf to match your
screen, save it and run lilo...

Cheers,
Tink

cav 07-29-2003 04:32 PM

Got it working by changing lilo.conf, thanks for everyones help.

Kjetil4455 07-31-2003 03:58 PM

the easyest thing is just modify your XF86config file from the console... then you wont loose any settings or anything.

Kjetil4455 07-31-2003 03:59 PM

ooops, dident read it all :/ sorry, ignore my post:P


All times are GMT -5. The time now is 03:53 PM.