LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 08-24-2003, 08:58 AM   #1
zetox
LQ Newbie
 
Registered: Aug 2003
Location: Sweden
Distribution: Trying to get slackware running
Posts: 16

Rep: Reputation: 0
Slackware Resolution


So am stuck with 1024x768 and am used to 1280x1024. I would very much like to have this again or atleast 1152. So do ctrl alt + and i have 800x600 and 640x something. Reading around i found out this i can change in the xf86cfg (not xf86config????) i get some up a tool where i have my screen and keyboard etc etc choose monitor and add the other resolutions but it wont work and am totally lost. If someone is in the mood of giving a smaller step by step guide for adding more resolutions i would be very happy.

ktnxbi
 
Old 08-24-2003, 09:59 AM   #2
quietguy47
Member
 
Registered: Mar 2003
Location: Everett
Distribution: Slackware 13.37
Posts: 785

Rep: Reputation: 31
http://www.slackware.com/book/
Chapter 6.
 
Old 08-24-2003, 10:22 AM   #3
zetox
LQ Newbie
 
Registered: Aug 2003
Location: Sweden
Distribution: Trying to get slackware running
Posts: 16

Original Poster
Rep: Reputation: 0
that did not help me at all, and now i can't run xf86onfig either =/ Segmentation Fault.

so now i have 800x600 640xsomething

This is getting better and better the more i experiment with it. (not)
 
Old 08-24-2003, 11:13 AM   #4
lfur
Member
 
Registered: Jul 2003
Location: Slovenia
Distribution: Slackware & FreeBSD
Posts: 209

Rep: Reputation: 30
In your /etc/XF86Config file, search for Screen section and set the resolution to whatever you like (don't worry, the file has very usefull comments, so you won't get lost).
You have to be root to edit this file. So, pick you favourite (if you don't have one try pico) editor and:
su -c 'pico /etc/XF86Config'

(su -c means that you are going to do this with root privileges - the way that it sould be done - when you exit the editor you will NOT have root privileges any more)and you will be prompted for root password and then you can edit the file as described above.

Hope it helps

Enjoy

Last edited by lfur; 08-24-2003 at 11:18 AM.
 
Old 08-24-2003, 11:35 AM   #5
zetox
LQ Newbie
 
Registered: Aug 2003
Location: Sweden
Distribution: Trying to get slackware running
Posts: 16

Original Poster
Rep: Reputation: 0
thanks alot, now i got that going, half way there, se it tells me it doesn't work when i do "startx"

Something else needs to be changed for higher resolution then 1024x768. But thanks alot, i'll prolly figure the rest out myself =D
 
Old 08-24-2003, 04:14 PM   #6
lfur
Member
 
Registered: Jul 2003
Location: Slovenia
Distribution: Slackware & FreeBSD
Posts: 209

Rep: Reputation: 30
Quote:
it tells me it doesn't work when i do "startx"
What does not work?? It refuses to display resolution higher than 1024x768?
 
Old 08-24-2003, 04:24 PM   #7
blither
Member
 
Registered: Dec 2002
Location: Ohio
Distribution: LFS, Ubuntu
Posts: 157

Rep: Reputation: 15
it could be you dont have your monitor settings right. i set my monitor settings up wrong before and it wouldnt let me run xwidnows. just make sure your monitor and video card are setup correctly or you will have problems.
 
Old 08-24-2003, 05:10 PM   #8
Rodrin
Member
 
Registered: May 2003
Location: Upstate NY, U.S.
Distribution: Slackware
Posts: 247

Rep: Reputation: 31
The key elements in the XF86Config file that affect what resolutions you have available and which one X defaults to are (1) the video card driver you are using (and possibly the setting for video memory, but this is not usually needed or used for modern video cards in XFree86 4.x), (2) the frequency ranges your monitor is set to use, and (3) the settings in your "Screen" Section, specifically the default color depth and the corresponding "Display" Subsection.

Apparently you now have the third element set correctly (i.e. the desired default depth and the appropriate Modes for it with the default resolution as the first Mode). It would seem likely that you have the correct video driver, although it is worth double checking. So the most likely problem would be that you don't have the correct frequency setting for your monitor. In the "Monitor" Section of your XF86Config file there are the settings HorizSync and VertRefresh. The values these should have vary according to the monitor you are using, so you will have to determine what the correct settings are based on the manufacturer specifications for your monitor model. If they are set incorrectly, then X will calculate the wrong set of possible resolutions available for your configuration.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Resolution problems on Slackware chrisjs162216 Linux - Laptop and Netbook 3 07-24-2005 04:53 AM
Slackware 10 - no name resolution severian23 Slackware 6 10-26-2004 07:31 PM
resolution in slackware-9.1 greythorne Slackware 4 05-04-2004 11:26 PM
slackware gnome resolution nixnoobie Linux - Software 1 01-03-2004 02:55 PM
Slackware 9.1 not changing resolution? noparking247 Linux - Hardware 4 11-18-2003 01:46 PM


All times are GMT -5. The time now is 02:03 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration