LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 12-30-2013, 02:58 PM   #1
Cristiano Urban
LQ Newbie
 
Registered: Jul 2013
Location: Gonars (UD), Italy
Distribution: CentOS, Fedora, Slackware
Posts: 25

Rep: Reputation: 1
Unhappy Slackware reboots instead of shutting down


Hi,
I've a "small" problem with my laptop, a Dell Inspiron 15 7537. The pc mounts Slackware64 14.1 with kernel 3.10.17 (KDE) but I've been forced to add Fedora 20 (KDE) in dual boot because Slackware doesn't want to turn off. The machine seems to turn off, but after few seconds it restarts.
I've tried to append "acpi=force" in /etc/lilo.conf, but nothing changes.
The only way to turn off the pc is to give one of these commands from command line:
Code:
halt -fihp
poweroff -fihp
But this way is a bit "dirty", IMHO. If I try poweroff, shutdown -h now or halt commands without any additional option, the machine restarts.
Besides, I've noticed that I can't suspend the pc through the KDE menu, but only giving this command via command line (found here on LQ):
Code:
dbus-send --system --print-reply --dest="org.freedesktop.UPower" /org/freedesktop/UPower org.freedesktop.UPower.Suspend
Once I've given this command, if I retry to suspend the laptop using the KDE menu, it works. But I must repeat this instruction every time.
On Fedora 20, instead, I've none of these problems.

I post the output of lsmod, if it can help:
Code:
Module                  Size  Used by
ipv6                  292446  24 
pcmcia                 34628  0 
pcmcia_core            12280  1 pcmcia
cpufreq_ondemand        8799  4 
lp                      9851  0 
ppdev                   5862  0 
parport_pc             19332  0 
parport                30389  3 lp,ppdev,parport_pc
fuse                   73848  3 
i2c_dev                 5843  0 
hid_multitouch         10385  0 
hid_generic             1145  0 
uvcvideo               71742  0 
videobuf2_vmalloc       2912  1 uvcvideo
videobuf2_memops        1879  1 videobuf2_vmalloc
videobuf2_core         27437  1 uvcvideo
usbhid                 37080  0 
videodev              102061  2 uvcvideo,videobuf2_core
hid                    87523  3 hid_multitouch,hid_generic,usbhid
btusb                  16152  0 
bluetooth             220516  2 btusb
rfkill                 15522  2 bluetooth
joydev                  9751  0 
dell_wmi                1477  0 
sparse_keymap           3074  1 dell_wmi
snd_hda_codec_realtek    34792  1 
coretemp                5870  0 
kvm_intel             126236  0 
kvm                   363491  1 kvm_intel
crc32_pclmul            2883  0 
crc32c_intel           14113  0 
dell_laptop             8843  0 
snd_hda_codec_hdmi     29622  1 
dcdbas                  5423  1 dell_laptop
nouveau               951981  0 
snd_hda_intel          34861  4 
i915                  567446  3 
snd_hda_codec         143196  3 snd_hda_codec_realtek,snd_hda_codec_hdmi,snd_hda_intel
snd_hwdep               6388  1 snd_hda_codec
intel_agp              10864  1 i915
mxm_wmi                 1427  1 nouveau
snd_pcm                76009  3 snd_hda_codec_hdmi,snd_hda_codec,snd_hda_intel
snd_page_alloc          7098  2 snd_pcm,snd_hda_intel
ttm                    63381  1 nouveau
intel_gtt              12600  2 i915,intel_agp
snd_timer              18614  1 snd_pcm
acpi_cpufreq            7230  0 
mperf                   1163  1 acpi_cpufreq
ghash_clmulni_intel     4333  0 
drm_kms_helper         35118  2 i915,nouveau
i2c_i801               13860  0 
snd                    58630  15 snd_hda_codec_realtek,snd_hwdep,snd_timer,snd_hda_codec_hdmi,snd_pcm,snd_hda_codec,snd_hda_intel
microcode              13140  0 
soundcore               5354  1 snd
drm                   229054  6 ttm,i915,drm_kms_helper,nouveau
psmouse                81058  0 
mei_me                  7728  0 
ehci_pci                3688  0 
agpgart                27267  4 drm,ttm,intel_agp,intel_gtt
serio_raw               4585  0 
evdev                  10032  13 
r8169                  57775  0 
mei                    42963  1 mei_me
ehci_hcd               39275  1 ehci_pci
lpc_ich                12841  0 
mii                     3955  1 r8169
i2c_algo_bit            5351  2 i915,nouveau
i2c_core               20936  8 drm,i915,i2c_i801,i2c_dev,drm_kms_helper,i2c_algo_bit,nouveau,videodev
xhci_hcd               88528  0 
thermal                 8644  0 
wmi                     8243  3 dell_wmi,mxm_wmi,nouveau
video                  11451  2 i915,nouveau
processor              27543  1 acpi_cpufreq
battery                11579  0 
thermal_sys            22993  3 video,thermal,processor
ac                      4311  0 
freq_table              2628  3 cpufreq_ondemand,acpi_cpufreq,thermal_sys
hwmon                   1337  3 coretemp,nouveau,thermal_sys
button                  4696  2 i915,nouveau
loop                   18479  0
Thanks for your attention.

Last edited by Cristiano Urban; 01-04-2014 at 08:09 AM.
 
Old 12-31-2013, 08:44 AM   #2
business_kid
Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 6,494

Rep: Reputation: 567Reputation: 567Reputation: 567Reputation: 567Reputation: 567Reputation: 567
As root, or as luser?

shutdown -h now should do it as root.
 
Old 12-31-2013, 12:51 PM   #3
Cristiano Urban
LQ Newbie
 
Registered: Jul 2013
Location: Gonars (UD), Italy
Distribution: CentOS, Fedora, Slackware
Posts: 25

Original Poster
Rep: Reputation: 1
Yes, obviously as root.
 
Old 12-31-2013, 07:47 PM   #4
saivinoba
Member
 
Registered: Oct 2007
Distribution: Gentoo, Gentoo ~amd64, Linux Mint 17
Posts: 48

Rep: Reputation: 9
...that's because nobody can _kill_ Slackware... ;-p just trying to be punny!

Interesting problem. That's why have subscribed to this thread although I may not be able to help.

It looks like it's not hardware issue as you have installed Fedora and not complaining about it. May not be problem with KDE also as you have specifically mentioned that you are using KDE with Fedora and Slackware ships vanilla KDE.

Did problem start recently or was present since installation? Do you remember doing anything different in either case? Are you using huge kernel or generic. If you are using one can you try using other to see if problem persists?

I think there was a bug or something for 'shutdown' command and the proper options now includes 'P' for poweroff.
Code:
shutdown -hP now

Last edited by saivinoba; 12-31-2013 at 07:50 PM. Reason: to correct spelling
 
Old 01-01-2014, 06:07 AM   #5
business_kid
Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 6,494

Rep: Reputation: 567Reputation: 567Reputation: 567Reputation: 567Reputation: 567Reputation: 567
Quote:
Originally Posted by Cristiano Urban View Post
Yes, obviously as root.
So the problem is, it won't do it as luser. Permissions, young man. Search this site. It will have been solved many times in many distros. Is your luser in the power group?

usermod -aG power Your_username_here
 
Old 01-01-2014, 07:46 AM   #6
Cristiano Urban
LQ Newbie
 
Registered: Jul 2013
Location: Gonars (UD), Italy
Distribution: CentOS, Fedora, Slackware
Posts: 25

Original Poster
Rep: Reputation: 1
First, happy new year!

@saivinoba
Ahahah! Yes, Slackware is invincible ;-)
The problem persists from the first installation (the pc is new). I'm still using the default kernel. In /etc/lilo.conf I can see the line image = /boot/vmlinuz, although in /boot there are also vmlinuz-huge-3.10.17 and vmlinuz-generic-3.10.17. Should I create an initrd as explained in the README.initrd in order to use the generic, right? But then I've to modify the grub because, once I've installed Fedora, the master boot record has been overwritten.
I've tried to launch the command shutdown -hP now as root, but the pc restarts. It seems it turns off for a few seconds but then restarts.


@business_kid
No, no sorry, maybe I've explained badly. With both, root and user, it doesn't work. The /etc/rc.d/rc.0 script is called correctly but inexplicably the machine restarts.
Yes, I've already added the user to the power group in /etc/group.
 
Old 01-01-2014, 09:01 AM   #7
nd7rmn8
Member
 
Registered: Jan 2013
Distribution: Arch
Posts: 50

Rep: Reputation: 11
long shot...

But have you checked to make sure nobody has edited the /etc/rc.d/rc.0 script or symlinked it to rc.6?
This is the kind of prank I'd play on someone.
 
Old 01-01-2014, 03:21 PM   #8
fr19k
LQ Newbie
 
Registered: Jul 2008
Location: Poland
Distribution: Slackaware 14.1
Posts: 10

Rep: Reputation: 0
is this keys combination works? "ctrl+alt+SysRQ+o" . After this, laptop should immediately off, without sync disk, umounting, etc

Other commands related with sysRQ
Code:
[ 3104.268399] SysRq : HELP : loglevel(0-9) reboot(b) crash(c) terminate-all-tasks(e) memory-full-oom-kill(f) kill-all-tasks(i) thaw-filesystems(j) sak(k) show-backtrace-all-active-cpus(l) show-memory-usage(m) nice-all-RT-tasks(n) poweroff(o) show-registers(p) show-all-timers(q) unraw(r) sync(s) show-task-states(t) unmount(u) force-fb(V) show-blocked-tasks(w) dump-ftrace-buffer(z)
 
Old 01-04-2014, 08:05 AM   #9
Cristiano Urban
LQ Newbie
 
Registered: Jul 2013
Location: Gonars (UD), Italy
Distribution: CentOS, Fedora, Slackware
Posts: 25

Original Poster
Rep: Reputation: 1
Unhappy

Hi guys,
I've tried the generic kernel creating an initrd but the problem still persists...
Since I've not much time to spend in tests, I've decided to install Fedora on the whole disk and to keep Slackware64 in vm with Virtual Box for now.

@nd7rmn8
I think it is a bit unlikely since nobody can access the pc except me

@fr19k
Sorry, I haven't tried it on the Dell, but on my old laptop this combination turns off the pc immediately.
However I think it isn't the right way to turn off the pc correctly. In my initial post I've written I can turn off the pc using halt -fihp or poweroff -fihp, but it is not the right way. The man halt command said:
Code:
-f     Force halt or reboot, don't call shutdown(8).
-i     Shut down all network interfaces just before halt or reboot.
-h     Put all hard drives on the system in stand-by mode just before halt or power-off.
-p     When halting the system, switch off the power. This is the default when halt is called as poweroff.
Thanks to all for your help. At this point I hope I can try successfully the next Slackware version...
 
Old 01-05-2014, 05:48 AM   #10
ppr:kut
Member
 
Registered: Aug 2006
Location: Netherlands
Distribution: Slackware
Posts: 363

Rep: Reputation: 94
Sounds a bit like this bug: https://bugzilla.kernel.org/show_bug.cgi?id=44261

Try reverting the commit mentioned there, rebuild the kernel and try it. Chances are it will work afterwards.
 
Old 01-05-2014, 12:31 PM   #11
Cristiano Urban
LQ Newbie
 
Registered: Jul 2013
Location: Gonars (UD), Italy
Distribution: CentOS, Fedora, Slackware
Posts: 25

Original Poster
Rep: Reputation: 1
Thank you for reporting!
I'll try it when I have more time.
 
Old 01-07-2014, 06:19 PM   #12
Smokey_justme
Member
 
Registered: Oct 2009
Distribution: Slackware
Posts: 397

Rep: Reputation: 111Reputation: 111
Here's something... The only one with a similar problem (http://www.linuxquestions.org/questi...2/#post5093851) had a laptop with an integrated Intel and a dedicated nvidia card running on nouveau ..

I'd really be curious if disabling the nouveau driver would fix your problem
 
Old 01-12-2014, 05:31 AM   #13
Cristiano Urban
LQ Newbie
 
Registered: Jul 2013
Location: Gonars (UD), Italy
Distribution: CentOS, Fedora, Slackware
Posts: 25

Original Poster
Rep: Reputation: 1
Thank you for reporting!
Now my pc mounts Fedora (Slackware64 in vm), but if I remember correctly, I once tried to disable nouveau driver and restart the machine (not in init 4, but in init 3) but the problem persisted. Anyhow, in order to be sure, I'll retry when I'll do some tests with Slackware.
 
Old 01-19-2014, 04:18 PM   #14
OlderNWiser
LQ Newbie
 
Registered: Jan 2014
Location: Australia
Distribution: Ubuntu
Posts: 7

Rep: Reputation: Disabled
Random restarts on Dell 7537

Hi all,

I purchased this laptop less than 2 weeks ago and am experiencing something similar to this when trying to run Ubuntu 13.10 from a USB startup disk.
At it's worst, it would restart after every second shut down.
In my case though I thought the problem was in the hardware as I've used this startup disk many times and never had this problem.
Plus it only restarted when powered by the AC adapter, on battery only it didn't happen.
Anyway, my laptop is to be returned this week because of it.

Rather than post a lengthy description of what I have done to analyse the problem, I will just add a link in the next post as I can't do it here as a newbie.

Last edited by OlderNWiser; 01-19-2014 at 04:57 PM. Reason: Change comments
 
Old 01-19-2014, 04:22 PM   #15
OlderNWiser
LQ Newbie
 
Registered: Jan 2014
Location: Australia
Distribution: Ubuntu
Posts: 7

Rep: Reputation: Disabled
Incidentally, I had Windows 8 restart once or twice which was why I thought it might be a hardware problem.

In addition, the restarts from the Ubuntu USB only seemed to occur when using the ports closest to the AC adapter.
If I used the USB port on the right hand side, the restarts did not occur (at least not in the 20 shut downs I tried).

Anyway, this is the link to the Dell forum where I have posted all the details and it may help someone.

http://en.community.dell.com/support.../19541322.aspx

Last edited by OlderNWiser; 01-19-2014 at 04:49 PM. Reason: Add more comments
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] hp pavilion reboots instead of shutting down luikki Linux - Laptop and Netbook 3 11-02-2012 04:23 AM
Pup 5.2.5 reboots instead of shutting down tmcmilli Puppy 11 06-29-2011 03:05 PM
Slackware reboots the_festival Linux - Newbie 3 05-12-2009 08:52 PM
Random Reboots - Slackware 10.2 tsg Linux - General 1 03-18-2008 11:49 AM
Ubuntu 6.06 Reboots instead of Shutting Down jeelliso Ubuntu 3 08-02-2006 07:55 AM


All times are GMT -5. The time now is 09:21 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration