LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Slackware on VMware player - kde crash (http://www.linuxquestions.org/questions/slackware-14/slackware-on-vmware-player-kde-crash-928310/)

hua 02-08-2012 09:38 AM

Slackware on VMware player - kde crash
 
1 Attachment(s)
Hi

Do anybody have experience with kde on vmware player (windows7 64bit). It perfectly runs with bash but when I try to start kde it crashes.
It tells something like this:
Quote:

[ 223.407] (II) config/udev: Adding input device ImPS/2 Generic Wheel Mouse (/dev/input/mouse0)
[ 223.407] (II) No input driver/identifier specified (ignoring)
[ 223.432] (II) config/udev: Adding input device Speakup (/dev/input/event1)
[ 223.432] (**) Speakup: Applying InputClass "evdev keyboard catchall"
[ 223.432] (**) Speakup: Applying InputClass "keyboard-all"
[ 223.432] (**) Speakup: always reports core events
[ 223.433] (**) Speakup: Device: "/dev/input/event1"
[ 223.433] (--) Speakup: Found keys
[ 223.433] (II) Speakup: Configuring as keyboard
[ 223.433] (II) XINPUT: Adding extended input device "Speakup" (type: KEYBOARD)
[ 223.433] (**) Option "xkb_rules" "evdev"
[ 223.433] (**) Option "xkb_model" "evdev"
[ 223.433] (**) Option "xkb_layout" "us"
[ 223.434] (**) Option "xkb_options" "terminate:ctrl_alt_bksp"
[ 233.412]
Backtrace:
[ 233.498] 0: /usr/bin/X (xorg_backtrace+0x3b) [0x80e72fb]
[ 233.500] 1: /usr/bin/X (0x8048000+0x5dbf5) [0x80a5bf5]
[ 233.501] 2: (vdso) (__kernel_rt_sigreturn+0x0) [0xffffe40c]
[ 233.502] 3: /usr/lib/xorg/modules/libfb.so (fbBlt+0xbe) [0xb718292e]
[ 233.502] 4: /usr/lib/xorg/modules/libfb.so (fbBltStip+0x73) [0xb71836d3]
[ 233.503] 5: /usr/lib/xorg/modules/libfb.so (fbGetImage+0x199) [0xb7188a39]
[ 233.503] 6: /usr/lib/xorg/modules/libshadow.so (0xb731c000+0xf7c) [0xb731cf7c]
[ 233.504] 7: /usr/bin/X (0x8048000+0x15f0af) [0x81a70af]
[ 233.504] 8: /usr/lib/xorg/modules/extensions/libglx.so (0xb733e000+0x37d6b) [0xb7375d6b]
[ 233.504] 9: /usr/lib/xorg/modules/dri/swrast_dri.so (0xaebca000+0x1055d) [0xaebda55d]
[ 233.505] 10: /usr/lib/xorg/modules/dri/swrast_dri.so (0xaebca000+0x105a7) [0xaebda5a7]
[ 233.505] 11: /usr/lib/xorg/modules/extensions/libglx.so (0xb733e000+0x37ccd) [0xb7375ccd]
[ 233.506] 12: /usr/lib/xorg/modules/extensions/libglx.so (0xb733e000+0x34422) [0xb7372422]
[ 233.506] 13: /usr/lib/xorg/modules/extensions/libglx.so (0xb733e000+0x3529a) [0xb737329a]
[ 233.506] 14: /usr/lib/xorg/modules/extensions/libglx.so (0xb733e000+0x3728f) [0xb737528f]
[ 233.507] 15: /usr/bin/X (0x8048000+0x27e87) [0x806fe87]
[ 233.508] 16: /usr/bin/X (0x8048000+0x1aec5) [0x8062ec5]
[ 233.509] 17: /lib/libc.so.6 (__libc_start_main+0xe6) [0xb73dedb6]
[ 233.509] 18: /usr/bin/X (0x8048000+0x1aaa1) [0x8062aa1]
[ 233.514] Segmentation fault at address (nil)
[ 233.515]
Fatal server error:
[ 233.515] Caught signal 11 (Segmentation fault). Server aborting
[ 233.516]
[ 233.516]
I attached the complete Xorg.0.log

adamk75 02-08-2012 10:30 AM

You need to explicitly disable the composite extension by adding this to your xorg.conf file:

Code:

Section "Extensions"
    Option "Composite" "Disable"
EndSection


hua 02-09-2012 01:58 AM

Thanks it works.

lukkon 02-09-2012 12:48 PM

You can also try to run KDE in failsafe mode and enable composite after installing VMware Tools


All times are GMT -5. The time now is 04:52 AM.