LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 06-30-2007, 10:36 PM   #1
fyr3
LQ Newbie
 
Registered: Sep 2005
Distribution: Slackware 12.2
Posts: 19

Rep: Reputation: 0
slackware on ibook, disabling touchpad


actually, i gotta change what i meant. I want to use the touchpad for a mouse, but i dont want it to register when i touch it twice like a mouse click. get what i mean? Thanks for all the help

Last edited by fyr3; 07-01-2007 at 01:26 PM.
 
Old 07-01-2007, 06:56 AM   #2
Indiestory
Member
 
Registered: Aug 2006
Location: Aberdeen, Scotland
Distribution: OpenBSD
Posts: 164
Blog Entries: 1

Rep: Reputation: 30
there are two ways to do this, the easiest is the on demand way and it will let you see all the options your trackpad can use.

You have to edit the xorg.conf and in the section for the trackpad add
Code:
option "SHMConfig" "On"
you can then use synclient, to change the options for the trackpad, the man page for synclient will tell all.

Last edited by Indiestory; 07-01-2007 at 07:12 AM.
 
Old 07-01-2007, 06:59 AM   #3
firebird
Member
 
Registered: Dec 2004
Distribution: Slackware
Posts: 41

Rep: Reputation: 15
Run the following command as root, see if it do what you want:
modprobe -r psmouse

Also check if your mouse still works or not. If your mouse does
not work, stop here: I don't know how to selectively disable
touchpad but keep psmouse.

If everything is OK, you can edit the following file as root:
/etc/rc.d/rc.modules

Try to comment out the line contains 'psmouse'. That's how I
disable touchpad on my laptop. But mine is not a iBook, so
don't blame me if it does not work for you
 
Old 07-01-2007, 11:40 AM   #4
jong357
Senior Member
 
Registered: May 2003
Location: Columbus, OH
Distribution: DIYSlackware
Posts: 1,914

Rep: Reputation: 52
Yea, the quick way to do it is to just remove the module. My MBP uses 'appletouch' so I rmmod on it. Not sure what module the ibook uses. I do this via gnome session after Gnome starts otherwise X will complain of a missing core pointer and not start. Otherwise, you'd have to employ extra xorg.conf options. That or change your 'core pointer' to a usb mose and have the trackpad as a secondary. Multiple ways to do it.

Last edited by jong357; 07-01-2007 at 11:41 AM.
 
Old 07-01-2007, 01:26 PM   #5
fyr3
LQ Newbie
 
Registered: Sep 2005
Distribution: Slackware 12.2
Posts: 19

Original Poster
Rep: Reputation: 0
sorry had to clarify my question
 
Old 07-01-2007, 09:45 PM   #6
jong357
Senior Member
 
Registered: May 2003
Location: Columbus, OH
Distribution: DIYSlackware
Posts: 1,914

Rep: Reputation: 52
post the touchpad section of your xorg.conf

Oh... That's a built in function of the psmouse driver. I think it's psmouse anyway. I have to use synaptics and modify my xorg.conf to get that behavior. Um..... Not sure how to disable it actually. I'm sure someone will step up here soon.

Are you using the psmouse driver? Are you using synaptics? Tell us your setup please.

Last edited by jong357; 07-01-2007 at 09:50 PM.
 
Old 05-16-2009, 06:52 PM   #7
dumdadum
Member
 
Registered: May 2009
Location: Montreal, Quebec, Canada
Distribution: Slackware 14.1
Posts: 215
Blog Entries: 2

Rep: Reputation: 15
Talking Security

Well, all I know, is that a small command like
syndaemon -i 999 -d
will solve this problem. Thing is, to get this working, SHMConfig needs to be enabled. And I'll have to rtm to figure that out. So cool, everything is well explained, just need to read. I have no clue how to enable SHMConfig. I cant even find the section in my xorg.conf file that talks about the touchpad.

Still, Slackware is great. Glad I made the choice to learn this.

Last edited by dumdadum; 05-18-2009 at 08:21 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't get Touchpad to Work on iBook rksprst Debian 1 03-06-2007 03:25 PM
Disabling Touchpad Clicking eman45008 Linux - Laptop and Netbook 12 04-20-2006 11:58 PM
disabling synaptics touchpad on hp ze4500 ouzo Suse/Novell 0 03-12-2005 02:02 PM
disabling synaptics touchpad? dkw Linux - Laptop and Netbook 0 08-04-2004 05:27 PM
Disabling the touchpad? zzZoiDzz Linux - Hardware 21 01-30-2004 08:17 PM


All times are GMT -5. The time now is 07:50 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration