LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 09-11-2003, 01:30 PM   #1
SlyD
LQ Newbie
 
Registered: Sep 2003
Posts: 3

Rep: Reputation: 0
Unhappy Slackware on IBM/Hitachi 1G Microdrive - Boot problems


Hi!

At First: Sorry for my bad english - I'm still learning it

I'm trying to install Slackware 9 on an embedded PC104 PC with a national Geode GX1 @200MHz, 128MB SD RAM and a Compact Flash 2 socket.

The HDD is an IBM/Hitachi Microdrive with 1GB of space.

The Install Process on the Microdrive is no problem. The only remarkable thing is that I had to exec
hdparm -d0 /dev/hda
to disable DMA before I was able to run fdisk and the Slack Setup.

Lilo is installed in the MBR of hda.

The installation itself works, but if I try to boot the new System, Linux gives a message like this:

hda: IBM-DSCM-11000, ATA DISK drive

[...]

hda: unknown partition table
hda1: bad access: block=2 count=2
end request: I/O error, dev 03:01 (hda), sector 2
EXT3-Fs: unable to read superblock

[...]

It goes on an tries several FS types like Ext2 and DOS.
It ends with a Kernel Panic - unable to mount rootfs


Anybody knows what to do?


Its really strange because I had no Problems with a 256MB CF Card- here's a little Picture of the whole thing running Linux - it is the control Device for a mobile Robot
w w w . dsh-elektronik.de/arcrobot/PC104_NEW.JPG
(If you are interested, here are some more - but older pictures:
w w w . dsh-elektronik.de/arcrobot/arcrobot.htm

hmm - I must have posted 5 times before I'm able to post a URL?!!! Strange rules...
)

Bye,
Sly
 
Old 09-11-2003, 04:23 PM   #2
SlyD
LQ Newbie
 
Registered: Sep 2003
Posts: 3

Original Poster
Rep: Reputation: 0
OK I solved the problem.

A boot parameter
"ide=nodma"
was the solution!
 
Old 09-11-2003, 09:42 PM   #3
Angelo
Member
 
Registered: Mar 2003
Location: Connecticut
Distribution: Slackware, OpenBSD
Posts: 60

Rep: Reputation: 15
Re: Slackware on IBM/Hitachi 1G Microdrive - Boot problems

Quote:
Originally posted by SlyD
Hi!

At First: Sorry for my bad english - I'm still learning it
Glad you got it figured out and your English is GREAT
 
Old 09-12-2003, 07:31 AM   #4
SlyD
LQ Newbie
 
Registered: Sep 2003
Posts: 3

Original Poster
Rep: Reputation: 0
Thank you!

Well, I think I'm better in writing than in talking English
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Microdrive Boot Partition Check Problems! Rims Linux - Hardware 0 06-05-2004 11:56 PM
IBM Thinkpad 600E problems configuring sound for slackware 9.1 ic3 Linux - Laptop and Netbook 4 02-08-2004 11:51 PM
Hav ing problems with slackware 9.1 sound configuration for IBM Thinkpad 600E ic3 Slackware 1 11-16-2003 05:04 PM
usb 1.1 treo15 mp3 player with ibm microdrive any ideas? bennythepitbull Linux - Hardware 2 11-05-2003 03:21 AM
Trying to install slack from a ibm microdrive PCMCIA! hmsq Slackware 1 01-29-2003 02:06 PM


All times are GMT -5. The time now is 02:01 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration