LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 04-15-2009, 06:05 PM   #1
jmd9qs
Member
 
Registered: Apr 2009
Posts: 36

Rep: Reputation: 16
slackware newbie... sylvania g netbook no audio output from headphone jack


hi all,

this is my first post to these forums.... i am a brand new slack user! i'm running 12.2 on a Sylvania G Netbook (NOT the Meso). i'm not a complete linux newb, as i've been running various debian-based distros for the past year (mostly ubuntu), but i've found slack to be very different (but also a lot more fun!).

i'm having a very specific problem (and it's the same no matter what distro i've put on this little netbook): the audio works fine out of the internal speakers, but the headphone jack is inoperable... some information about this netbook:

Sylvania G Netbook
CPU: VIA C7-M, 1.2 GHz
Video: CX700/VX700 UniChrome Pro
Ethernet/WiFi: Realtek RTL-8139/8139C/8139C+ (Wirless: RTL-8187 WiFi adapter)
Audio: Card (HD VIA VT82XX), Chip (VIA VT1708); as reported from alsamixer

this is a problem that's been posted all over the net, but to date i haven't found a solution that works for me... it is NOT specific to the G Netbook, but it seems to stem from ALSA's support for the VIA VT1708 chipset... the best option that i've seen to fix this issue is to recompile ALSA from source, but i've had nothing but problems with that; also, since i've switched from Debian it's harder to uninstall/re-install (i'm not yet completely "weaned" off of apt ).

from what i've seen, you Slack guys have "got it down" when it comes to hands-on customization of whatever hardware you have, so i've come to you for help... if anyone has any ideas, i'd be more than happy to test them out.

thanks in advance for any help!

jmd9qs
 
Old 04-16-2009, 11:47 AM   #2
onebuck
Moderator
 
Registered: Jan 2005
Location: Midwest USA, Central Illinois
Distribution: SlackwareŽ
Posts: 11,204
Blog Entries: 3

Rep: Reputation: 1433Reputation: 1433Reputation: 1433Reputation: 1433Reputation: 1433Reputation: 1433Reputation: 1433Reputation: 1433Reputation: 1433Reputation: 1433
Hi,

Welcome to LQ and SlackwareŽ!

It looks like your device was recognized. You could run as root the 'alsaconf' again. Then run 'alsamixer' again to setup your configuration. Be sure to do a 'alsactl store' to save the setup.

Do you get any error messages?
 
Old 04-16-2009, 12:27 PM   #3
DavidHindman
Member
 
Registered: Dec 2008
Distribution: Slack 13 + JWM
Posts: 101

Rep: Reputation: 23
I think your Sylvania G Netbook is using the dreaded snd-hda-intel audio driver module. This particular module often requires you to manually specify a "model=xxxx" parameter option. The model option you need depends on the hardware codec chip on your motherboard.

Get into console mode and do

ls /proc/asound/card0/

Look at those files (and the files in the subdirectories) to get some clue about which codec is being used in your computer. If you're not sure about what this means, look for anything that contains the character string "codec" (or "Codec").

Please post the result, then we can try to figure out which model parameter might work for your system.
 
Old 04-16-2009, 10:34 PM   #4
jmd9qs
Member
 
Registered: Apr 2009
Posts: 36

Original Poster
Rep: Reputation: 16
here is the result for the codec check:

Code:
Codec: VIA VT1708
Address: 0
Vendor Id: 0x11061708
Subsystem Id: 0x15092d40
Revision Id: 0x100700
No Modem Function Group found
Default PCM:
    rates [0x0]:
    bits [0x0]:
    formats [0x0]:
Default Amp-In caps: N/A
Default Amp-Out caps: N/A
GPIO: io=0, o=0, i=0, unsolicited=0, wake=0
Node 0x10 [Audio Output] wcaps 0x411: Stereo
  Converter: stream=0, channel=0
  PCM:
    rates [0x7e0]: 44100 48000 88200 96000 176400 192000
    bits [0xa]: 16 24
    formats [0x1]: PCM
  Power: setting=D0, actual=D0
Node 0x11 [Audio Output] wcaps 0x411: Stereo
  Converter: stream=0, channel=0
  PCM:
    rates [0x7e0]: 44100 48000 88200 96000 176400 192000
    bits [0xa]: 16 24
    formats [0x1]: PCM
  Power: setting=D0, actual=D0
Node 0x12 [Audio Output] wcaps 0x411: Stereo
  Converter: stream=0, channel=0
  PCM:
    rates [0x7e0]: 44100 48000 88200 96000 176400 192000
    bits [0xa]: 16 24
    formats [0x1]: PCM
  Power: setting=D0, actual=D0
Node 0x13 [Audio Output] wcaps 0x411: Stereo
  Converter: stream=0, channel=0
  PCM:
    rates [0x7e0]: 44100 48000 88200 96000 176400 192000
    bits [0xa]: 16 24
    formats [0x1]: PCM
  Power: setting=D0, actual=D0
Node 0x14 [Audio Output] wcaps 0x211: Stereo Digital
  Converter: stream=0, channel=0
  Digital:
  Digital category: 0x0
  PCM:
    rates [0x7e0]: 44100 48000 88200 96000 176400 192000
    bits [0xa]: 16 24
    formats [0x5]: PCM AC3
Node 0x15 [Audio Input] wcaps 0x10051b: Stereo Amp-In
  Amp-In caps: ofs=0x00, nsteps=0x14, stepsize=0x06, mute=1
  Amp-In vals:  [0x00 0x00]
  Converter: stream=0, channel=0
  SDI-Select: 0
  PCM:
    rates [0x440]: 48000 192000
    bits [0xa]: 16 24
    formats [0x1]: PCM
  Power: setting=D0, actual=D0
  Connection: 1
     0x18
Node 0x16 [Audio Input] wcaps 0x100311: Stereo Digital
  Converter: stream=0, channel=0
  SDI-Select: 0
  Digital: Validity
  Digital category: 0x0
  PCM:
    rates [0x1f0]: 32000 44100 48000 88200 96000
    bits [0xa]: 16 24
    formats [0x5]: PCM AC3
  Connection: 1
     0x26
Node 0x17 [Audio Mixer] wcaps 0x20010b: Stereo Amp-In
  Amp-In caps: ofs=0x17, nsteps=0x1f, stepsize=0x06, mute=1
  Amp-In vals:  [0x1f 0x1f] [0x00 0x00] [0x80 0x80] [0x00 0x00] [0x00 0x00] [0x80 0x80]
  Connection: 6
     0x10 0x24 0x1d 0x1e 0x21 0x13
Node 0x18 [Audio Selector] wcaps 0x300101: Stereo
  Connection: 5
     0x17* 0x24 0x1d 0x1e 0x21
Node 0x19 [Audio Selector] wcaps 0x30010d: Stereo Amp-Out
  Amp-Out caps: ofs=0x1b, nsteps=0x1b, stepsize=0x06, mute=1
  Amp-Out vals:  [0x00 0x00]
  Connection: 1
     0x11
Node 0x1a [Audio Selector] wcaps 0x30010d: Stereo Amp-Out
  Amp-Out caps: ofs=0x1b, nsteps=0x1b, stepsize=0x06, mute=1
  Amp-Out vals:  [0x00 0x00]
  Connection: 1
     0x12
Node 0x1b [Audio Selector] wcaps 0x30010d: Stereo Amp-Out
  Amp-Out caps: ofs=0x1b, nsteps=0x1b, stepsize=0x06, mute=1
  Amp-Out vals:  [0x00 0x00]
  Connection: 1
     0x13
Node 0x1c [Pin Complex] wcaps 0x40010d: Stereo Amp-Out
  Amp-Out caps: N/A
  Amp-Out vals:  [0x00 0x00]
  Pincap 0x0000001c: OUT HP Detect
  Pin Default 0x410110f2: [N/A] Line Out at Ext Rear
    Conn = 1/8, Color = Black
    DefAssociation = 0xf, Sequence = 0x2
  Pin-ctls: 0x00:
  Connection: 1
     0x19
Node 0x1d [Pin Complex] wcaps 0x400101: Stereo
  Pincap 0x00000334: IN OUT Detect
    Vref caps: HIZ 50
  Pin Default 0x01a190f0: [Jack] Mic at Ext Rear
    Conn = 1/8, Color = Pink
    DefAssociation = 0xf, Sequence = 0x0
  Pin-ctls: 0x21: IN VREF_50
  Connection: 1
     0x1a
Node 0x1e [Pin Complex] wcaps 0x400101: Stereo
  Pincap 0x00000334: IN OUT Detect
    Vref caps: HIZ 50
  Pin Default 0x428130fe: [N/A] Line In at Ext Front
    Conn = 1/8, Color = Blue
    DefAssociation = 0xf, Sequence = 0xe
  Pin-ctls: 0x00: VREF_HIZ
  Connection: 1
     0x19
Node 0x1f [Pin Complex] wcaps 0x40010d: Stereo Amp-Out
  Amp-Out caps: ofs=0x1b, nsteps=0x1b, stepsize=0x06, mute=1
  Amp-Out vals:  [0x1b 0x1b]
  Pincap 0x0000001c: OUT HP Detect
  Pin Default 0x901141f0: [Fixed] Speaker at Int N/A
    Conn = 1/8, Color = Green
    DefAssociation = 0xf, Sequence = 0x0
    Misc = NO_PRESENCE
  Pin-ctls: 0x40: OUT
  Connection: 1
     0x17
Node 0x20 [Pin Complex] wcaps 0x40010d: Stereo Amp-Out
  Amp-Out caps: ofs=0x1b, nsteps=0x1b, stepsize=0x06, mute=1
  Amp-Out vals:  [0x80 0x80]
  Pincap 0x0000001c: OUT HP Detect
  Pin Default 0x422140f0: [N/A] HP Out at Ext Front
    Conn = 1/8, Color = Green
    DefAssociation = 0xf, Sequence = 0x0
  Pin-ctls: 0x40: OUT
  Connection: 1
     0x17
Node 0x21 [Pin Complex] wcaps 0x400101: Stereo
  Pincap 0x00000334: IN OUT Detect
    Vref caps: HIZ 50
  Pin Default 0x90a191f0: [Fixed] Mic at Int N/A
    Conn = 1/8, Color = Pink
    DefAssociation = 0xf, Sequence = 0x0
    Misc = NO_PRESENCE
  Pin-ctls: 0x21: IN VREF_50
  Connection: 1
     0x1b
Node 0x22 [Pin Complex] wcaps 0x400101: Stereo
  Pincap 0x00000014: OUT Detect
  Pin Default 0x410160f1: [N/A] Line Out at Ext Rear
    Conn = 1/8, Color = Orange
    DefAssociation = 0xf, Sequence = 0x1
  Pin-ctls: 0x00:
  Connection: 1
     0x1a
Node 0x23 [Pin Complex] wcaps 0x400101: Stereo
  Pincap 0x00000014: OUT Detect
  Pin Default 0x410120f4: [N/A] Line Out at Ext Rear
    Conn = 1/8, Color = Grey
    DefAssociation = 0xf, Sequence = 0x4
  Pin-ctls: 0x00:
  Connection: 1
     0x1b
Node 0x24 [Pin Complex] wcaps 0x400001: Stereo
  Pincap 0x00000020: IN
  Pin Default 0x593300f7: [N/A] CD at Int ATAPI
    Conn = ATAPI, Color = Unknown
    DefAssociation = 0xf, Sequence = 0x7
  Pin-ctls: 0x00:
Node 0x25 [Pin Complex] wcaps 0x400301: Stereo Digital
  Pincap 0x00000010: OUT
  Pin Default 0x474410f0: [N/A] SPDIF Out at Ext Rear Panel
    Conn = RCA, Color = Black
    DefAssociation = 0xf, Sequence = 0x0
  Pin-ctls: 0x40: OUT
  Connection: 1
     0x14
Node 0x26 [Pin Complex] wcaps 0x400201: Stereo Digital
  Pincap 0x00010030: IN OUT EAPD
  EAPD 0x2: EAPD
  Pin Default 0x71c420f0: [N/A] SPDIF In at Oth Rear
    Conn = RCA, Color = Grey
    DefAssociation = 0xf, Sequence = 0x0
  Pin-ctls: 0x40: OUT
Node 0x27 [Audio Input] wcaps 0x10051b: Stereo Amp-In
  Amp-In caps: ofs=0x00, nsteps=0x14, stepsize=0x06, mute=1
  Amp-In vals:  [0x00 0x00]
  Converter: stream=0, channel=0
  SDI-Select: 0
  PCM:
    rates [0x440]: 48000 192000
    bits [0xa]: 16 24
    formats [0x1]: PCM
  Power: setting=D0, actual=D0
  Connection: 1
     0x21
lsmod brings up that yes, i am using snd-hda-intel... i have a snd-vt82xx module, but if i use it the sound won't work at all
 
Old 04-17-2009, 12:03 AM   #5
DavidHindman
Member
 
Registered: Dec 2008
Distribution: Slack 13 + JWM
Posts: 101

Rep: Reputation: 23
What you're supposed to do is look at the following alsa documentation file, which should be on your Slackware 12.2 system if you installed everything (as recommended):

Code:
/usr/src/linux/Documentation/sound/alsa/ALSA-Configuration.txt
You're supposed to go down to the section for snd-hda-intel module, look up your codec in the tables, and note the recommended model option. Then, as root, use a text editor to make the file /etc/modprobe.d/sound look like the following:

Code:
alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-hda-intel
options snd-hda-intel model=xxx
where you substitute xxx above with the recommended model option. (Some modification to the above will be required if you have more than one sound card.) Then restart your system.

The problem is that your VT1708 codec isn't listed in the alsa documentation file. What you do in that situation is to Google for alsa VT1708 "snd-hda-intel" and find whether anyone has reported success with any of the available model options.

I did a casual search and did not find any clear cut successes reported. However, on the basis of what I did see, I think it would be worth trying the following model options:

3stack
3stack-dig

Sometimes people resort to trial and error, spending a weekend trying all the possible model options. Hopefully, you'll avoid that by finding someone who has already done that and reported a success.
 
Old 04-20-2009, 09:28 PM   #6
jmd9qs
Member
 
Registered: Apr 2009
Posts: 36

Original Poster
Rep: Reputation: 16
sorry i haven't posted in awhile...

for some reason, i don't have that documentation on my system (or it resides in some other directory)... I've google'd for hours with different combinations of "snd-hda-intel vt82xxx vt1708 VIA sylvania g netbook alsa", to no avail. after not finding anything i tried just picking random options i've seen on other forum posts, but none of the ones i tried worked, either.

anyway... it looks like my only hope is to re-compile alsa and apply the patch found in this post: ( http://ubuntuforums.org/showthread.php?t=1124185 )... i am REALLY hesitant to do this: when i had Crunchbang linux (a sort-of "Ubuntu-lite") installed, this "patch" broke alsa and i had to re-install the entire OS to get it working again. basically, i'm trying to see if any of you could help me through doing this (keeping in mind that i'm used to a Debian-based system) to see if it'll fix my problem, and, if it doesn't, help me fix alsa again so i can at least have some sound.

again, any help is appreciated.
 
Old 04-25-2009, 05:28 PM   #7
jmd9qs
Member
 
Registered: Apr 2009
Posts: 36

Original Poster
Rep: Reputation: 16
BUMP BUMP

i hate doing that, but i'm getting desperate... i NEED music!!
 
Old 04-25-2009, 11:28 PM   #8
DavidHindman
Member
 
Registered: Dec 2008
Distribution: Slack 13 + JWM
Posts: 101

Rep: Reputation: 23
Quote:
Originally Posted by jmd9qs View Post
BUMP BUMP

i hate doing that, but i'm getting desperate... i NEED music!!
Well, it seems your sound hardware isn't being supported correctly by alsa and no one has reported an easy fix.

USB audio works fairly reliably with Slackware 12.2. A cheap & easy workaround might be to use USB speakers or headphones with your system. No one's going to guarantee USB audio will work with your configuration, so maybe you can borrow USB headphones to try them out first.

If you do that, you'll have to make sure the USB audio is your default alsa sound device. For your system (which uses the snd-hda-intel driver for its onboard sound card) that's done by first running (as root) alsaconf, running alsamixer to set the default volumes, then running alsactl store. Then (also as root) edit your /etc/modprobe.d/sound file to look like this:

Code:
alias snd-card-0 snd-usb-audio
alias sound-slot-0 snd-usb-audio
options snd-usb-audio index=0
alias snd-card-1 snd-hda-intel
alias sound-slot-1 snd-hda-intel
options snd-hda-intel index=1
Alternatively, if you can disable your onboard sound card in your bios setup, you can simply run alsaconf, alsamixer, and alsactl store. In that case only the USB audio device will be detected, and it should automatically get assigned to be the alsa default device.

Last edited by DavidHindman; 04-25-2009 at 11:29 PM.
 
Old 04-26-2009, 03:22 PM   #9
jmd9qs
Member
 
Registered: Apr 2009
Posts: 36

Original Poster
Rep: Reputation: 16
Quote:
Originally Posted by DavidHindman View Post
USB audio works fairly reliably with Slackware 12.2. A cheap & easy workaround might be to use USB speakers or headphones with your system. No one's going to guarantee USB audio will work with your configuration, so maybe you can borrow USB headphones to try them out first.
wow, embarrassingly enough, i hadn't even thought of that... i'll give it a shot, thanks!

josh
 
  


Reply

Tags
alsa, headphone, jack, netbook, slackware


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: A Linux Netbook Done The Right Way: the Sylvania g Netbook Meso LXer Syndicated Linux News 0 04-01-2009 05:20 PM
LXer: Netbook Nightmare: My Experience With the Sylvania g Netbook LXer Syndicated Linux News 0 02-13-2009 05:41 PM
Low sound from speakers/ No sound from headphone jack with Intel ICH8 Family Audio troydclayton Linux - Hardware 2 03-28-2008 10:18 PM
No audio output from headphone jack in a Fujitsu N3410 laptop nigham Linux - Hardware 4 08-14-2006 04:03 PM


All times are GMT -5. The time now is 05:39 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration