LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 11-01-2012, 03:18 PM   #1
Mazer
LQ Newbie
 
Registered: Jun 2012
Posts: 20

Rep: Reputation: Disabled
slackware mutism


hello everybody! I recently reinstalled Slackware 14 on my acer aspire 5560, and I just can't make it speak. I can run alsaconf, but it doesn't seem to help. Can you give me some advice?
Thank you very much!
 
Old 11-01-2012, 03:55 PM   #2
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Main: Gentoo Others: What fits the task
Posts: 15,614
Blog Entries: 2

Rep: Reputation: 4070Reputation: 4070Reputation: 4070Reputation: 4070Reputation: 4070Reputation: 4070Reputation: 4070Reputation: 4070Reputation: 4070Reputation: 4070Reputation: 4070
Quote:
Originally Posted by Mazer View Post
I can run alsaconf, but it doesn't seem to help.
How do you do that? alsaconf is deprecated and not part of Slackware 14.
Anyways, have you tried to run alsamixer and unmute the channels?
What is the output of
Code:
aplay -l
 
Old 11-01-2012, 03:57 PM   #3
kikinovak
Senior Member
 
Registered: Jun 2011
Location: Montpezat (South France)
Distribution: Slackware, Slackware64
Posts: 1,863

Rep: Reputation: 932Reputation: 932Reputation: 932Reputation: 932Reputation: 932Reputation: 932Reputation: 932Reputation: 932
Quote:
Originally Posted by Mazer View Post
hello everybody! I recently reinstalled Slackware 14 on my acer aspire 5560, and I just can't make it speak. I can run alsaconf, but it doesn't seem to help. Can you give me some advice?
Thank you very much!
Probably the channels are muted. Launch alsamixer and check your channels for any [MM] symbols. To unmute them, use the [,] key.
 
Old 11-01-2012, 04:44 PM   #4
Mazer
LQ Newbie
 
Registered: Jun 2012
Posts: 20

Original Poster
Rep: Reputation: Disabled
sorry, I meant alsamixer.
 
Old 11-02-2012, 06:03 AM   #5
STDOUBT
Member
 
Registered: May 2010
Location: Stumptown
Distribution: Slackware 14.0/32bit + Xmonad
Posts: 269

Rep: Reputation: 63
Quote:
Originally Posted by TobiSGD View Post
How do you do that? alsaconf is deprecated and not part of Slackware 14.
Anyways, have you tried to run alsamixer and unmute the channels?
What is the output of
Code:
aplay -l
Depreciated......I just hate that word. I remember back around 2009 when some Debian developer decided alsaconf was (to paraphrase) "outdated, and useless". I was sure glad to see Slackware had the sense to keep it. I NEEDED it! In fact, since my stupid video card has a sound chip in it, my PC now has two "sound cards". I still haven't figured out how to tell alsa which one to use. I got it working for now but _I have no idea how or why_.

I guess kmod is more important. It was really fun learning Linux the first time.
Not so sure I want to keep learning it over and over again *sigh*
 
Old 11-02-2012, 06:26 AM   #6
gnashley
Amigo developer
 
Registered: Dec 2003
Location: Germany
Distribution: Slackware
Posts: 4,771

Rep: Reputation: 477Reputation: 477Reputation: 477Reputation: 477Reputation: 477
Depreciated != Deprecated
Two different words.
 
Old 11-02-2012, 07:19 AM   #7
Mazer
LQ Newbie
 
Registered: Jun 2012
Posts: 20

Original Poster
Rep: Reputation: Disabled
ok, I have another bigger issue now. I think I'll open another post for it. As soon as I solve the other one I'll post aplay. :s
 
Old 11-02-2012, 01:42 PM   #8
hotchili
Member
 
Registered: Sep 2009
Location: Germany
Distribution: slackware64-current
Posts: 70

Rep: Reputation: 18
Hello,

it seems your laptop has amd cpu + amd graphics + hdmi.
I had a sound problem on my netbook (amd e-350 with integrated radeon graphics), turns out that linux made the hdmi output
the default soundcard. To fix this I made a file hda_intel_first.conf in /etc/modprobe.d which contains:
Code:
options snd-hda-intel id=SB index=1
So if aplay -l lists hdmi fist, maybe try something like this. Took me a while to figure this out.
 
Old 11-02-2012, 05:59 PM   #9
STDOUBT
Member
 
Registered: May 2010
Location: Stumptown
Distribution: Slackware 14.0/32bit + Xmonad
Posts: 269

Rep: Reputation: 63
Quote:
Originally Posted by gnashley View Post
Depreciated != Deprecated
Two different words.
:shameful retort:
OK, I feel stupid, however, if the wikipedia definition of 'deprecated' can be trusted, what exactly superseded alsaconf?
alsactl? And how are we supposed to know? Can it be expected that our tools are going to keep changing pretty much every few years?!?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: Making Slackware and Slackware Derivative Linux Distros Speak Your Language LXer Syndicated Linux News 0 01-29-2009 01:30 AM
About Slackware 9.1 boot disk?? ftp://ftp.kpn.be/pub/linux/slackware/slackware-9.1-is AL3OMDAH Slackware 4 04-18-2007 10:54 AM


All times are GMT -5. The time now is 11:13 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration