LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 01-31-2004, 07:11 AM   #1
krajzega
Member
 
Registered: Jan 2004
Location: Poland
Distribution: FreeBSD 5.1
Posts: 92

Rep: Reputation: 15
Slackware Linux and audio I/O


I've got following problem: in my slack i set ALSA as audio output and everything is ok. XMMS doesn't return any errors, and plays mp3 files but there is no soud! All types of volume are set to max but it has no effect. Then I checked all cables and I supose its ok (I can hear all audio on Winshit). How to configure my audio card? I havn't found any features in control center.

PS: I am a slackware-newbie (ive installed it yesterday).
 
Old 01-31-2004, 07:30 AM   #2
dopefish
Member
 
Registered: Nov 2003
Location: Northcliffe, WA
Distribution: Slackware 12.0
Posts: 481

Rep: Reputation: 30
Have u unmuted the channels? Even if yourve got them turned up they may still be muted. Unmute them by typing:

amixer set Master unmute
amixer set PCM unmute

if that doesnt work check the permissions on /dev/dsp and /dev/mixer. If you dont have permission for those devices su to root and type:

chmod 666 /dev/dsp*
chmod 666 /dev/mixer*
 
Old 01-31-2004, 07:46 AM   #3
Jernej
LQ Newbie
 
Registered: Jan 2004
Location: Slovenia
Posts: 8

Rep: Reputation: 0
Thumbs up

Witch sound card do you have? I think that must only start alsamixer and unmute right chanels... exit alsamixer and write alsactl store

it must work!!!
 
Old 01-31-2004, 07:51 AM   #4
krajzega
Member
 
Registered: Jan 2004
Location: Poland
Distribution: FreeBSD 5.1
Posts: 92

Original Poster
Rep: Reputation: 15
Well it still doesnt work.
 
Old 01-31-2004, 08:05 AM   #5
dopefish
Member
 
Registered: Nov 2003
Location: Northcliffe, WA
Distribution: Slackware 12.0
Posts: 481

Rep: Reputation: 30
what version of slackware are you using?

also what is the output of lsmod???

Last edited by dopefish; 01-31-2004 at 08:09 AM.
 
Old 01-31-2004, 08:12 AM   #6
Jernej
LQ Newbie
 
Registered: Jan 2004
Location: Slovenia
Posts: 8

Rep: Reputation: 0
Look I can write you my unmuted "cahnels" (press m to mute od unmute): Master, Master M, Headphon, Bass treble, 3D Contr, 3D contr, Surround, Surround, Surround, Center, LFE, Wave, Wave Cap, Wave Cen, Wave LFE, Wave Sur, Music, CD and Sigmatel (Sigmatel Surround). If you have Creative sound blaster then you must mute SB Live (SB Live Analog/Digital Output Jack)!!! That's all for Creative cards.
Otherwise : http://www.alsa-project.org/
 
Old 01-31-2004, 08:34 AM   #7
krajzega
Member
 
Registered: Jan 2004
Location: Poland
Distribution: FreeBSD 5.1
Posts: 92

Original Poster
Rep: Reputation: 15
Well, ive unmuted all channels. My lsmod output is :
snd-pcm-oss 37252 0
snd-mixer-oss 11992 0 [snd-pcm-oss]
snd-emu10k1 60212 0 (unused)
snd-hwdep 4672 0 [snd-emu10k1]
snd-util-mem 1136 0 [snd-emu10k1]
emu10k1-gp 1352 0 (unused)
gameport 1452 0 [emu10k1-gp]
8139too 15240 1
mii 2304 0 [8139too]
crc32 2880 0 [8139too]
uhci 24496 0 (unused)
usbcore 58400 1 [uhci]
snd-via82xx 11712 0
snd-pcm 55904 0 [snd-pcm-oss snd-emu10k1 snd-via82xx]
snd-timer 13252 0 [snd-pcm]
snd-ac97-codec 37240 0 [snd-emu10k1 snd-via82xx]
snd-page-alloc 6004 0 [snd-emu10k1 snd-via82xx snd-pcm]
snd-mpu401-uart 3136 0 [snd-via82xx]
snd-rawmidi 12512 0 [snd-emu10k1 snd-mpu401-uart]
snd-seq-device 3920 0 [snd-emu10k1 snd-rawmidi]
snd 27460 0 [snd-pcm-oss snd-mixer-oss snd-emu10k1 snd-hwd ep snd-util-mem snd-via82xx snd-pcm snd-timer snd-ac97-codec snd-mpu401-uart snd




My slackware version is 9.1 and my souncard is Soundblaster Live

Last edited by krajzega; 01-31-2004 at 08:38 AM.
 
Old 02-01-2004, 07:52 AM   #8
dopefish
Member
 
Registered: Nov 2003
Location: Northcliffe, WA
Distribution: Slackware 12.0
Posts: 481

Rep: Reputation: 30
Ah someone just had the same problem you need to disable your onboard ac97 soundcard
 
Old 02-01-2004, 10:01 AM   #9
krajzega
Member
 
Registered: Jan 2004
Location: Poland
Distribution: FreeBSD 5.1
Posts: 92

Original Poster
Rep: Reputation: 15
So could you tell me how to do that?
 
Old 02-02-2004, 03:01 AM   #10
dopefish
Member
 
Registered: Nov 2003
Location: Northcliffe, WA
Distribution: Slackware 12.0
Posts: 481

Rep: Reputation: 30
go into your BIOS and change your ac'97 audio from enabled to disabled it should be in integrated devices or something like that
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Slackware audio problem malodemickey Slackware 24 11-24-2005 10:27 AM
how to play audio cd in slackware 10.1? anindyanuri Slackware 13 06-26-2005 01:06 AM
Audio CD Doesn't Play - Slackware mijenks Slackware 9 07-22-2004 11:44 PM
Audio in Slackware XPediTioN Slackware 6 07-08-2003 12:36 AM
HELP: C-Media audio under slackware 9.0 fysx Linux - Hardware 8 04-30-2003 10:52 PM


All times are GMT -5. The time now is 08:17 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration