LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Slackware Linux and audio I/O (http://www.linuxquestions.org/questions/slackware-14/slackware-linux-and-audio-i-o-140653/)

krajzega 01-31-2004 06:11 AM

Slackware Linux and audio I/O
 
I've got following problem: in my slack i set ALSA as audio output and everything is ok. XMMS doesn't return any errors, and plays mp3 files but there is no soud! All types of volume are set to max but it has no effect. Then I checked all cables and I supose its ok (I can hear all audio on Winshit). How to configure my audio card? I havn't found any features in control center.

PS: I am a slackware-newbie (ive installed it yesterday).

dopefish 01-31-2004 06:30 AM

Have u unmuted the channels? Even if yourve got them turned up they may still be muted. Unmute them by typing:

amixer set Master unmute
amixer set PCM unmute

if that doesnt work check the permissions on /dev/dsp and /dev/mixer. If you dont have permission for those devices su to root and type:

chmod 666 /dev/dsp*
chmod 666 /dev/mixer*

Jernej 01-31-2004 06:46 AM

Witch sound card do you have? I think that must only start alsamixer and unmute right chanels... exit alsamixer and write alsactl store

it must work!!!

krajzega 01-31-2004 06:51 AM

Well it still doesnt work.

dopefish 01-31-2004 07:05 AM

what version of slackware are you using?

also what is the output of lsmod???

Jernej 01-31-2004 07:12 AM

Look I can write you my unmuted "cahnels" (press m to mute od unmute): Master, Master M, Headphon, Bass treble, 3D Contr, 3D contr, Surround, Surround, Surround, Center, LFE, Wave, Wave Cap, Wave Cen, Wave LFE, Wave Sur, Music, CD and Sigmatel (Sigmatel Surround). If you have Creative sound blaster then you must mute SB Live (SB Live Analog/Digital Output Jack)!!! That's all for Creative cards.
Otherwise : http://www.alsa-project.org/

krajzega 01-31-2004 07:34 AM

Well, ive unmuted all channels. My lsmod output is :
snd-pcm-oss 37252 0
snd-mixer-oss 11992 0 [snd-pcm-oss]
snd-emu10k1 60212 0 (unused)
snd-hwdep 4672 0 [snd-emu10k1]
snd-util-mem 1136 0 [snd-emu10k1]
emu10k1-gp 1352 0 (unused)
gameport 1452 0 [emu10k1-gp]
8139too 15240 1
mii 2304 0 [8139too]
crc32 2880 0 [8139too]
uhci 24496 0 (unused)
usbcore 58400 1 [uhci]
snd-via82xx 11712 0
snd-pcm 55904 0 [snd-pcm-oss snd-emu10k1 snd-via82xx]
snd-timer 13252 0 [snd-pcm]
snd-ac97-codec 37240 0 [snd-emu10k1 snd-via82xx]
snd-page-alloc 6004 0 [snd-emu10k1 snd-via82xx snd-pcm]
snd-mpu401-uart 3136 0 [snd-via82xx]
snd-rawmidi 12512 0 [snd-emu10k1 snd-mpu401-uart]
snd-seq-device 3920 0 [snd-emu10k1 snd-rawmidi]
snd 27460 0 [snd-pcm-oss snd-mixer-oss snd-emu10k1 snd-hwd ep snd-util-mem snd-via82xx snd-pcm snd-timer snd-ac97-codec snd-mpu401-uart snd




My slackware version is 9.1 and my souncard is Soundblaster Live

dopefish 02-01-2004 06:52 AM

Ah someone just had the same problem you need to disable your onboard ac97 soundcard

krajzega 02-01-2004 09:01 AM

So could you tell me how to do that?

dopefish 02-02-2004 02:01 AM

go into your BIOS and change your ac'97 audio from enabled to disabled it should be in integrated devices or something like that


All times are GMT -5. The time now is 01:51 AM.