LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 08-09-2013, 06:52 AM   #1
Sefid par
Member
 
Registered: Jul 2013
Location: Iran, Shiraz
Distribution: Slackware 14.01
Posts: 53

Rep: Reputation: 0
Question Slackware, Lilo, Debian, Grub


Recently I have installed Debian beside Slackware on another partition.
I needed Grub to load it, So I installed it.
Grub could load Slackware, But not properly, Slackware couldn't open X environment by 'startx'
Then I installed Lilo by Slackware. It could load Slackware properly, But when Debian loaded to login screen, crashed.

I had this problem by Slackware 11 too, which The lilo configured by Slackware 11 could not load Slackware 14.
What can I do in these situations?
What is the problem with these?

How can I make a lilo to boot both Slackware and Debian?
 
Old 08-09-2013, 07:43 AM   #2
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware{,64}-14.1 on a Lenovo T61 6457-4XG
Posts: 3,955

Rep: Reputation: 936Reputation: 936Reputation: 936Reputation: 936Reputation: 936Reputation: 936Reputation: 936Reputation: 936
Quote:
Originally Posted by Sefid par View Post
I had this problem by Slackware 11 too, which The lilo configured by Slackware 11 could not load Slackware 14.
This is a known limitation of lilo's version shipped in Slackware 11. Rebuild a 'lilo' package for Slackware 11 using the newer source shipped in Slackware 14 would have solved it.

Quote:
Originally Posted by Sefid par View Post
What can I do in these situations?
What is the problem with these?

How can I make a lilo to boot both Slackware and Debian?
To investigate further, we need to know more about your system and settings, so please provide following informations (copy and paste them, of even better attach the files to your next post):
  • full content of Slackware's /etc/lilo.conf
  • full content of Debian's /etc/fstab
  • full content of Slackware's /etc/fstab
  • full output of following commands, typed on Slackware (the latter as root):
    Code:
    cat /proc/partitions
    fdisk -l

Last edited by Didier Spaier; 08-09-2013 at 07:45 AM.
 
Old 08-09-2013, 08:05 AM   #3
cynwulf
Senior Member
 
Registered: Apr 2005
Distribution: OpenBSD, Slackware
Posts: 1,218

Rep: Reputation: 375Reputation: 375Reputation: 375Reputation: 375
You don't need grub for either Slackware nor Debian. Just install lilo once in either one and boot from that.
 
Old 08-09-2013, 08:49 AM   #4
Captain Pinkeye
Member
 
Registered: Oct 2012
Location: The Czech Republic
Posts: 173

Rep: Reputation: Disabled
Quote:
Originally Posted by Sefid par View Post
Grub could load Slackware, But not properly, Slackware couldn't open X environment by 'startx'
I don't understand this bit. Could someone please explain to me how the bootloader can affect starting X?
 
Old 08-09-2013, 08:59 AM   #5
Sefid par
Member
 
Registered: Jul 2013
Location: Iran, Shiraz
Distribution: Slackware 14.01
Posts: 53

Original Poster
Rep: Reputation: 0
Thumbs up

Code:
#fdisk -l
Disk /dev/sda: 320.1 GB, 320072933376 bytes
255 heads, 63 sectors/track, 38913 cylinders, total 625142448 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0xe820841d

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *        2048     3074047     1536000    7  HPFS/NTFS/exFAT
/dev/sda2         3074048    86960127    41943040    7  HPFS/NTFS/exFAT
/dev/sda3        86960128   170481663    41760768    7  HPFS/NTFS/exFAT
/dev/sda4       170483710   564758527   197137409    f  W95 Ext'd (LBA)
/dev/sda5       170483712   183066623     6291456   82  Linux swap
/dev/sda6       183068672   187262975     2097152   83  Linux
/dev/sda7       187265024   396980223   104857600   83  Linux
/dev/sda8       396982272   480868351    41943040   83  Linux
/dev/sda9       480870400   522813439    20971520   83  Linux
/dev/sda10      522815488   564758527    20971520   83  Linux
Code:
#cat /proc/partitions
major minor  #blocks  name

   8        0  312571224 sda
   8        1    1536000 sda1
   8        2   41943040 sda2
   8        3   41760768 sda3
   8        4          1 sda4
   8        5    6291456 sda5
   8        6    2097152 sda6
   8        7  104857600 sda7
   8        8   41943040 sda8
   8        9   20971520 sda9
   8       10   20971520 sda10
/etc/fstab for Debian and Slackware & lilo.conf are attached.
Quote:
Originally Posted by cynwulf View Post
You don't need grub for either Slackware nor Debian. Just install lilo once in either one and boot from that.
Do you mean to install two lilos? One on Debian and another on Slackware? Though I need only one!
Attached Files
File Type: txt lilo.conf.txt (2.2 KB, 17 views)
File Type: txt fstab_debian.txt (664 Bytes, 3 views)
File Type: txt fstab_slackware.txt (640 Bytes, 2 views)
 
Old 08-09-2013, 10:06 AM   #6
jprzybylski
Member
 
Registered: Apr 2011
Location: Canada
Distribution: Slackware
Posts: 93

Rep: Reputation: 22
I personally use Slackware's Lilo (installed on the MBR, the device would be something like /dev/sda) to boot Debian's Grub (installed wherever Debian's root is, ex. /dev/sda3). That way, I still have lots of control over my overall boot, but if I want to use Debian, Debian can keep control of how it wants to start.
 
Old 08-09-2013, 10:19 AM   #7
xflow7
Member
 
Registered: May 2004
Distribution: Slackware
Posts: 158

Rep: Reputation: 21
Quote:
Originally Posted by Captain Pinkeye View Post
I don't understand this bit. Could someone please explain to me how the bootloader can affect starting X?
Could it be that the GRUB installation is configured to pass some particular kernel parameter that LILO is not? For instance, to prevent loading the nouveau driver so it doesn't conflict with the NVIDIA blob?
 
Old 08-09-2013, 03:53 PM   #8
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware{,64}-14.1 on a Lenovo T61 6457-4XG
Posts: 3,955

Rep: Reputation: 936Reputation: 936Reputation: 936Reputation: 936Reputation: 936Reputation: 936Reputation: 936Reputation: 936
The problem lies in /etc/lilo.conf. You use the same kernel (Slackware's) to boot both Debian and Slackware, as you have the same line:
Code:
image = /boot/vmlinuz
in stanzas for Debian and Slackware. This can't work, or only by chance.

Do this in Slackware:
  1. As root, type "mkdir /debian" (without the quotes, of course)
  2. Add following line to /etc/fstab after the line for /dev/sda7:
    Code:
    /dev/sda9        /debian            ext4        defaults         1   2
  3. Type "mount /debian"
  4. Check in /debian/boot the name of Debian's kernel. I will assume that it's "vmlinuz", else adapt next step accordingly.
  5. In /etc/lilo.conf, replace the line before " root = /dev/sda9" with:
    Code:
    image = /debian/boot/vmlinuz
  6. Run as root "lilo -t -v " and if all goes well, "lilo".
Now you should be able to boot Slackware or Debian.

Last edited by Didier Spaier; 08-10-2013 at 03:39 PM. Reason: No need to reboot at step 3.
 
1 members found this post helpful.
Old 02-19-2014, 09:05 PM   #9
Sefid par
Member
 
Registered: Jul 2013
Location: Iran, Shiraz
Distribution: Slackware 14.01
Posts: 53

Original Poster
Rep: Reputation: 0
I got failed on Debian, After that, Now I need this for Ubuntu 12.04. I added the image and also initrd to lilo.conf as:
Code:
# Linux bootable partition config begins
image = /friend/boot/vmlinuz-3.11.0-15-generic
  root = /dev/sda9
  label = Kinect
  read-only  # Partitions should be mounted read-only for checking
But Ubuntu loaded on Standard screen resolution and also mouse/keyboard did not work. Then I added the initrd:
Code:
# Linux bootable partition config begins
image = /friend/boot/vmlinuz-3.11.0-15-generic
  root = /dev/sda9
  initrd = /friend/boot/initrd.img-3.11.0-15-generic
  label = Kinect
  read-only  # Partitions should be mounted read-only for checking
Skip checking didn't work.
Also I got warning:
Code:
Warning: LBA32 addressing assumed
Added Linux  *
Added Kinect  +
Added Windows
One warning was issued.
So I added lba32 to lilo.conf and the warning did not appear.

Now screen resolution got correct but there is another problem:
I get the error on Ubuntu boot:
Code:
the disk drive for / is not ready yet or not present. Continue to wait; or press s to skip mounting or M for manual recovery.
What is the next step to get Ubuntu work correctly?
Thanks in advance.

Last edited by Sefid par; 02-19-2014 at 09:08 PM.
 
Old 02-19-2014, 09:31 PM   #10
colorpurple21859
Senior Member
 
Registered: Jan 2008
Location: florida
Distribution: slackware64-current, puppy, ubuntu
Posts: 1,342

Rep: Reputation: 184Reputation: 184
The error could be caused by several different things. Googling the error message comes up with several different ways to fixed it based on what was done or happened during the installation and or software updates. Could be from a drive that was attached during the install resulting in a bad fstab entry or updates/software install resulting in partition being mounted in read only mode.

Last edited by colorpurple21859; 02-19-2014 at 09:34 PM.
 
1 members found this post helpful.
Old 02-19-2014, 09:49 PM   #11
tommcd
Senior Member
 
Registered: Jun 2006
Location: Philadelphia PA USA
Distribution: Lubuntu, Slackware
Posts: 2,227

Rep: Reputation: 286Reputation: 286Reputation: 286
Quote:
Originally Posted by Sefid par View Post
I got failed on Debian, After that, Now I need this for Ubuntu 12.04. I added the image and also initrd to lilo.conf as ... What is the next step to get Ubuntu work correctly?
I have been dual booting Ubuntu + Slackware + other distros for several years now.
My preference is to use Ubuntu's grub2 to boot everything.
If you would like to use Ubuntu's grub2 to boot all of your Linux distros, here is how to reinstall grub2 to your computer MBR:
https://help.ubuntu.com/community/Re...tallingWindows
Or you can use a boot repair CD:
https://help.ubuntu.com/community/Boot-Repair
The only problem here is that Ubuntu's grub2 will create multiple boot entries for Slackware since there are huge and generic kernels in the Slackware boot directory.
Since I use an initrd to boot the Slackware generic kernel as Pat V recommends, I just create my own custom boot file for Slackware in Ubuntu's /etc/grub.d/ directory that I name 31_Slackware64-14.1. This way it show up at the bottom of the Ubuntu grub2 menu. I make the file executable. Here is the contents of the file:
Code:
## Remember to make this file executable in Ubuntu.
#
echo "Adding Slackware64-14.1 on /dev/sda5" >&2
cat << EOF
##!/bin/sh
#exec tail -n +3 $0
menuentry "Slackware64-14.1 on /dev/sda5" {
        set root=(hd0,5)
        linux  /boot/vmlinuz-generic-3.10.17 root=/dev/sda5 ro 
        initrd  /boot/initrd.gz
}
EOF
Note that my Slackware is on /dev/sda5. Be sure to adjust this depending on where your Slackware partition is.
Note also that I have commented out the lines:
Code:
##!/bin/sh
#exec tail -n +3 $0
I have seen reports on the Ubuntu forums that some people needed those lines to boot other distros from ubuntu's grub2, but I have never needed them. I just keep them in the file for reference.
Then just be sure to run
Code:
sudo update-grub
from Ubuntu after you create the custom boot file for Slackware for the changes to be written to your Ubuntu's /boot/grub/grub.cfg file.
Also, using Ubuntu's grub2 will also let you easily boot Debian if you are still using that after you run "sudo update-grub".
Hope this helps.

Last edited by tommcd; 02-19-2014 at 09:54 PM.
 
1 members found this post helpful.
Old 02-20-2014, 06:13 AM   #12
enorbet
Member
 
Registered: Jun 2003
Location: Virginia
Distribution: Slackware 14 is Main OpSys on Main PC, 2ndary are OpenSuSe 13 and SolydK
Posts: 667

Rep: Reputation: 257Reputation: 257Reputation: 257
I'm not sure that I've even owned a single OpSys PC since 1993, and many have more than 3 on them. Wait, even in DOS days I often had M$DOS and Novell or Caldera. Hmmmm... In any case with GUI type operating systems, and with my propensity to "muck about and break stuff" I developed the habit of redundant or chainload type booting. If I have 5 operating systems, each one gets a bootloader installed to root, but just one get's it in MBR as well. That insures only one major fail point and pointing to any partition boots it. Simple.

I have had occasion recently where a few systems don't seem to like "Other = /dev/foo2, Label = Foo2" so I keep a local copy of kernel and initrd in it's own subdirectory, like this -

Code:
 #####
image = /boot/vmlinuz-custom-3.12
root = /dev/sda9
 label = Slack14-13.12
 read-only ##
###
other = /dev/sda8
label = Stubuntu
###
image = /boot/suse/vmlinuz-3.11.6-4-desktop
root = /dev/sdb8
label = OpenSuSe
read-only##
##
image = /boot/solydk/vmlinuz-3.11-2-amd64
        initrd = /boot/solydk/initrd.img-3.11-2-amd64
        root = /dev/sda12
        append = "nomodeset"
        label = SolydK
read-only##
##
other = /dev/sda3
label = Win7
#####
I only resort to the latter if simple chainloading doesn't work. I like redundancy. It has saved my bacon many times.

Last edited by enorbet; 02-20-2014 at 06:15 AM.
 
1 members found this post helpful.
Old 02-20-2014, 10:52 AM   #13
cynwulf
Senior Member
 
Registered: Apr 2005
Distribution: OpenBSD, Slackware
Posts: 1,218

Rep: Reputation: 375Reputation: 375Reputation: 375Reputation: 375
As you only have one fixed disk (/dev/sda) just install one bootloader in the root controlled by one OS. It doesn't matter which. If you find grub2 easier, just use that. It can usually scan all /boot partitions on the disk and just add entries for all kernels.

Regarding lilo, the issue surrounding the /boot/vmlinuz symlink, confuses me somewhat. I don't think Debian uses that anyway, so you can simply specify the kernel you want to load - e.g. /boot/vmlinuz-3.2.0-4-amd64 for Debian and /boot/vmlinuz-generic-3.10.17-smp for Slackware (or just /boot/vmlinuz assuming the generic kernel is symlinked to that).

Short version: Your original lilo config should work if you specify the correct partition and kernel image. Generally if running lilo passes, then it should work. The problems you reported initially don't seem related.

If you want something more automated - install grub2 once on one OS, do not install grub2 (or lilo for that matter) for two OS.

Last edited by cynwulf; 02-20-2014 at 10:54 AM.
 
1 members found this post helpful.
Old 02-20-2014, 02:14 PM   #14
brianL
LQ 5k Club
 
Registered: Jan 2006
Location: Oldham, Lancs, England
Distribution: Slackware & Slackware64 14.1
Posts: 6,861
Blog Entries: 51

Rep: Reputation: Disabled
Quote:
Originally Posted by jprzybylski View Post
I personally use Slackware's Lilo (installed on the MBR, the device would be something like /dev/sda) to boot Debian's Grub (installed wherever Debian's root is, ex. /dev/sda3). That way, I still have lots of control over my overall boot, but if I want to use Debian, Debian can keep control of how it wants to start.
That's what I've done whenever dual-booting Slackware with Debian (or any other distro). Only needs two lines in lilo.conf:
Code:
other = /dev/sda3
  label = Debian
 
1 members found this post helpful.
Old 02-21-2014, 03:22 AM   #15
Sefid par
Member
 
Registered: Jul 2013
Location: Iran, Shiraz
Distribution: Slackware 14.01
Posts: 53

Original Poster
Rep: Reputation: 0
Thanks all, Your solutions worked properly;

First I installed Grub2 on Ubutnu again and worked fine.
But as lilo is more comfortable for me, I installed lilo again and configured it as brianL said. It worked fine.
LILO finds and boots grub2 from Ubuntu's partition.

my Lilo's partitions setup is as this:

Code:
# Linux bootable partition config begins
image = /boot/vmlinuz
  root = /dev/sda8
  label = Linux
  read-only  # Partitions should be mounted read-only for checking
# Linux bootable partition config ends
# Linux bootable partition config begins
other = /dev/sda9
label = Kinect
# Linux bootable partition config ends

# Windows bootable partition config begins
other = /dev/sda2
  label = Windows
  table = /dev/sda
# Windows bootable partition config ends

Last edited by Sefid par; 02-21-2014 at 03:32 AM.
 
  


Reply

Tags
grub, kernel, lilo


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Before Install: Slackware over Ubuntu (Grub to LILO), Dual w/Vista: LILO question Ubunoob001 Slackware - Installation 3 03-01-2010 03:01 PM
Installed Debian, with Lilo instead of Grub now I can't load Windoze ocajublinky Linux - Newbie 2 01-19-2009 03:22 PM
i cant boot lilo on slackware, grub doesnt allow i to blacksky2 Slackware 3 10-14-2008 04:30 PM
slackware install problems (lilo vs grub) ultimatenoob Linux - Newbie 13 08-07-2006 10:51 AM
LILO/GRUB for dual booting Gentoo and Debian. rmanocha Linux - Software 2 02-22-2004 01:23 PM


All times are GMT -5. The time now is 05:26 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration