LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   slackware ldap server (http://www.linuxquestions.org/questions/slackware-14/slackware-ldap-server-928565/)

idnotcrae 02-09-2012 07:33 PM

slackware ldap server
 
I installed ldap by building the package after editing slackbuild script to enable slapd and slurpd. but I don't find any available modules like back_hdb.la
will the server work fine ! and if not what should I do to handle this issue.

idnotcrae 02-09-2012 07:50 PM

darkstar:~# slapd -d config


Quote:

4f33e9f8 line 9 (pidfile /var/run/slapd.pid)
4f33e9f8 line 10 (argsfile /var/run/slapd.args)
4f33e9f8 line 11 (loglevel none)
4f33e9f8 line 13 (modulepath /usr/local/libexec/openldap)
4f33e9f8 /usr/local/etc/openldap/slapd.conf: line 13: keyword <modulepath> ignored
4f33e9f8 line 14 (moduleload back_hdb)
4f33e9f8 /usr/local/etc/openldap/slapd.conf: line 14: keyword <moduleload> ignored
4f33e9f8 line 20 (database hdb)
4f33e9f8 line 21 (suffix "dc=example,dc=com")
4f33e9f8 line 22 (rootdn "cn=Manager,dc=example,dc=com")
4f33e9f8 line 23 (rootpw ***)
4f33e9f8 line 24 (directory /usr/local/var/openldap-data)
4f33e9f8 line 25 (index objectclass,cn eq)
4f33e9f8 index objectClass 0x0004
4f33e9f8 index cn 0x0004
4f33e9f8 config_back_db_open: No explicit ACL for back-config configured. Using hardcoded default
4f33e9f8 hdb_monitor_db_open: monitoring disabled; configure monitor database to enable
4f33e9f8 slapd starting

idnotcrae 02-10-2012 07:54 PM

I downloaded the source code and compiled it with enabling modules and now everything is okay :) one should google before posting questions :D

planet_x 10-14-2012 07:46 AM

Quote:

I downloaded the source code and compiled it with enabling modules and now everything is okay one should google before posting questions
Are you sure? cos I have the same problem too.
Using Slackware 14 and enable module but still no luck :(
Code:

./configure \
  --prefix=/usr \
  --libdir=/usr/lib${LIBDIRSUFFIX} \
  --localstatedir=/var/lib \
  --sysconfdir=/etc \
  --mandir=/usr/man \
  --with-cyrus-sasl \
  --with-tls \
  --with-threads \
  --enable-debug \
  --enable-syslog \
  --enable-dynamic \
  --enable-local \
  --enable-proctitle \
  --disable-static \
  --enable-shared \
  --enable-slapd \
  --enable-modules \
  --enable-rlookups \
  --enable-crypt \
  --enable-sql


camerabambai 01-22-2013 07:33 AM

Code:

./configure \
  --prefix=/usr \
  --libdir=/usr/lib${LIBDIRSUFFIX} \
  --localstatedir=/var/lib \
  --sysconfdir=/etc \
  --mandir=/usr/man \
  --with-cyrus-sasl \
  --with-tls \
  --with-threads \
  --enable-debug \
  --enable-syslog \
  --enable-dynamic \
  --enable-local \
  --enable-proctitle \
  --enable-static \
  --enable-modules=yes \
  --enable-overlays=mod \
  --enable-shared

This is a correct configure to enable modules


All times are GMT -5. The time now is 12:35 PM.