LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 03-23-2013, 10:29 PM   #1
mrmarria
LQ Newbie
 
Registered: Mar 2013
Posts: 9

Rep: Reputation: Disabled
Question Slackware Install -probable Grub problem- boot OK from Flashdrive


Thought I'd give Slackware a try, Ubuntu is causing me samba problems.

Install went easily, using Grub to multi-boot,
however, when I boot from flash drive Slackware install created, everything OK. When I boot from HD, after initial decompression, screen black out.
I believe that the boot continues to Login.

I can login, and issue startx, which gets a lot of drive activity but no display still. I can also login blind, and shutdown the system.

Been reading up on grub2, not sure where to look for config problem - guessing something like vga settings?

The files on the flashdrive are so simple compared to what grub apparently does, I am lost.

Any help?
 
Old 03-24-2013, 02:12 PM   #2
Erik_FL
Member
 
Registered: Sep 2005
Location: Boynton Beach, FL
Distribution: Slackware
Posts: 797

Rep: Reputation: 247Reputation: 247Reputation: 247
When you first boot Slackware after installing, it stays in text console mode. I think the problem you have is the frame buffer graphics mode is not compatible with your video card.

You can try adding these kernel parameters in the grub menu entry for Slackware on the line that has "/boot/vmlinuz".

Code:
vga=normal video=640x480
Edit the "/boot/grub/grub.cfg" file in the Ubuntu partition (or whatever partition has GRUB installed).

The menu entry for Slackware will look similar to this. Your GRUB 2 menu entry may look different and there may be a few more options on the line with "/boot/vmlinuz". Add the "vga" and "video" options to the end of that line. If the "vga" or "video" option is already there, then change the existing options.

Code:
menuentry "Slackware" {
    recordfail
    insmod ext2
    set root=(hd0,msdos2)
    linux    /boot/vmlinuz root=/dev/sda2 ro vga=normal video=640x480 
}
If you still do not see a display, you may have to black-list the Noveau graphics driver.

Create a text file in the Slackware partition named "/etc/modprobe.d/disable-nouveau.conf". The file should contain this to disable Noveau.

Code:
blacklist nouveau
options nouveau modeset=0
For example, if you mounted the Slackware partition under "/mnt" then you need to create a file called "/mnt/etc/modprobe.d/disable-nouveau.conf". The directory "etc/modprobe.d" should already exist in the Slackware partition.

If that does not solve the problem, please post information about your graphics card. Use this command on a version of Linux that does boot and post the results here.

Code:
lspci
If you know the manufacturer and model of your graphics card or chip, post that as well.
 
1 members found this post helpful.
Old 03-24-2013, 04:54 PM   #3
mrmarria
LQ Newbie
 
Registered: Mar 2013
Posts: 9

Original Poster
Rep: Reputation: Disabled
blacklist worked, why?

Thank you Erik_FL.

Blacklisting was the immediate solution, the other things did not succeed.

The card reports as: nVidia Corporation g98 [GeForce 8400 GS] (rev a1)

it is a PNY GeForce 8400 GS pci-e card

So with nouveau disabled, I get low res from flashdrive boot and / or HD boot.

With nouveau enabled. I only can see a a display after nouveau goes active from the flashdrive.
(I see it start in the flashdrive boot) as the text goes hi-res.

What is happening differently to this "driver"?

Obviously, a lot more is going on with grub than with the flash drive boot....
I tried mkinitrd from running slackware boot, but that did not succeed.

Thank you.
Michael
 
Old 03-24-2013, 08:54 PM   #4
Erik_FL
Member
 
Registered: Sep 2005
Location: Boynton Beach, FL
Distribution: Slackware
Posts: 797

Rep: Reputation: 247Reputation: 247Reputation: 247
I don't know a lot about GRUB 2 but there is a way to set the graphics resolution before booting Linux.

In the Slackware menu entry add this line to set the graphics resolution.

Code:
set gfxpayload=640x480
or

Code:
set gfxpayload=text
You can also use other resolutions if your graphics card supports those. For example, "1024x768" or "1024x768x24".

To make sure that GRUB can tell the kernel the correct video resolution, you should have these modules loaded at the beginning of your "grub.cfg" file.

For a computer with a BIOS.

Code:
insmod vbe
For a computer with UEFI.

Code:
insmod efi_gop
insmod efi_uga
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Slackware install from a flashdrive? free_bird Slackware 6 01-04-2007 11:40 PM
Slackware install from a flashdrive? free_bird Slackware 1 11-28-2006 12:55 AM
grub support from cdrom and flashdrive boot vineet7kumar Linux - Hardware 1 05-03-2006 10:12 AM


All times are GMT -5. The time now is 07:57 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration