LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 03-23-2015, 07:15 PM   #1
slacksam
Member
 
Registered: Oct 2012
Location: Germany
Distribution: Slackware, Salix, Manjaro, Arch
Posts: 133

Rep: Reputation: 14
Question Slackware in QEMU - jumping mouse cursor in X when using vmware graphics driver


Hi,

I installed Slackware 14.1 inside of a QEMU 2.2.0 virtual machine and when I start an X session, using vmware video card emulation, the mouse cursor is jumping around inside the QEMU window and is out of control.

Everything else seems to work fine, no problems with the keyboard and no mouse issues in the console.

I also tried Salix in QEMU and there is no such issue.

How can I get the mouse working for Slackware inside QEMU with vmware graphics?

I tried to set proto=imps and proto=bare as module option for psmouse, but that changed nothing.


[edit] Oh, I forgot to mention that I have two Slackware installations in QEMU, one 32bit and one 64bit system and the mouse issue is on both.

Last edited by slacksam; 03-25-2015 at 10:30 AM. Reason: solved
 
Old 03-23-2015, 10:26 PM   #2
Ztcoracat
LQ Guru
 
Registered: Dec 2011
Distribution: Slackware
Posts: 7,074
Blog Entries: 9

Rep: Reputation: Disabled
Hi:

Is there a smart mouse feature in QEMU?
Maybe adjust that.

You might want to give Virtual Box a try.
It's running Arch and Mageia flawlessly for me.

http://www.linuxquestions.org/questi...al-4175500846/
 
Old 03-23-2015, 11:43 PM   #3
veerain
Senior Member
 
Registered: Mar 2005
Location: Earth bound to Helios
Distribution: Custom
Posts: 2,524

Rep: Reputation: 319Reputation: 319Reputation: 319Reputation: 319
Is there any particular requirement to use vmware graphics? You can use cirrus or plain vesa video graphics. They work good.
 
Old 03-24-2015, 03:59 AM   #4
slacksam
Member
 
Registered: Oct 2012
Location: Germany
Distribution: Slackware, Salix, Manjaro, Arch
Posts: 133

Original Poster
Rep: Reputation: 14
Quote:
Originally Posted by Ztcoracat
Is there a smart mouse feature in QEMU?
Looks like there is no such feature but if there is one, I never used it.
On other systems I'm running in QEMU I either don't use it and there are no mouse issues (like I mentioned it in my first post).

Quote:
Originally Posted by Ztcoracat
You might want to give Virtual Box a try.
I know Virtualbox but prefer QEMU mainly because I'm already using it for years and have many other distros running on it.

Quote:
Originally Posted by veerain
Is there any particular requirement to use vmware graphics?
Yes, the reason is that I have other (graphical) issues with Cirrus or VESA (not only when running Slackware).


Please consider my question like this:
What can I do to make the X session on Slackware in QUEMU with VMWare video emulation run without the mentioned mouse issues, like other Distributions do (eg. Salix or Manjaro)?


[edit] One option to solve this issue is to use "-usbdevice mouse" as start option with QEMU,
but I'm still wondering why the other distros mentioned above do not need that option.

Last edited by slacksam; 03-24-2015 at 06:25 AM.
 
Old 03-24-2015, 08:03 AM   #5
AlleyTrotter
Member
 
Registered: Jun 2002
Location: Coal Township PA
Distribution: Slackware64-14.2 (4.10.4) UEFI enabled
Posts: 416

Rep: Reputation: 98
It would help if you posted the type of mouse you use. Also the command you are using to start qemu. I have had this problem in the past but I don't remember how I fixed it. It seems it had something to do with screen resolution or size.

Last edited by AlleyTrotter; 03-24-2015 at 08:05 AM.
 
Old 03-24-2015, 10:17 AM   #6
slacksam
Member
 
Registered: Oct 2012
Location: Germany
Distribution: Slackware, Salix, Manjaro, Arch
Posts: 133

Original Poster
Rep: Reputation: 14
Hi AlleyTrotter,

I'm using a Logitech PS/2 mouse over a Belkin LVM switch.
The starting commands für QEMU look like:
Code:
qemu-system-i386 -monitor stdio -cpu qemu32 -soundhw es1370 -k de -vga vmware -enable-kvm -m 700 -no-fd-bootchk -localtime -hda /home/sam/qemu/slackware.qcow2 -boot once=d,menu=off -net nic,vlan=0 -net user,vlan=0 -name "Slackware"
But as I already mentioned, I also have installations of other Linux distros in QEMU and I'm starting them the same way, on the same machine, with the same QEMU specific hardware configurations, but most of the others don't have that mouse issue.
 
Old 03-24-2015, 02:05 PM   #7
AlleyTrotter
Member
 
Registered: Jun 2002
Location: Coal Township PA
Distribution: Slackware64-14.2 (4.10.4) UEFI enabled
Posts: 416

Rep: Reputation: 98
Code:
qemu-system-i386 -cpu qemu32 -soundhw es1370 -k de -vga vmware -enable-kvm -m 700 -localtime -hda /home/sam/qemu/slackware.qcow2
Try with above. It seems that in the past qemu on slackware sometimes got confused for me with the order of longer command lines. The -monitor and -vga commands may be conflicting.
Also after booting try setting your display to a different resolution. I just can't find my notes on this issue, but you are not alone.
 
Old 03-24-2015, 03:09 PM   #8
slacksam
Member
 
Registered: Oct 2012
Location: Germany
Distribution: Slackware, Salix, Manjaro, Arch
Posts: 133

Original Poster
Rep: Reputation: 14
Quote:
Originally Posted by AlleyTrotter
Code:
qemu-system-i386 -cpu qemu32 -soundhw es1370 -k de -vga vmware -enable-kvm -m 700 -localtime -hda /home/sam/qemu/slackware.qcow2
...
Also after booting try setting your display to a different resolution.
Tried it, but no success - the mouse problem still persists.
Even changing the resolution with xrandr doesn't solve the issue.

Please note the edited part in my last post. I don't think that the problem is a wrong QEMU option or screen resolution, but some wrong/missing configurations in the X server or kernel module options.
 
Old 03-24-2015, 07:08 PM   #9
fdonkers
LQ Newbie
 
Registered: Dec 2013
Posts: 6

Rep: Reputation: Disabled
If the mouse movement is erratic, it can be fixed by adding a graphics tablet. I use libvirt with virtual machine manager, so I am not starting qemu from the command line. It looks like the option for a tablet is the following:

Code:
-device usb-tablet,id=input0
 
2 members found this post helpful.
Old 03-25-2015, 02:26 AM   #10
slacksam
Member
 
Registered: Oct 2012
Location: Germany
Distribution: Slackware, Salix, Manjaro, Arch
Posts: 133

Original Poster
Rep: Reputation: 14
@fdonkers
Thanks, the option
Code:
-usbdevice tablet
works best for me.
With the option -usbdevice mouse it works, too, but there's an issue in fluxbox: When I move the mouse cursor to the bottom border of an open window, the mouse cursor jumps to the right bottom corner of the screen.
With the option -usbdevice tablet it works properly and also automatic grabbing of the mouse cursor, when moving it over the QEMU window, works.


However, I'm still wondering, why for other desktop distros I tested as guest system I don't need this option.
 
Old 03-25-2015, 08:59 AM   #11
AlleyTrotter
Member
 
Registered: Jun 2002
Location: Coal Township PA
Distribution: Slackware64-14.2 (4.10.4) UEFI enabled
Posts: 416

Rep: Reputation: 98
Quote:
Originally Posted by slacksam View Post
Please note the edited part in my last post. I don't think that the problem is a wrong QEMU option or screen resolution, but some wrong/missing configurations in the X server or kernel module options.
As it turns out it was a wrong/missing qemu option
I find that using a minimal startup command for qemu and then building from that works best for me. Usually the defaults work fine. Sorry I could not offer more.
By the way when I had the jumping cursor it was when I was trying to use libvirt/virsh. It went away when I switched back to starting qemu from the command line. Virsh just seems to complicate things. My virtualisation needs are probably simpler than most. I just use it to build/compile new software and test current.
Glad you got it fixed
John

Last edited by AlleyTrotter; 03-25-2015 at 09:05 AM.
 
Old 03-25-2015, 10:20 PM   #12
Ztcoracat
LQ Guru
 
Registered: Dec 2011
Distribution: Slackware
Posts: 7,074
Blog Entries: 9

Rep: Reputation: Disabled
Quote:
why for other desktop distros I tested as guest system I don't need this option.
If I had to guess (notice I said guess) it might be because there is a library, binary, module or driver that already includes the functionality for the mouse automatically.

It may also be something associated with systemd which controls start and stop services and other types of initializations that occur with system functions.
 
Old 03-13-2017, 03:34 AM   #13
Weber Kai
LQ Newbie
 
Registered: Jun 2009
Location: Brasília, Brazil
Distribution: Slackware64
Posts: 17

Rep: Reputation: 13
Sorry to post in an old entry, but I came from google looking for these same answers to same problems, and I would like to contribute.

But I am using virt-manager, so I can't edit command line.

In both guests 14.1 and 14.2 I solved the mouse offset issue by editing file /usr/share/X11/xorg.conf.d/05-qxl.conf and removing these lines:

Code:
# Prevent udev from loading vmmouse in a vm and crashing.
Section "ServerFlags"
    Option "AutoAddDevices" "False"
EndSection
Thank you!
 
2 members found this post helpful.
Old 03-13-2017, 11:26 AM   #14
Ztcoracat
LQ Guru
 
Registered: Dec 2011
Distribution: Slackware
Posts: 7,074
Blog Entries: 9

Rep: Reputation: Disabled
Quote:
Originally Posted by Weber Kai View Post
Sorry to post in an old entry, but I came from google looking for these same answers to same problems, and I would like to contribute.

But I am using virt-manager, so I can't edit command line.

In both guests 14.1 and 14.2 I solved the mouse offset issue by editing file /usr/share/X11/xorg.conf.d/05-qxl.conf and removing these lines:

Code:
# Prevent udev from loading vmmouse in a vm and crashing.
Section "ServerFlags"
    Option "AutoAddDevices" "False"
EndSection
Thank you!
Thanks for posting a solution.
 
  


Reply

Tags
mouse, problem, qemu, slackware 14.1, vmware


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Crazy jumping mouse cursor after fresh install--did I choose the wrong mouse type? Kallaste Slackware 56 07-08-2012 02:38 PM
[SOLVED] Suse (on vmware) terminal mouse cursor position misaligned wedz Linux - Newbie 1 03-09-2012 01:09 AM
Strange problem with cursor jumping to menus in Slackware 12.1 teddyt Slackware 15 06-27-2008 06:44 AM
Mouse cursor jumping erratically + takes clicking action when not moved? JZL240I-U Linux - Software 23 04-30-2008 08:54 AM
how to use ati graphics chipsets in qemu/other vms without driver in guest system lomix Linux - Hardware 4 04-17-2008 07:54 AM


All times are GMT -5. The time now is 12:17 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration