LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 01-23-2011, 07:09 PM   #1
mlangdn
Senior Member
 
Registered: Mar 2005
Location: Kentucky
Distribution: Slackware64-current
Posts: 1,387

Rep: Reputation: 181Reputation: 181
Slackware Identifier Icon missing


I am using Firefox-4.0b9 from /testing. I never deleted the old profile from 3.6x days. I just noticed that the Slackware identifier icon is now just a generic Linux icon. I checked in about:config, and the general.useragent.extra.linux string is still set to Slackware Linux.

Is there something different to do for FF-4x? This isn't a real problem, just an annoying matter of pride.
 
Click here to see the post LQ members have rated as the most helpful post in this thread.
Old 01-23-2011, 10:25 PM   #2
enorbet
Member
 
Registered: Jun 2003
Location: Virginia
Distribution: Slackware 14 is Main OpSys on Main PC, 2ndary are OpenSuSe 13 and SolydK
Posts: 736

Rep: Reputation: 345Reputation: 345Reputation: 345Reputation: 345
Yup

Same here all around. no fix yet.... do like the beta tho except for search bar and status bar 0 search bar crashes sometimes and even with Status4Ever mouseover links still show in addy bar and are usually truncated, but pride is definitely an issue and I hope soon fixed
 
Old 01-23-2011, 11:37 PM   #3
mlangdn
Senior Member
 
Registered: Mar 2005
Location: Kentucky
Distribution: Slackware64-current
Posts: 1,387

Original Poster
Rep: Reputation: 181Reputation: 181
I am in the process of adding back themes, addons and such since blowing away the old profile. I'm gonna find a solution I hope.
 
Old 01-24-2011, 12:14 AM   #4
mlangdn
Senior Member
 
Registered: Mar 2005
Location: Kentucky
Distribution: Slackware64-current
Posts: 1,387

Original Poster
Rep: Reputation: 181Reputation: 181
There is nothing in about:config that helps. Its time for bed now.
 
Old 01-24-2011, 07:11 AM   #5
mlangdn
Senior Member
 
Registered: Mar 2005
Location: Kentucky
Distribution: Slackware64-current
Posts: 1,387

Original Poster
Rep: Reputation: 181Reputation: 181
Back up early and still trying to fix this. Just added a new string to about:config, so this is to see if it worked.
 
Old 01-24-2011, 07:21 AM   #6
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Linux Mint
Posts: 8,516

Rep: Reputation: 896Reputation: 896Reputation: 896Reputation: 896Reputation: 896Reputation: 896Reputation: 896
For some reason, the beta version from firefox doesn't support the icon thing,
even if it's set in about:config
I'm using 4.0b10pre, and have the same problem.
However when I use the latest version, not beta, it works.

Kind regards
 
Old 01-24-2011, 07:22 AM   #7
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Linux Mint
Posts: 8,516

Rep: Reputation: 896Reputation: 896Reputation: 896Reputation: 896Reputation: 896Reputation: 896Reputation: 896
This is with 3.6.13
Same config in about:config

Kind regards
 
Old 01-24-2011, 07:29 AM   #8
brianL
LQ 5k Club
 
Registered: Jan 2006
Location: Oldham, Lancs, England
Distribution: Slackware & Slackware64 14.1
Posts: 7,140
Blog Entries: 52

Rep: Reputation: Disabled
I'm using FF 4 beta 9 on 13.1. Got it from Mozilla, and stuck it in /opt. Do I get the Slack icon?
No...
 
Old 01-24-2011, 07:33 AM   #9
mlangdn
Senior Member
 
Registered: Mar 2005
Location: Kentucky
Distribution: Slackware64-current
Posts: 1,387

Original Poster
Rep: Reputation: 181Reputation: 181
All-righty, then. I think I got the daggone thingy fixed. In about:config, I created a new string:

Code:
general.useragent.override
This is what I used for the value, and I got this from Mozilla:

Code:
Mozilla/5.0 (X11; Linux x86_64; rv:2.0b9) Gecko/20100101 Firefox/4.0b9
Next, I modified this value:

Code:
Mozilla/5.0 (X11; Linux x86_64; rv:2.0b9) Gecko/20100101 Firefox/4.0b9/ Slackware Linux
I think this will work!

---------- Post added 01-24-11 at 06:34 AM ----------

And it did!!!!!
 
5 members found this post helpful.
Old 01-24-2011, 07:36 AM   #10
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Linux Mint
Posts: 8,516

Rep: Reputation: 896Reputation: 896Reputation: 896Reputation: 896Reputation: 896Reputation: 896Reputation: 896
Test
 
Old 01-24-2011, 07:38 AM   #11
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Linux Mint
Posts: 8,516

Rep: Reputation: 896Reputation: 896Reputation: 896Reputation: 896Reputation: 896Reputation: 896Reputation: 896
Thank you, it works ok now.

Kind regards
 
Old 01-24-2011, 07:39 AM   #12
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Linux Mint
Posts: 8,516

Rep: Reputation: 896Reputation: 896Reputation: 896Reputation: 896Reputation: 896Reputation: 896Reputation: 896
Quick test to see if 3.6.13 still works
 
Old 01-24-2011, 07:48 AM   #13
mlangdn
Senior Member
 
Registered: Mar 2005
Location: Kentucky
Distribution: Slackware64-current
Posts: 1,387

Original Poster
Rep: Reputation: 181Reputation: 181
On one of the Mozilla help sites, I found out what the new useragent string looked like. However, I could not find this string in about:config. This site:

http://whatsmyuseragent.com/

identified Firefox with that useragent string. Last night, I was going nuts trying to find out where it is, and I still don't know where this string is in Firefox. On a Windows forum, somebody was having trouble with something I now have forgotten. Creating that new string was what was suggested. So I just modified it a bit to see what would happen. I knew I could always delete it from prefs.js if it didn't work. I got lucky!
 
1 members found this post helpful.
Old 01-24-2011, 07:56 AM   #14
brianL
LQ 5k Club
 
Registered: Jan 2006
Location: Oldham, Lancs, England
Distribution: Slackware & Slackware64 14.1
Posts: 7,140
Blog Entries: 52

Rep: Reputation: Disabled
Testing...testing...1, 2, 3...


...yes. Thanks, mlangdn.
 
Old 01-24-2011, 08:34 AM   #15
sahko
Senior Member
 
Registered: Sep 2008
Distribution: Slackware
Posts: 1,041

Rep: Reputation: Disabled
Thanks, it works on Lubuntu too.

PS. Jackpot 777 posts
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
nm-applet icon missing Linux.Girl Red Hat 7 08-21-2010 11:51 AM
[SOLVED] Wine Icon Gone Missing PLEASE HELP! ChrisWho Linux - Software 7 04-05-2010 12:06 AM
Missing program Icon noelc Linux - Newbie 5 05-21-2009 04:03 AM
Samba Icon Missing kaede Linux - Networking 4 08-16-2005 11:40 AM
icon for the gfloppy is missing athenerx Linux - Newbie 1 07-29-2001 10:21 PM


All times are GMT -5. The time now is 01:12 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration