LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Slackware Identifier Icon missing (http://www.linuxquestions.org/questions/slackware-14/slackware-identifier-icon-missing-858199/)

mlangdn 01-23-2011 07:09 PM

Slackware Identifier Icon missing
 
I am using Firefox-4.0b9 from /testing. I never deleted the old profile from 3.6x days. I just noticed that the Slackware identifier icon is now just a generic Linux icon. I checked in about:config, and the general.useragent.extra.linux string is still set to Slackware Linux.

Is there something different to do for FF-4x? This isn't a real problem, just an annoying matter of pride.

enorbet 01-23-2011 10:25 PM

Yup
 
Same here all around. no fix yet.... do like the beta tho except for search bar and status bar 0 search bar crashes sometimes and even with Status4Ever mouseover links still show in addy bar and are usually truncated, but pride is definitely an issue and I hope soon fixed

mlangdn 01-23-2011 11:37 PM

I am in the process of adding back themes, addons and such since blowing away the old profile. I'm gonna find a solution I hope.

mlangdn 01-24-2011 12:14 AM

There is nothing in about:config that helps. Its time for bed now.

mlangdn 01-24-2011 07:11 AM

Back up early and still trying to fix this. Just added a new string to about:config, so this is to see if it worked.

repo 01-24-2011 07:21 AM

For some reason, the beta version from firefox doesn't support the icon thing,
even if it's set in about:config
I'm using 4.0b10pre, and have the same problem.
However when I use the latest version, not beta, it works.

Kind regards

repo 01-24-2011 07:22 AM

This is with 3.6.13
Same config in about:config

Kind regards

brianL 01-24-2011 07:29 AM

I'm using FF 4 beta 9 on 13.1. Got it from Mozilla, and stuck it in /opt. Do I get the Slack icon?
No...

mlangdn 01-24-2011 07:33 AM

All-righty, then. I think I got the daggone thingy fixed. In about:config, I created a new string:

Code:

general.useragent.override
This is what I used for the value, and I got this from Mozilla:

Code:

Mozilla/5.0 (X11; Linux x86_64; rv:2.0b9) Gecko/20100101 Firefox/4.0b9
Next, I modified this value:

Code:

Mozilla/5.0 (X11; Linux x86_64; rv:2.0b9) Gecko/20100101 Firefox/4.0b9/ Slackware Linux
I think this will work!

---------- Post added 01-24-11 at 06:34 AM ----------

And it did!!!!!

repo 01-24-2011 07:36 AM

Test

repo 01-24-2011 07:38 AM

Thank you, it works ok now.

Kind regards

repo 01-24-2011 07:39 AM

Quick test to see if 3.6.13 still works

mlangdn 01-24-2011 07:48 AM

On one of the Mozilla help sites, I found out what the new useragent string looked like. However, I could not find this string in about:config. This site:

http://whatsmyuseragent.com/

identified Firefox with that useragent string. Last night, I was going nuts trying to find out where it is, and I still don't know where this string is in Firefox. On a Windows forum, somebody was having trouble with something I now have forgotten. Creating that new string was what was suggested. So I just modified it a bit to see what would happen. I knew I could always delete it from prefs.js if it didn't work. I got lucky! :)

brianL 01-24-2011 07:56 AM

Testing...testing...1, 2, 3...


...yes. Thanks, mlangdn.

sahko 01-24-2011 08:34 AM

Thanks, it works on Lubuntu too.

PS. Jackpot 777 posts :)


All times are GMT -5. The time now is 10:24 PM.