LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Slackware: how to make SAMBA PDC? (http://www.linuxquestions.org/questions/slackware-14/slackware-how-to-make-samba-pdc-4175497529/)

fjur94 03-08-2014 03:53 PM

Slackware: how to make SAMBA PDC?
 
2 Attachment(s)
i installed samba, configured, created machine and users account, restart smb service etc.. etc... but it isnt working

pics below shows smb.conf and wins 7 error

Ser Olmy 03-09-2014 08:19 AM

"security = user" means you've not configured Samba as either an NT or an Active Directory DC. You've created a standalone server with local user accounts.

You should abandon the notion of setting up a "PDC", as that's a Primary Domain Controller in an ancient non-Active Directory domain. AD DCs have been supported since the release of Samba 4.0.

To create an AD domain, you should first decide whether you want to use BIND or the built-in Samba DNS server. Then run samba-tool domain provision to create an Active Directory domain.

lukkon 03-09-2014 11:28 AM

Do you want to make a NT-like Domain Controller (Samba 3.x) or AD Domain Controller (Samba 4.x)? You can find a lot of tutorials about doing this using Debian or CentOS, doing this on Slackware should be very similar. Remember that you shouldn't create machine accounts, they are created itself when you connect a Windows workstation to domain.

fjur94 03-09-2014 03:38 PM

i solved it, windows 7 isn't compatible with samba... after i tried with windows XP S3, it worked :|

lukkon 03-09-2014 06:07 PM

Quote:

Originally Posted by fjur94 (Post 5131670)
i solved it, windows 7 isn't compatible with samba... after i tried with windows XP S3, it worked :|

But you can change a few things to make Windows 7 work with Samba 3 and if you want to use Samba 4 no changes are needed:)

urulab 03-12-2014 07:52 AM

Put the lines below on a samba.reg file and run on all win7 machines, then try to join.

Code:

Windows Registry Editor Version 5.00
[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\LanManWorkstation\Parameters]
"DNSNameResolutionRequired\=dword:00000000
"DomainCompatibilityMode"=dword:00000001
[HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\System]
"SlowLinkDetectEnabled"=dword:00000000
"DeleteRoamingCache"=dword:00000001
"WaitForNetwork"=dword:00000000
"CompatibleRUPSecurity"=dword:00000001



All times are GMT -5. The time now is 09:16 PM.