LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Slackware- Help installing software (http://www.linuxquestions.org/questions/slackware-14/slackware-help-installing-software-4175457173/)

PeterUK 04-06-2013 08:40 PM

Slackware- Help installing software
 
Hi! I am trying to move to work on slackware but I it has a bit harder than Ubuntu. I nearly have all running on the new Ubuntu and have been taking much longer to get this going on the slackware (I would like to end up xfce just because it looks similar to 10.04 Ubuntu).

I kind of missing the ability to grap package with "apt-get"

I am going to list some software I would like to have in Slackware if possible:

Skype (I took the dynamic version and I didn't installed anything but I am not sure on this, in Ubuntu is working better)

LibreOffice
It suggest here I use:
# wget http://www.rlworkman.net/pkgs/14.0/x...6_64-1_rlw.txz
But it does not work so I search on the address and find:
Code:

libreoffice-4.0.1-x86_64-1_rlw.txz
So I downloaded and then:
Code:

installpkg libreoffice*
But this is not working

Browser: Chrome will not start as root, But I have been using Opera and Firefox is there any different to Chrome?
I have installed Chrome from this website here and here

ISE: I installed from the main xilinx web, I haven't properly test it.

Video Drivers: Inter here How can I find my drivers?

I am getting the themes from here

I installed the VM by: sh VirtualBox-4.2.10-84104-Linux_x86.run install

I would like to install BlueGriffon from here Is it safe?

frankbell 04-06-2013 09:05 PM

I usually pkgtool to install packages on Slackware, mostly out of habit.

Please provide more information.

Did you su to or login as root before issuing the install command? Slackware does not have Ubuntu's "sudo" fetish.

What error messages, if any, did the command throw?

This chapter from the Slackbook gives a pretty good overview Slackware's package management system. The book needs some updating, but this chapter is still accurate.

I usually get packages from slackbuilds.org; if a package has dependencies, the descriptions normally list them. Sometimes I get them from Alien Bob. Very rarely, (maybe twice in the last year), I've compiled software from sources.

PeterUK 04-06-2013 10:10 PM

Quote:

Originally Posted by frankbell (Post 4926588)
Please provide more information.

Did you su to or login as root before issuing the install command? Slackware does not have Ubuntu's "sudo" fetish.

What error messages, if any, did the command throw?

This chapter from the Slackbook gives a pretty good overview Slackware's package management system. The book needs some updating, but this chapter is still accurate.

I usually get packages from slackbuilds.org; if a package has dependencies, the descriptions normally list them. Sometimes I get them from Alien Bob. Very rarely, (maybe twice in the last year), I've compiled software from sources.

Thanks when you said pkgtool you mean like "upgradepkg --install-new /tmp/.." after the build?

Is there a Log for installation? for example for Openoffice I only did "installpkg libreoffice*" Now when I try to open from the menu nothing is appearing, how do I get the error?

I still log in as root, I have create a user but I am not using it yet

zrdc28 04-06-2013 10:40 PM

Download from the link below, put it in /tmp and installpkg "whatever the libre pkg is" and you will be good to go!

http://alien.slackbook.org/blog/libr...-slackware-14/

PeterUK 04-06-2013 10:44 PM

Quote:

Originally Posted by zrdc28 (Post 4926633)
Download from the link below, put it in /tmp and installpkg "whatever the libre pkg is" and you will be good to go!

http://alien.slackbook.org/blog/libr...-slackware-14/

Yes but should I be looking to remove what is already here? How do I know what have it done now?

psionl0 04-07-2013 01:56 AM

Quote:

Originally Posted by PeterUK (Post 4926572)
LibreOffice
It suggest here I use:
# wget http://www.rlworkman.net/pkgs/14.0/x...6_64-1_rlw.txz
But it does not work so I search on the address and find:
Code:

libreoffice-4.0.1-x86_64-1_rlw.txz
So I downloaded and then:
Code:

installpkg libreoffice*
But this is not working

Have you installed JRE?

Quote:

Originally Posted by PeterUK (Post 4926572)
Video Drivers: Inter here How can I find my drivers?

I am getting the themes from here

I installed the VM by: sh VirtualBox-4.2.10-84104-Linux_x86.run install

I would like to install BlueGriffon from here Is it safe?

These are not slackware packages.

catkin 04-07-2013 03:38 AM

Quote:

Originally Posted by PeterUK (Post 4926636)
Yes but should I be looking to remove what is already here? How do I know what have it done now?

Those are difficult questions to answer because you have not told us exactly what you did and what happened (error messages etc.) when you did it.

When you ran installpkg libreoffice* was it as root? Were you in the directory containing the downloaded package? When you wrote "But this is not working", how do you know it did not work?

If what you did did install a package then the package will be listed in /var/log/packages. By looking in there you can find the exact name of the package -- for example libreoffice-4.0.1-x86_64-1alien -- and remove it by running, as root, removepkg libreoffice-4.0.1-x86_64-1alien replacing libreoffice-4.0.1-x86_64-1alien with the name of the package you installed.

Here's my log of installing libreoffice-4.0.1-x86_64-1alien. The repository path of '/home/c/d/Repository/Slackware/Slackware64 14.0/LibreOffice 4.0.1' is not important -- it can be any directory which is convenient for you. The en_GB files are for the British English dictionary. Replace with whatever dictionary you require (files available at http://taper.alienbase.nl/mirrors/pe...ce/pkg64/14.0/) or remove if you do not want a dictionary.

26.2 Version 4.0.1

26.2.1 Download
17mar13
Downloaded these files from http://taper.alienbase.nl/mirrors/pe...ce/pkg64/14.0/ to '/home/c/d/Repository/Slackware/Slackware64 14.0/LibreOffice 4.0.1':
Code:

c:~/.../Slackware/Slackware64 14.0/LibreOffice 4.0.1$ ls -l
total 118M
-rw-r--r-- 1 c users 2.3M Mar 17 11:33 libreoffice-4.0.1-x86_64-1alien.lst
-rw-r--r-- 1 c users  881 Mar 17 11:33 libreoffice-4.0.1-x86_64-1alien.meta
-rw-r--r-- 1 c users  626 Mar 17 11:33 libreoffice-4.0.1-x86_64-1alien.txt
-rw-r--r-- 1 c users 110M Mar 17 11:39 libreoffice-4.0.1-x86_64-1alien.txz
-rw-r--r-- 1 c users  198 Mar 17 11:34 libreoffice-4.0.1-x86_64-1alien.txz.asc
-rw-r--r-- 1 c users  70 Mar 17 11:34 libreoffice-4.0.1-x86_64-1alien.txz.md5
-rw-r--r-- 1 c users  33K Mar 17 11:34 libreoffice-l10n-en_GB-4.0.1-x86_64-1alien.lst
-rw-r--r-- 1 c users  681 Mar 17 11:34 libreoffice-l10n-en_GB-4.0.1-x86_64-1alien.meta
-rw-r--r-- 1 c users  418 Mar 17 11:34 libreoffice-l10n-en_GB-4.0.1-x86_64-1alien.txt
-rw-r--r-- 1 c users 5.5M Mar 17 11:34 libreoffice-l10n-en_GB-4.0.1-x86_64-1alien.txz
-rw-r--r-- 1 c users  198 Mar 17 11:34 libreoffice-l10n-en_GB-4.0.1-x86_64-1alien.txz.asc
-rw-r--r-- 1 c users  81 Mar 17 11:34 libreoffice-l10n-en_GB-4.0.1-x86_64-1alien.txz.md5

26.2.2 Verification
17mar13
Code:

c:~/.../Slackware/Slackware64 14.0/LibreOffice 4.0.1$ md5sum --check *.md5
libreoffice-4.0.1-x86_64-1alien.txz: OK
libreoffice-l10n-en_GB-4.0.1-x86_64-1alien.txz: OK

26.2.3 Previous version removal
[details of removing the previous version snipped]

26.2.4 Installation
17mar13
Code:

root:~# ver=4.0.1; cd '/home/c/d/Repository/Slackware/Slackware64 14.0/LibreOffice 4.0.1' \
    && installpkg libreoffice-$ver-x86_64-1alien.txz  \
    && installpkg libreoffice-l10n-en_GB-4.0.1-x86_64-1alien.txz


catkin 04-07-2013 03:57 AM

Quote:

Originally Posted by psionl0 (Post 4926684)
Quote:

...
I installed the VM by: sh VirtualBox-4.2.10-84104-Linux_x86.run install
...
These are not slackware packages.

True.

I have been installing and upgrading (by removal and fresh install) VirtualBox on Slackware for a few years using these "not Slackware package" files from https://www.virtualbox.org/wiki/Downloads for some years without problems.

The only gotchas have been:
  • The extension packs were not always easy to find on VirtualBox' website
  • The VirtualBox-<version>-Linux_<architecture>.run files must be made executable or run via the sh command.
  • You have to be in the same directory as the VirtualBox-<version>-Linux_<architecture>.run file when running it.
  • The extension packs have to be made available before installing in a VM by VBoxManage extpack install Oracle_VM_VirtualBox_Extension_Pack-<version>.vbox-extpack
  • The installation adds daemons/services I do not want to the local boot script (on Slackware /etc/rc.d/rc.local) -- vboxballoonctrl-service, vboxweb-service and vboxautostart-service. These can be manually commented out.

PeterUK 04-07-2013 07:41 AM

Quote:

Originally Posted by psionl0 (Post 4926684)
Have you installed JRE?

These are not slackware packages.

Actually I have not installed JRE I went close because I have installed JDK for arduino, do I need JRE?

PeterUK 04-07-2013 08:49 AM

Quote:

Originally Posted by PeterUK (Post 4926803)
Actually I have not installed JRE I went close because I have installed JDK for arduino, do I need JRE?

Actually I looked in slackbuilds and JRE is not require for libreoffice (3.6.4) it said only jdk (7u15)

elesmod 04-07-2013 09:16 AM

Quote:

Originally Posted by PeterUK (Post 4926803)
I have installed JDK for arduino, do I need JRE?

If you have JDK, you don't need JRE.

Actually, you should not have them both installed at the same time.


edit:

Maybe you managed to install LibreOffice, but it just didn't appear in your start menu? What happens if you type
Code:

libreoffice
in the terminal?

PeterUK 04-07-2013 03:49 PM

Hi I opened an individual Thread for Libre Office could you please look at here:

Code:

http://www.linuxquestions.org/questions/slackware-14/slackware-help-installing-libreoffice-4175457264/

Alien Bob 04-07-2013 03:55 PM

Please, do not open a new thread for every piece of software you fail to install.
It would be better to read a bit more about creating and installing packages first. I you still have questions afterwards, ask them here.

Required reading materials:

http://docs.slackware.com/slackware:beginners_guide
http://docs.slackware.com/slackbook:...ading_packages
http://docs.slackware.com/howtos:sla...ckbuild_script
http://docs.slackware.com/slackware:slackbuild_scripts

Eric

w1k0 04-09-2013 01:39 AM

PeterUK,

1. Skype

I installed it successfully using the following slackbuild.

2. LibreOffice

I installed it successfully using the package from the following directory.

Because I was disappointed with LibreOffice 4.0.0.3 I installed Apache OpenOffice.

3. Apache OpenOffice

I installed it successfully using the package from the following directory. (It seems that kikinovak removed these packages from his server so ask him to put them back for you.)

4. Chromium

I just installed it successfully for you using the following slackbuild. To compile it you need also libevent package from SlackBuilds.org. It took ages to compile Chromium but consider that as my friendly favor for you. To run Chromium use the command: /usr/lib/chromium/chrome.

5. VirtualBox

I installed it successfully using the following slackbuild. To compile it you need acpica and virtualbox-kernel packages from SlackBuilds.org.

***

All above programs work for me so try to follow my path and install them as well.

Disclaimer:

I used 32-bit versions of the applications for Slackware 14.0. If you use 64-bit system or some older Slackware version feel free to customize the above recipe to your needs.


All times are GMT -5. The time now is 12:20 PM.