LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 08-03-2013, 11:40 AM   #16
san2ban
Member
 
Registered: May 2013
Location: Bengaluru / India
Distribution: Slackware14.1-64bit
Posts: 74

Original Poster
Rep: Reputation: Disabled

Code:
bash-4.2$ cat /etc/suauth
# Format "to-id: from-ID: ACTION"
# A couple of privileged users may su to root
# with their own password
# root:username1,username2:OWNPASS
# Anyone else may not su to root unless
# they are a member of the "wheel" group
root:ALL EXCEPT GROUP wheel DENY
Modified as per su hardening tips, link in my first post
 
Old 08-03-2013, 12:09 PM   #17
e5150
Member
 
Registered: Oct 2005
Location: Sweden
Distribution: Slackware
Posts: 73

Rep: Reputation: 41
Quote:
Originally Posted by san2ban View Post
Code:
root:ALL EXCEPT GROUP wheel DENY
There is supposed to be a colon (and no spaces) between "wheel" and "DENY".
 
Old 08-03-2013, 12:11 PM   #18
wadsworth
Member
 
Registered: Aug 2007
Distribution: Slackware64 13.37
Posts: 214

Rep: Reputation: 64
Maybe needs a colon between "wheel" and "DENY"
Code:
root:ALL EXCEPT GROUP wheel:DENY
 
Old 08-03-2013, 03:24 PM   #19
phoemur
LQ Newbie
 
Registered: Aug 2013
Location: Brazil
Posts: 5

Rep: Reputation: Disabled
I had the same problem, and it's not in the /etc/suauth...
In fact i removed the file and had the same error:

Quote:
su
Password:
su: Authentication failure
The problem ocurred when you changed the permissions of /bin/su, which i solved with:
Quote:
chmod u+s /bin/su
And now everything works again...

But don't forget the colon they said, you need it...

Last edited by phoemur; 08-03-2013 at 03:31 PM.
 
Old 08-03-2013, 03:31 PM   #20
phoemur
LQ Newbie
 
Registered: Aug 2013
Location: Brazil
Posts: 5

Rep: Reputation: Disabled
This happened because when you chown the /bin/su to group wheel it looses the The Set User ID and Set Group ID permissions...
it should be rws instead of just rwx
 
Old 08-04-2013, 02:08 AM   #21
san2ban
Member
 
Registered: May 2013
Location: Bengaluru / India
Distribution: Slackware14.1-64bit
Posts: 74

Original Poster
Rep: Reputation: Disabled
Genlemen
Thanks to e5150 for pointing out the missing semicolon. Problem is solved.
I blindly copied and pasted from the link for su hardening tips. This semicolon should be put there also


Thanks to everybody. This is what makes us slackers
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: Most Common Linux Server's Hardening Tips LXer Syndicated Linux News 0 07-15-2013 07:30 AM
Searching tips for bash script hardening norbert74 Linux - Security 6 02-09-2010 12:26 PM
LXer: Top 20 Linux Server Hardening Security Tips LXer Syndicated Linux News 0 10-30-2009 07:50 PM
Slackware hardening guide tangle Slackware 4 03-14-2005 09:47 PM
Hardening Slackware AhYup Slackware 8 03-07-2005 06:35 PM


All times are GMT -5. The time now is 07:31 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration