LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 08-05-2004, 01:39 PM   #1
eyeliner
Member
 
Registered: Aug 2004
Location: Near...
Distribution: Mandriva 2011.0
Posts: 58

Rep: Reputation: 15
Slackware for the first time. Several issues. Would you help me? Newbie here.




Just installed Slackware 10 today, after using Mandrake for some time now.

Here are my questions:

1)

My sound card (Cirrus Logic Crystal CS4281) after entering X comes up with
an error (Arts being used):

| Sound server informational message:
| Error while initializing the sound driver:
|
| device /dev/dsp can't be opened (No such device)
|
| The sound server will continue, using the null output device

Well, no sound here.

2)

No network! I've been banging my head over and over and i can't find the
solution!

I have a PCMCIA D-Link DFE-670TXD fast ethernet card wich is recognised
at boot, it beeps twice, loud beeps, so it's fine right?
The problem is: What now?

I have a computer with WinXP hooked up to a cable modem and i want to
use it as a gateway. In Windows environment it goes fine, so in Slackware it should as well. However, i have no idea what to do.

3)

Is it possible to shut down the computer in X? I only have the logout
option, having to go to a terminal to shutdown the computer.
And why doesn't he power down by himself? Mandrake did...

Sorry if it is too lame to pose these questions. Any help would be apreciated.

Thanks.
 
Old 08-05-2004, 02:02 PM   #2
Quickdraw
Member
 
Registered: Dec 2003
Location: NY
Distribution: Slackware
Posts: 41

Rep: Reputation: 16
hi eyeliner,
when you first started X did you configure alsa for the sound ??
if not try running alsaconfig from the terminal and then restart X, as for the network not working....what is the output from the lsmod command, maybe the module is't loaded, or are you getting an ip address ?
 
Old 08-05-2004, 02:06 PM   #3
320mb
Senior Member
 
Registered: Nov 2002
Location: pikes peak
Distribution: Slackware, LFS
Posts: 2,577

Rep: Reputation: 47
sound
http://www.linuxquestions.org/questi...+Crystal+CS481

http://www.linuxquestions.org/questi...+Crystal+CS481

network.......

http://www.linuxquestions.org/questi...der=descending
 
Old 08-05-2004, 02:15 PM   #4
gbonvehi
Senior Member
 
Registered: Jun 2004
Location: Argentina (SR, LP)
Distribution: Slackware
Posts: 3,145

Rep: Reputation: 51
About network, try running the command ifconfig to show if your card is being detected, if it shows eth0 then run: netconfig and setup your machine ip or dhcp and your gateway.
 
Old 08-05-2004, 03:44 PM   #5
YBA^[x]
Member
 
Registered: Apr 2004
Location: Denmark
Distribution: Slackware 10.2
Posts: 121

Rep: Reputation: 15
Hey.

For the power off problem.

Uncomment this line (remove the "#"):

#/sbin/modprobe apm

in the #### APM support ### section of /etc/rc.d/rc.modules. This worked for me. I don't know about the log out/shutdown part.

Regards.
 
Old 08-05-2004, 04:22 PM   #6
superbondbond
Member
 
Registered: Nov 2002
Posts: 668

Rep: Reputation: 30
for the network card, since you're using a PCMCIA card, I would recommend letting those scripts handle it rather than the standard networking scripts (/etc/rc.d/rc.inet1). The one you should look at is /etc/pcmcia/network.opts and it looks something like this:
Code:
# Network adapter configuration
#
# The address format is "scheme,socket,instance,hwaddr".
#
# Note: the "network address" here is NOT the same as the IP address.
# See the Networking HOWTO.  In short, the network address is the IP
# address masked by the netmask.
#
case "$ADDRESS" in
*,*,*,*)
    INFO="Sample private network setup"
    # Transceiver selection, for some cards -- see 'man ifport'
    IF_PORT=""
    # Use BOOTP (via /sbin/bootpc, or /sbin/pump)? [y/n]
    BOOTP="n"
    # Use DHCP (via /sbin/dhcpcd, /sbin/dhclient, or /sbin/pump)? [y/n]
    DHCP="n"
    # If you need to explicitly specify a hostname for DHCP requests
    DHCP_HOSTNAME=""
    # Host's IP address, netmask, network address, broadcast address
    IPADDR=""
    NETMASK="255.255.255.0"
    NETWORK="10.0.1.0"
    BROADCAST="10.0.1.255"
    # Gateway address for static routing
    GATEWAY="10.0.1.1"
    # Things to add to /etc/resolv.conf for this interface
    DOMAIN=""
    SEARCH=""
    DNS_1=""
    DNS_2=""
    DNS_3=""
    # NFS mounts, should be listed in /etc/fstab
    MOUNTS=""
    # If you need to override the interface's MTU...
    MTU=""
    # For IPX interfaces, the frame type and network number
    IPX_FRAME=""
    IPX_NETNUM=""
    # Extra stuff to do after setting up the interface
    start_fn () { return; }
    # Extra stuff to do before shutting down the interface
    stop_fn () { return; }
    # Card eject policy options
    NO_CHECK=n
    NO_FUSER=n
    ;;
esac
Just fill in all your appropriate settings and it should initiate everything every time you insert the card. If you connect to multiple networks you separate the different configurations by setting a different scheme for each network like this:
Code:
# Network adapter configuration
#
# The address format is "scheme,socket,instance,hwaddr".
#
# Note: the "network address" here is NOT the same as the IP address.
# See the Networking HOWTO.  In short, the network address is the IP
# address masked by the netmask.
#
case "$ADDRESS" in
scheme1,*,*,*)
    settings for scheme 1
    ;;
scheme2,*,*,*)
    settings for scheme 2
    ;;
esac
Then you would simply change schemes using the command cardctl scheme scheme name

hope that helps
 
Old 08-06-2004, 06:51 AM   #7
eyeliner
Member
 
Registered: Aug 2004
Location: Near...
Distribution: Mandriva 2011.0
Posts: 58

Original Poster
Rep: Reputation: 15


THANKS!

Sound is up. And it shuts down now. Network, however...
I can surf the web, but how can i see the shared file in each computer?

This one is my last remaining question.

Thank you all. I apreciate i.
 
Old 08-06-2004, 07:28 AM   #8
isis
LQ Newbie
 
Registered: Oct 2003
Location: Saarland, Germany
Distribution: Slackware
Posts: 22

Rep: Reputation: 15
If you want to browse a Windows - Network with samba and kde, just open Konqueror in KDE and type

smb:/

You`ll then hopefully see all workgroups in your network and will be able to browse them.
I usually have a link to konqueror with that option on my desktop ( Link to program, command : konqueror smb:/ ).

Anyway, do you use kde?
If so you have to use kdm as loginmanager to shut the pc down from kde menu.

Just comment the section about gdm out in /etc/rc.d/rc.4:

#! /bin/sh
#
# rc.4 This file is executed by init(8) when the system is being
# initialized for run level 4 (XDM)
#
# Version: @(#)/etc/rc.d/rc.4 2.00 02/17/93
#
# Author: Fred N. van Kempen, <waltje@uwalt.nl.mugnet.org>
# At least 47% rewritten by: Patrick J. Volkerding <volkerdi@slackware.com>
#

# Tell the viewers what's going to happen...
echo "Starting up X11 session manager..."

# Try to use GNOME's gdm session manager:
#if [ -x /usr/bin/gdm ]; then
#exec /usr/bin/gdm -nodaemon
#fi

# Not there? OK, try to use KDE's kdm session manager:
if [ -x /opt/kde/bin/kdm ]; then
exec /opt/kde/bin/kdm -nodaemon
fi

# If all you have is XDM, I guess it will have to do:
if [ -x /usr/X11R6/bin/xdm ]; then
exec /usr/X11R6/bin/xdm -nodaemon
fi

# error
echo
echo "Hey, you don't have KDM, GDM, or XDM. Can't use runlevel 4 without"
echo "one of those installed."
sleep 30

# All done.

would look like that .

Hop it helps and good luck.
 
Old 08-06-2004, 10:28 AM   #9
eyeliner
Member
 
Registered: Aug 2004
Location: Near...
Distribution: Mandriva 2011.0
Posts: 58

Original Poster
Rep: Reputation: 15
Thank you!

By using smb:/ i see my workgroup, after selecting it an internal error error rises its ugly head...

libsmbclient reported an error... blah blah...

There is light at the end of the tunnel, is it?
 
Old 08-06-2004, 02:41 PM   #10
isis
LQ Newbie
 
Registered: Oct 2003
Location: Saarland, Germany
Distribution: Slackware
Posts: 22

Rep: Reputation: 15
Is there anything in your logfiles
/var/log/samba and /var/log/messages ?
 
Old 08-06-2004, 08:20 PM   #11
eyeliner
Member
 
Registered: Aug 2004
Location: Near...
Distribution: Mandriva 2011.0
Posts: 58

Original Poster
Rep: Reputation: 15
Everything is now fine!
I used this smb.conf:

[global]
workgroup = Casa
security = share
public = yes
username map = /etc/samba/users.map
writeable = yes

[homes]
browseable = no
writeable = yes

[home]
path = /share
public = yes
only guest = yes
writable = yes

Bad thing is that now appear a few network folder named:
tmp, share, homes in WinXP.

How to remove them?

Probably needs some furtherwriting but i guess that goes out of my league.
Thank for your help people. I apreciate it.

If you have coments, please, comment.

Last edited by eyeliner; 08-06-2004 at 08:24 PM.
 
Old 08-09-2004, 06:10 PM   #12
isis
LQ Newbie
 
Registered: Oct 2003
Location: Saarland, Germany
Distribution: Slackware
Posts: 22

Rep: Reputation: 15
Easiest way to config your samba is probably using swat ( An easy to use webadmin for samba ):


/etc/inetd.conf

# swat is the Samba Web Administration Tool
swat stream tcp nowait.400 root /usr/sbin/swat swat <-- just uncomment this line and reboot or restart your inetd service

Then use your browser to connect to http://localhost:901
Login with your root - account and configure samba just the way you like.
 
Old 08-09-2004, 07:59 PM   #13
WMD
Member
 
Registered: Jul 2004
Location: Florida
Distribution: Slackware, Debian
Posts: 484

Rep: Reputation: 30
Lightbulb

Webmin also has Samba config, along with many other things.
 
Old 08-10-2004, 07:04 AM   #14
eyeliner
Member
 
Registered: Aug 2004
Location: Near...
Distribution: Mandriva 2011.0
Posts: 58

Original Poster
Rep: Reputation: 15
The funny thing is when i connect both my usb modem and network card.
Net access is fine. as Slack gives eth1 for modem and i've put dhcp="yes"
in the eth1 portion of rc.inet1.config.

But when i only connect the modem... eth0 is the modem and net access is
gone, by the obvious reason.

Any workaround?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Various clock issues: Clock shows wrong time only in Knoppmyth, & CMOS time change ? davidbix General 1 04-05-2006 09:58 PM
Newbie Help With Date & Time Jude Lucien Debian 2 10-11-2005 10:21 AM
FTP Issues, very slow response time! dermotti Linux - Networking 4 04-01-2005 09:39 PM
newbie;I am a linux newbie who has installed slackware and have run into a few proble MollyJolly Slackware - Installation 6 06-01-2004 11:21 AM
How To Update To Slackware-Current For a Newbie, By a Newbie :) windsok Slackware 1 09-18-2003 08:53 PM


All times are GMT -5. The time now is 11:33 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration