LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   slackware current - xfce 4.10 shows completely blank black screen (http://www.linuxquestions.org/questions/slackware-14/slackware-current-xfce-4-10-shows-completely-blank-black-screen-4175420105/)

comet.berkeley 08-02-2012 11:36 PM

slackware current - xfce 4.10 shows completely blank black screen
 
xfce 4.10 is running though as I can hit Alt-F4 and the exit menu appears and then click on LOGOUT.

But nothing else shows on the screen.

Here is the .xsession-errors file for a user:
Code:

/usr/bin/startxfce4: X server already running on display :0
xfce4-panel: error while loading shared libraries: libexo-1.so.0: cannot open shared object file: No such file or directory
Thunar: error while loading shared libraries: libexo-1.so.0: cannot open shared object file: No such file or directory
xfdesktop: error while loading shared libraries: libgarcon-1.so.0: cannot open shared object file: No such file or directory
xfce4-volumed: error while loading shared libraries: libkeybinder.so.0: cannot open shared object file: No such file or directory

** (process:3147): WARNING **: Trying to register gtype 'GMountMountFlags' as enum when in fact it is of type 'GFlags'

** (process:3147): WARNING **: Trying to register gtype 'GDriveStartFlags' as enum when in fact it is of type 'GFlags'

** (process:3147): WARNING **: Trying to register gtype 'GSocketMsgFlags' as enum when in fact it is of type 'GFlags'

^[[01mHP Linux Imaging and Printing System (ver. 3.12.6)^[[0m
^[[01mSystem Tray Status Service ver. 2.0^[[0m

Copyright (c) 2001-14 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

^[[35;01mwarning: No hp: or hpfax: devices found in any installed CUPS queue. Exiting.^[[0m

** (process:3153): WARNING **: Trying to register gtype 'GMountMountFlags' as enum when in fact it is of type 'GFlags'

** (process:3153): WARNING **: Trying to register gtype 'GDriveStartFlags' as enum when in fact it is of type 'GFlags'

** (process:3153): WARNING **: Trying to register gtype 'GSocketMsgFlags' as enum when in fact it is of type 'GFlags'
xfsettingsd: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.0.
polkit-gnome-authentication-agent-1: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.0.
blueman-applet: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.0.
Loading configuration plugins
blueman-applet version 1.22 starting
Stale PID, overwriting
Using file config backend
Using file config backend
Using file config backend
Using file config backend
Using file config backend
Using file config backend
Using file config backend
Using file config backend
Using file config backend
Using file config backend

Off hand it looks like libexo-1.so.0 and libgarcon-1.so.0 are missing from the xfce4 packages....

ponce 08-03-2012 12:10 AM

I suppose you forgot to issue a
Code:

slackpkg install-new
before the
Code:

slackpkg upgrade-all
things have been splitted and others have been added.

comet.berkeley 08-03-2012 09:35 AM

Quote:

Originally Posted by ponce (Post 4744666)
I suppose you forgot to issue a
Code:

slackpkg install-new
before the
Code:

slackpkg upgrade-all
things have been splitted and others have been added.

Good suggestion.

I install all packages that start with "lib*"

libexo-1.so.0 and libgarcon-1.so.0 are now where to be found...

fvwm2 works with no problems.

willysr 08-03-2012 09:56 AM

it's
exo-0.8.0-i486-1.txz and garcon-0.2.0-i486-1.txz

ponce 08-03-2012 12:49 PM

Quote:

Originally Posted by comet.berkeley (Post 4745051)
I install all packages that start with "lib*"

following which criteria?
if you want to select what to install and what not, it's assumed that you know what you're doing...
otherwise a full install is advised.

Mobile1 08-03-2012 01:57 PM

Right click on the desktop....you'll find your menu's : )

comet.berkeley 08-05-2012 01:15 PM

Quote:

Originally Posted by willysr (Post 4745073)
it's
exo-0.8.0-i486-1.txz and garcon-0.2.0-i486-1.txz

Thanks Willy!

That fixed the problem.

These packages are misnamed as they actually do include shared runtme libraries:

libexo-1.so.0.0.0
libgarcon-1.so.0.0.0

And the packages should be called

libexo-0.8.0-i486-1.txz and
libgarcon-0.2.0-i486-1.txz

I don't load all packages.

Fvwm2 and xdm work fine for me, but sometimes I use xfce.

T3slider 08-05-2012 04:49 PM

Quote:

Originally Posted by comet.berkeley (Post 4746574)
These packages are misnamed as they actually do include shared runtme libraries:

libexo-1.so.0.0.0
libgarcon-1.so.0.0.0

And the packages should be called

libexo-0.8.0-i486-1.txz and
libgarcon-0.2.0-i486-1.txz

That isn't how packages are named. Generally Slackware just favours upstream naming conventions -- other distros sometimes split packages into lib versions but that isn't the case with Slackware. For example, atk is not named libatk and gmp is not named libgmp. Both the exo and garcon packages exist in the newly created xfce/ directory, so if you want XFCE to work...then obviously you will need to install everything in that directory (unless you want to troubleshoot). They should not be moved to l/ since they are XFCE-specific and they should not be renamed since they are named according to upstream. I don't see a problem here.

comet.berkeley 08-05-2012 05:53 PM

Quote:

That isn't how packages are named. Generally Slackware just favours upstream naming conventions -- other distros sometimes split packages into lib versions but that isn't the case with Slackware...

Both the exo and garcon packages exist in the newly created xfce/ directory, so if you want XFCE to work...then obviously you will need to install everything in that directory (unless you want to troubleshoot)...
Thanks for your post.

I found several more packages missing from my xfce installation.

Most of the time I use fvwm2 to avoid complex window managers with lots of pieces.


All times are GMT -5. The time now is 05:40 PM.