LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 12-15-2010, 02:37 AM   #1
kkmic
Member
 
Registered: Jul 2004
Location: Romania
Distribution: Slackware 13.0
Posts: 55

Rep: Reputation: 16
Question Slackware current x64 dbus related issue


Hello,

I have a dual boot machine with the x64 current Slackware installed.

After one of the recent upgrades using slapt-get, I got into a issue with the latest mesa version and libpthread (if i remember correctly). After solving that (it took me a while since I am quite busy with my job) I had the unpleasant surprise of having KDE crash on me.

Specifically, it crashes when I open Firefox and try to type some address. Apparently, when Firefox is trying to show the awesome bar, it crashes. Same crash when using Opera, also when attempting to type in the address bar.

I get an error similar to the one below (I don't have the exact error):
Code:
could not connect to dbus server org.freedesktop.dbus.error.noserver failed to connect to socket /tmp/dbus-{10 random characters}
I browsed around the web and LQ and found a thread here that addressed a similar issue, but regarding Dolphin here. Another thread that offers some explanation from rworkman on the dbus issue is here.

Since I am not at home ATM I'm curious if anyone else has a similar problem regarding dbus and if this solution (replacing/upgrading dbus) is worth following.

Thank you

Last edited by kkmic; 12-15-2010 at 02:37 AM. Reason: Minor details
 
Old 12-15-2010, 03:22 AM   #2
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 2,447

Rep: Reputation: 875Reputation: 875Reputation: 875Reputation: 875Reputation: 875Reputation: 875Reputation: 875
dbus has already been upgraded in -current.
 
Old 12-15-2010, 03:37 AM   #3
kkmic
Member
 
Registered: Jul 2004
Location: Romania
Distribution: Slackware 13.0
Posts: 55

Original Poster
Rep: Reputation: 16
Well, I cant check ATM the dbus version, but I did an slapt-get -u yesterday and everything was up to date. I'll double check this evening.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
OpenGL rendering issue since slackware -current update devnull10 Slackware 28 11-28-2010 07:13 AM
[SOLVED] DBus 1.3.1 for 13.1 Current? SeRi@lDiE Slackware 11 11-05-2010 12:15 PM
libelf.so.0 not found slackware-current x64 luckyknight Slackware 2 10-22-2010 11:38 AM
Slackware-Current x64 & x86 + Nvidia SqdnGuns Slackware 7 05-24-2009 10:34 AM
Slackware current + gcc issue vexer Slackware 2 08-11-2003 12:05 PM


All times are GMT -5. The time now is 11:28 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration