LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Slackware-current without "free" Opengl for GeForce 8200G M (http://www.linuxquestions.org/questions/slackware-14/slackware-current-without-free-opengl-for-geforce-8200g-m-4175457534/)

marbangens 04-09-2013 02:34 PM

Slackware-current without "free" Opengl for GeForce 8200G M
 
My laptop have an on board nvidia GeForce 8200G M and there is no opengl with:

kernel-3.8.6
libdrm-2.4.42
mesa-9.1.1
xf86-video-nouveau-1.0.4

running slackware current. There is slow, lagy software rendering whit tow or tree
real GPU opengl implementations. This is important to me because my laptop have a slow CPU.
Don't like Nvidias closed drivers.:cry:

Q:1. Are nouveau planing on any opengl support for the card?
Q:2. Can it be that I haven't sett up Xorg correctly?
Q:3. What else can I do about it?

willysr 04-09-2013 03:34 PM

Installing NVidia closed driver is the best solution if nouveau doesn't really keep up with your expectations

TobiSGD 04-09-2013 03:41 PM

The 8000 series should work without much problems with nouveau, this may be a configuration problem.
Please post the output of
Code:

glxinfo | grep render
But as willysr already stated, the nvidia driver will get you better performance and, crucial for laptops, better power-management.

marbangens 04-09-2013 03:49 PM

Code:

bash-4.2$ glxinfo | grep render
direct rendering: Yes
OpenGL renderer string: Gallium 0.4 on NVAA
    GL_MESA_window_pos, GL_NV_blend_square, GL_NV_conditional_render,


TobiSGD 04-09-2013 04:54 PM

So it seems that direct rendering is working, you should have OpenGL support as documented here (your card belongs to the NV50 family). It may be possible that the driver doesn't set the correct clockspeed for your card, but since I currently don't own a Nvidia card I can't say how to test that.

marbangens 04-10-2013 05:59 AM

Quote:

Originally Posted by TobiSGD (Post 4928472)
So it seems that direct rendering is working, you should have OpenGL support as documented here (your card belongs to the NV50 family). It may be possible that the driver doesn't set the correct clockspeed for your card, but since I currently don't own a Nvidia card I can't say how to test that.

I found this not on my card.
7 - It's slow, because proper power management isn't finished yet.

So you maybe right.
I'll think I go with the proprietary driver for now.
Thanks for the help.

ReaperX7 04-10-2013 10:35 PM

Try using the DRIConf package from slackbuilds and see if it helps any with setting some of the features, especially VSync.


All times are GMT -5. The time now is 11:43 PM.