LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 03-14-2006, 07:11 PM   #1
p0f
Member
 
Registered: Feb 2006
Distribution: slackware-current
Posts: 36

Rep: Reputation: 15
Slackware-current --> VSFTPD


Hi all

After upgrading my server to slackware-current today (15/3/06) I found that I had problems connecting to the my ftp server (vsftpd)

Quote:
[R] Connecting to xx.xxx.xxx.xx -> IP=xx.xxx.xxx.xx PORT=21 (attempt # 1)
[R] Connected to xx.xxx.xxx.xx
[R] 220 Welcome to FTP service.
[R] USER xxxx
[R] 331 Please specify the password.
[R] PASS (hidden)
[R] 230 Login successful.
[R] SYST
[R] 500 OOPS: capset
[R] FEAT
[R] 215 UNIX Type: L8
[R] REST 100
[R] 500 OOPS: vsf_sysutil_recv_peek
[R] This site may not allow file resuming
[R] PWD
[R] Connection lost: xx.xxx.xxx.xx
A quick google to figure out what was causing this problem, I came across a site that suggested a simple fix.

Quote:
modprobe capability
So tried this and...


Quote:
[R] Connecting to xx.xxx.xxx.xx -> IP=xx.xxx.xxx.xx PORT=21
[R] Connected to xx.xxx.xxx.xx
[R] 220 Welcome to FTP service.
[R] USER xxxx
[R] 331 Please specify the password.
[R] PASS (hidden)
[R] 230 Login successful.
[R] SYST
[R] 215 UNIX Type: L8
[R] FEAT
[R] 211-Features:
[R] EPRT
[R] EPSV
[R] MDTM
[R] PASV
[R] REST STREAM
[R] SIZE
[R] TVFS
[R] 211 End
[R] PWD
[R] 257 "/home/xxxx"
[R] TYPE A
[R] 200 Switching to ASCII mode.
[R] PASV
I'm still not sure what is exactly causing this problem, previously I was running kernel 2.6.15.3 from testing and upgraded to 2.6.15.6.

So Im guessing a new option has been added to the newer kernel?


A better solution would to be add the "modprobe capability" to your /etc/rc.d/rc.modules.

Anyway, I hope this helps anyone else that has this problem and it _may_ fix this same problem for other distro's.


Regards
 
Old 04-03-2006, 02:46 PM   #2
jymbo
Member
 
Registered: Jan 2003
Posts: 217

Rep: Reputation: 30
Quote:
Originally Posted by p0f
Hi all

After upgrading my server to slackware-current today (15/3/06) I found that I had problems connecting to the my ftp server (vsftpd)



A quick google to figure out what was causing this problem, I came across a site that suggested a simple fix.



So tried this and...




I'm still not sure what is exactly causing this problem, previously I was running kernel 2.6.15.3 from testing and upgraded to 2.6.15.6.

So Im guessing a new option has been added to the newer kernel?


A better solution would to be add the "modprobe capability" to your /etc/rc.d/rc.modules.

Anyway, I hope this helps anyone else that has this problem and it _may_ fix this same problem for other distro's.


Regards
Had a similar problem with vsftpd and Slack Current with the 2.6 kernel which this fixed. Thanks!
 
Old 04-03-2006, 02:55 PM   #3
Alien_Hominid
Senior Member
 
Registered: Oct 2005
Location: Lithuania
Distribution: Hybrid
Posts: 2,247

Rep: Reputation: 53
Should this module also reside in 2.6.16 cause I don't have one?
 
Old 04-05-2006, 08:27 PM   #4
major.tom
Member
 
Registered: Jun 2003
Location: Canada
Distribution: Slackware (current); Gentoo (newbie)
Posts: 142

Rep: Reputation: 15
I recently updated to the stock 2.6.15.6 kernel and encountered this too.

Kudos on the solution.

Alien] you must've built the 2.6.16 kernely yourself, right? You probably just need to config the kernel so it builds that module. I had a peek at the config file for the stock /testing 2.6 kernel, and there's an entry under Security, so I would look there.

I'm not positive, but it might help...

Garry
 
Old 04-10-2006, 08:06 PM   #5
Linux.tar.gz
Senior Member
 
Registered: Dec 2003
Location: Paris
Distribution: Slackware forever.
Posts: 2,227

Rep: Reputation: 86
Yes it's the in the section:

Enable different security models
--------->Default Linux Capabilities

You have to enable it as a module if you want to use the powerful BSD secure levels.
 
Old 09-18-2006, 01:00 PM   #6
tstrong12
LQ Newbie
 
Registered: Aug 2005
Posts: 3

Rep: Reputation: 0
Quote:
Originally Posted by Linux.tar.gz
Yes it's the in the section:

Enable different security models
--------->Default Linux Capabilities

You have to enable it as a module if you want to use the powerful BSD secure levels.

I am running:
Linux version 2.4.21-47.EL (bhcompile@hs20-bc1-1.build.redhat.com) (gcc version 3.2.3 20030502 (Red Hat Linux 3.2.3-54)

I am fairly new to administering Linux systems so for this version is it as simple as enabling another module as well? I've tried the modprobe fix and get: "modprobe: Can't locate module capability"

Thanks in advance,
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
slackware current? priller Slackware 24 07-09-2005 10:15 AM
how do you keep up with slackware-current? elyk Slackware 33 05-07-2005 11:21 PM
slackware-current how to salahuddin_66 Slackware 9 02-17-2005 07:42 AM
slackware current mustafa Slackware 7 02-08-2005 09:50 PM
slackware 8.1 iso vs slackware current illtbagu Slackware 9 02-26-2003 07:10 PM


All times are GMT -5. The time now is 09:46 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration