LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Slackware-current --> VSFTPD (http://www.linuxquestions.org/questions/slackware-14/slackware-current-vsftpd-424886/)

p0f 03-14-2006 08:11 PM

Slackware-current --> VSFTPD
 
Hi all

After upgrading my server to slackware-current today (15/3/06) I found that I had problems connecting to the my ftp server (vsftpd)

Quote:

[R] Connecting to xx.xxx.xxx.xx -> IP=xx.xxx.xxx.xx PORT=21 (attempt # 1)
[R] Connected to xx.xxx.xxx.xx
[R] 220 Welcome to FTP service.
[R] USER xxxx
[R] 331 Please specify the password.
[R] PASS (hidden)
[R] 230 Login successful.
[R] SYST
[R] 500 OOPS: capset
[R] FEAT
[R] 215 UNIX Type: L8
[R] REST 100
[R] 500 OOPS: vsf_sysutil_recv_peek
[R] This site may not allow file resuming
[R] PWD
[R] Connection lost: xx.xxx.xxx.xx
A quick google to figure out what was causing this problem, I came across a site that suggested a simple fix.

Quote:

modprobe capability
So tried this and...


Quote:

[R] Connecting to xx.xxx.xxx.xx -> IP=xx.xxx.xxx.xx PORT=21
[R] Connected to xx.xxx.xxx.xx
[R] 220 Welcome to FTP service.
[R] USER xxxx
[R] 331 Please specify the password.
[R] PASS (hidden)
[R] 230 Login successful.
[R] SYST
[R] 215 UNIX Type: L8
[R] FEAT
[R] 211-Features:
[R] EPRT
[R] EPSV
[R] MDTM
[R] PASV
[R] REST STREAM
[R] SIZE
[R] TVFS
[R] 211 End
[R] PWD
[R] 257 "/home/xxxx"
[R] TYPE A
[R] 200 Switching to ASCII mode.
[R] PASV
I'm still not sure what is exactly causing this problem, previously I was running kernel 2.6.15.3 from testing and upgraded to 2.6.15.6.

So Im guessing a new option has been added to the newer kernel?


A better solution would to be add the "modprobe capability" to your /etc/rc.d/rc.modules.

Anyway, I hope this helps anyone else that has this problem and it _may_ fix this same problem for other distro's.


Regards

jymbo 04-03-2006 03:46 PM

Quote:

Originally Posted by p0f
Hi all

After upgrading my server to slackware-current today (15/3/06) I found that I had problems connecting to the my ftp server (vsftpd)



A quick google to figure out what was causing this problem, I came across a site that suggested a simple fix.



So tried this and...




I'm still not sure what is exactly causing this problem, previously I was running kernel 2.6.15.3 from testing and upgraded to 2.6.15.6.

So Im guessing a new option has been added to the newer kernel?


A better solution would to be add the "modprobe capability" to your /etc/rc.d/rc.modules.

Anyway, I hope this helps anyone else that has this problem and it _may_ fix this same problem for other distro's.


Regards

Had a similar problem with vsftpd and Slack Current with the 2.6 kernel which this fixed. Thanks!

Alien_Hominid 04-03-2006 03:55 PM

Should this module also reside in 2.6.16 cause I don't have one?

major.tom 04-05-2006 09:27 PM

I recently updated to the stock 2.6.15.6 kernel and encountered this too.

Kudos on the solution.

Alien] you must've built the 2.6.16 kernely yourself, right? You probably just need to config the kernel so it builds that module. I had a peek at the config file for the stock /testing 2.6 kernel, and there's an entry under Security, so I would look there.

I'm not positive, but it might help...

Garry

Linux.tar.gz 04-10-2006 09:06 PM

Yes it's the in the section:

Enable different security models
--------->Default Linux Capabilities

You have to enable it as a module if you want to use the powerful BSD secure levels.

tstrong12 09-18-2006 02:00 PM

Quote:

Originally Posted by Linux.tar.gz
Yes it's the in the section:

Enable different security models
--------->Default Linux Capabilities

You have to enable it as a module if you want to use the powerful BSD secure levels.


I am running:
Linux version 2.4.21-47.EL (bhcompile@hs20-bc1-1.build.redhat.com) (gcc version 3.2.3 20030502 (Red Hat Linux 3.2.3-54)

I am fairly new to administering Linux systems so for this version is it as simple as enabling another module as well? I've tried the modprobe fix and get: "modprobe: Can't locate module capability"

Thanks in advance,


All times are GMT -5. The time now is 07:26 AM.