LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   slackware-current problem (http://www.linuxquestions.org/questions/slackware-14/slackware-current-problem-45210/)

KenHan 02-13-2003 11:07 AM

slackware-current problem
 
I've tried slackware-current several times the last few months,
everytime but once I've encountered a strange problem (I've used FULL Install every time) the problem is that my machine reboots after 20-30 seconds after login. And then I just tried again the other day and reinstalled slack-current, and it didn't reboot (same install method)
I ran it for several days without any problems at all, and then I updated some stuff, and when I rebooted the problem occured again.

I wiped the install and did a fresh install with the same cd that worked the last time, but the machine kept rebooting again. So I went back to slackware 8.1 which works beutifully, never fails.

I know for sure it is no hardware problem in terms that my machine is broken or something, instead it is something to do with slack-current/2.4.19 that missinterpreter my hardware configuration in some way.

I've noticed there are several errors occuring in the bootupsequence something about a"i810_rng" which as far as I've found out is some kind of random function for intel 810 chipset motherboard (I have a intel 850 chipset on my machine though) could that be the problem ?
if thats likely the problem, how do I remove that from the start?

Another error that displays is "rivafb" I don't know if thats the right driver either because I do have a "asus nvidia geoforce 3" card.

I'd apreciate any help cause that slack-current was beutiful and so very fast, I've saved a syslog which I will paste in this message.
syslog:
Feb 6 20:02:33 Khan_LinuX kernel: Linux version 2.4.19 (root@midas) (gcc version 3.2) #1 Sun Aug 18 13:24:13 PDT 2002
Feb 6 20:02:33 Khan_LinuX kernel: BIOS-e820: 0000000000000000 - 000000000009fc00 (usable)
Feb 6 20:02:33 Khan_LinuX kernel: BIOS-e820: 000000000009fc00 - 00000000000a0000 (reserved)
Feb 6 20:02:33 Khan_LinuX kernel: BIOS-e820: 00000000000f0000 - 0000000000100000 (reserved)
Feb 6 20:02:33 Khan_LinuX kernel: BIOS-e820: 0000000000100000 - 000000001fff0000 (usable)
Feb 6 20:02:33 Khan_LinuX kernel: BIOS-e820: 000000001fff0000 - 000000001fff3000 (ACPI NVS)
Feb 6 20:02:33 Khan_LinuX kernel: BIOS-e820: 000000001fff3000 - 0000000020000000 (ACPI data)
Feb 6 20:02:33 Khan_LinuX kernel: BIOS-e820: 00000000ffb00000 - 0000000100000000 (reserved)
Feb 6 20:02:33 Khan_LinuX kernel: On node 0 totalpages: 131056
Feb 6 20:02:33 Khan_LinuX kernel: zone(0): 4096 pages.
Feb 6 20:02:33 Khan_LinuX kernel: zone(1): 126960 pages.
Feb 6 20:02:33 Khan_LinuX kernel: zone(2): 0 pages.
Feb 6 20:02:33 Khan_LinuX kernel: Kernel command line: BOOT_IMAGE=SlackWare ro root=301 hdc=ide-scsi hdd=ide-scsi
Feb 6 20:02:33 Khan_LinuX kernel: ide_setup: hdc=ide-scsi
Feb 6 20:02:33 Khan_LinuX kernel: ide_setup: hdd=ide-scsi
Feb 6 20:02:33 Khan_LinuX kernel: Detected 1980.379 MHz processor.
Feb 6 20:02:33 Khan_LinuX kernel: Console: colour dummy device 80x25
Feb 6 20:02:33 Khan_LinuX kernel: Calibrating delay loop... 3945.26 BogoMIPS
Feb 6 20:02:33 Khan_LinuX kernel: Mount-cache hash table entries: 8192 (order: 4, 65536 bytes)
Feb 6 20:02:33 Khan_LinuX kernel: Buffer-cache hash table entries: 32768 (order: 5, 131072 bytes)
Feb 6 20:02:33 Khan_LinuX kernel: Page-cache hash table entries: 131072 (order: 7, 524288 bytes)
Feb 6 20:02:33 Khan_LinuX kernel: CPU: Intel(R) Pentium(R) 4 CPU 1.80GHz stepping 02
Feb 6 20:02:34 Khan_LinuX kernel: POSIX conformance testing by UNIFIX
Feb 6 20:02:34 Khan_LinuX kernel: mtrr: v1.40 (20010327) Richard Gooch (rgooch@atnf.csiro.au)
Feb 6 20:02:34 Khan_LinuX kernel: mtrr: detected mtrr type: Intel
Feb 6 20:02:34 Khan_LinuX kernel: Unknown bridge resource 0: assuming transparent
Feb 6 20:02:34 Khan_LinuX kernel: Unknown bridge resource 2: assuming transparent
Feb 6 20:02:34 Khan_LinuX kernel: Initializing RT netlink socket
Feb 6 20:02:34 Khan_LinuX kernel: Starting kswapd
Feb 6 20:02:35 Khan_LinuX kernel: Console: switching to colour frame buffer device 100x37
Feb 6 20:02:35 Khan_LinuX kernel: pty: 512 Unix98 ptys configured
Feb 6 20:02:35 Khan_LinuX kernel: ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
Feb 6 20:02:35 Khan_LinuX kernel: ICH2: IDE controller on PCI bus 00 dev f9
Feb 6 20:02:35 Khan_LinuX kernel: ICH2: chipset revision 4
Feb 6 20:02:35 Khan_LinuX kernel: ICH2: not 100%% native mode: will probe irqs later
Feb 6 20:02:35 Khan_LinuX kernel: ide0: BM-DMA at 0xf000-0xf007, BIOS settings: hda:DMA, hdb:DMA
Feb 6 20:02:35 Khan_LinuX kernel: ide1: BM-DMA at 0xf008-0xf00f, BIOS settings: hdc:DMA, hdd:DMA
Feb 6 20:02:35 Khan_LinuX kernel: hda: WDC WD1200JB-00CRA0, ATA DISK drive
Feb 6 20:02:35 Khan_LinuX kernel: hdb: WDC WD1200JB-75CRA0, ATA DISK drive
Feb 6 20:02:35 Khan_LinuX kernel: hdc: Hewlett-Packard DVD Writer 200, ATAPI CD/DVD-ROM drive
Feb 6 20:02:35 Khan_LinuX kernel: hdd: PLEXTOR CD-R PX-320A, ATAPI CD/DVD-ROM drive
Feb 6 20:02:35 Khan_LinuX kernel: ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
Feb 6 20:02:35 Khan_LinuX kernel: ide1 at 0x170-0x177,0x376 on irq 15
Feb 6 20:02:35 Khan_LinuX kernel: hdb: setmax LBA 234441648, native 234375000
Feb 6 20:02:35 Khan_LinuX kernel: ide-floppy driver 0.99.newide
Feb 6 20:02:35 Khan_LinuX kernel: RAMDISK driver initialized: 16 RAM disks of 7777K size 1024 blocksize
Feb 6 20:02:35 Khan_LinuX kernel: ide-floppy driver 0.99.newide
Feb 6 20:02:35 Khan_LinuX kernel: kmod: failed to exec /sbin/modprobe -s -k scsi_hostadapter, errno = 2
Feb 6 20:02:35 Khan_LinuX last message repeated 2 times
Feb 6 20:02:35 Khan_LinuX kernel: 8regs : 2304.000 MB/sec
Feb 6 20:02:35 Khan_LinuX kernel: 32regs : 1415.200 MB/sec
Feb 6 20:02:35 Khan_LinuX kernel: pIII_sse : 2589.200 MB/sec
Feb 6 20:02:35 Khan_LinuX kernel: pII_mmx : 2279.200 MB/sec
Feb 6 20:02:35 Khan_LinuX kernel: p5_mmx : 2307.200 MB/sec
Feb 6 20:02:36 Khan_LinuX kernel: raid5: using function: pIII_sse (2589.200 MB/sec)
Feb 6 20:02:36 Khan_LinuX kernel: VFS: Mounted root (ext3 filesystem) readonly.
Feb 6 20:02:36 Khan_LinuX kernel: Vendor: HP Model: DVD Writer 200j Rev: 1.27
Feb 6 20:02:36 Khan_LinuX kernel: Type: CD-ROM ANSI SCSI revision: 02
Feb 6 20:02:36 Khan_LinuX kernel: Vendor: PLEXTOR Model: CD-R PX-320A Rev: 1.01
Feb 6 20:02:36 Khan_LinuX kernel: Type: CD-ROM ANSI SCSI revision: 02
Feb 6 20:02:36 Khan_LinuX kernel: Attached scsi CD-ROM sr0 at scsi0, channel 0, id 0, lun 0
Feb 6 20:02:36 Khan_LinuX kernel: Attached scsi CD-ROM sr1 at scsi0, channel 0, id 1, lun 0
Feb 6 20:02:36 Khan_LinuX kernel: sr0: scsi3-mmc drive: 32x/32x writer cd/rw xa/form2 cdda tray
Feb 6 20:02:36 Khan_LinuX kernel: sr1: scsi3-mmc drive: 40x/40x writer cd/rw xa/form2 cdda tray
Feb 6 20:02:36 Khan_LinuX kernel: rivafb: cannot reserve FB region
Feb 6 20:02:36 Khan_LinuX kernel: PCI: Setting latency timer of device 00:1f.2 to 64
Feb 6 20:02:36 Khan_LinuX kernel: PCI: Setting latency timer of device 00:1f.4 to 64
Feb 6 20:02:36 Khan_LinuX kernel: i810 TCO timer init: failed to reset NO_REBOOT flag, reboot disabled by hardware
Feb 6 20:02:36 Khan_LinuX kernel: i810_rng: RNG not detected
Feb 6 20:02:36 Khan_LinuX kernel: rivafb: cannot reserve FB region
Feb 6 20:02:36 Khan_LinuX kernel: i810 TCO timer init: failed to reset NO_REBOOT flag, reboot disabled by hardware
Feb 6 20:02:37 Khan_LinuX kernel: i810_rng: RNG not detected
Feb 6 20:02:37 Khan_LinuX kernel: rivafb: cannot reserve FB region
Feb 6 20:02:37 Khan_LinuX kernel: i810 TCO timer init: failed to reset NO_REBOOT flag, reboot disabled by hardware
Feb 6 20:02:37 Khan_LinuX kernel: usb.c: USB device 2 (vend/prod 0x5e3/0x502) is not claimed by any active driver.
Feb 6 20:02:37 Khan_LinuX kernel: i810_rng: RNG not detected
Feb 6 20:02:37 Khan_LinuX kernel: rivafb: cannot reserve FB region
Feb 6 20:02:37 Khan_LinuX kernel: i810 TCO timer init: failed to reset NO_REBOOT flag, reboot disabled by hardware
Feb 6 20:02:37 Khan_LinuX kernel: i810_rng: RNG not detected
Feb 6 20:02:37 Khan_LinuX kernel: rivafb: cannot reserve FB region
Feb 6 20:02:37 Khan_LinuX kernel: i810 TCO timer init: failed to reset NO_REBOOT flag, reboot disabled by hardware
Feb 6 20:02:37 Khan_LinuX kernel: i810_rng: RNG not detected
Feb 6 20:02:37 Khan_LinuX kernel: rivafb: cannot reserve FB region
Feb 6 20:02:37 Khan_LinuX kernel: i810 TCO timer init: failed to reset NO_REBOOT flag, reboot disabled by hardware
Feb 6 20:02:37 Khan_LinuX kernel: i810_rng: RNG not detected
Feb 6 20:02:37 Khan_LinuX kernel: rivafb: cannot reserve FB region
Feb 6 20:02:37 Khan_LinuX kernel: i810 TCO timer init: failed to reset NO_REBOOT flag, reboot disabled by hardware
Feb 6 20:02:37 Khan_LinuX kernel: i810_rng: RNG not detected
Feb 6 20:02:37 Khan_LinuX kernel: rivafb: cannot reserve FB region
Feb 6 20:02:37 Khan_LinuX kernel: i810 TCO timer init: failed to reset NO_REBOOT flag, reboot disabled by hardware
Feb 6 20:02:37 Khan_LinuX kernel: i810_rng: RNG not detected
Feb 6 20:02:37 Khan_LinuX kernel: rivafb: cannot reserve FB region
Feb 6 20:02:37 Khan_LinuX kernel: i810 TCO timer init: failed to reset NO_REBOOT flag, reboot disabled by hardware
Feb 6 20:02:37 Khan_LinuX kernel: i810_rng: RNG not detected
Feb 6 20:02:37 Khan_LinuX kernel: rivafb: cannot reserve FB region
Feb 6 20:02:37 Khan_LinuX kernel: i810 TCO timer init: failed to reset NO_REBOOT flag, reboot disabled by hardware
Feb 6 20:02:37 Khan_LinuX kernel: i810_rng: RNG not detected
Feb 6 20:02:37 Khan_LinuX kernel: rivafb: cannot reserve FB region
Feb 6 20:02:37 Khan_LinuX kernel: i810 TCO timer init: failed to reset NO_REBOOT flag, reboot disabled by hardware
Feb 6 20:02:37 Khan_LinuX kernel: i810_rng: RNG not detected
Feb 6 20:02:37 Khan_LinuX kernel: rivafb: cannot reserve FB region
Feb 6 20:02:37 Khan_LinuX kernel: i810 TCO timer init: failed to reset NO_REBOOT flag, reboot disabled by hardware
Feb 6 20:02:37 Khan_LinuX kernel: i810_rng: RNG not detected

end syslog

Sorry for the big post,
and thanks in advance for any help you can provide..

//Kenneth

hkslacker 02-13-2003 11:52 AM

From the output it looks like the kernel is loading the rivafb. Are you requesting that this be loaded with your kernel?

If not, then your running kernel has builtin rivafb support which is probably causing your problem.. There is no need to use rivafb support even though you have an nvidia chipset. Try <<lsmod>> at a root prompt and see if the rivafb shows up. If so do the following: <<rmmod rivafb>>. This will only work if rivafb support has been compiled to added as a module.

I have had similar problems compiling custom kernels and trying out the rivafb support. So now I just leave out the rivafb support: causes too many problems: I have a GeForce 2 card. Or if you still want to mess with rivafb support, compile your kernel to have rivafb support loaded as a module. Then you can modprobe rivafb to insert the module to see what happens.

So what's the solution to your problem? Compile a custom kernel and leave out the rivafb support and use it in place of the kernel that you're using.

Hank

KenHan 02-14-2003 06:26 AM

I've tried to use "rmmod rivafb" but it says it cannot find the module,
and I've tried to manually rename the module to stop it from loading,
nothing works and I do not know enough yet to really dig into it.

I've used a full install and the bare.i (default-kernel) or whatever it is called when I've installed. I have not requested anything special neither have I tried to change the kernel modules ... I've just run a full install right of the bat.

The problem with trying the solution you suggested is that I cannot keep my system going more than 30 sec .. (unless I can do it from slack 8.1 .. cause that one works perfect)

I think it is strange, and I would think other people would experince the same problem that has similar hardware setup .. hmm ..

dunno what to do .. but I know I wanna switch to slack-current cause it was super ..:)

thanks for your help ..

//KenHan

DaOne 02-14-2003 08:29 AM

I have the same problem...but not with rivafb. I am using a Radeon 9700...which isn't the problem because the support is limited to VESA. My problem seems to stem from uhci and USB support. I even loaded the bare.i kernel, and disabled the USB controller in the BIOS...the kernel still tried to load it. So...I downloaded slack-current again, from a different mirror, and got the same thing. Of course, I can't keep the system up long enough to recompile the kernel, so all I can do is go back to slack 8.1. The only thing that has kind of worked for me so far is to install 8.1, upgrade the kernel to 2.4.19, then do a custom compile starting with the .config from the 2.4.18 kernel. Now as for upgrading the rest of the packages...it never seems to work right. At the moment, I have all of the packages upgraded, but can't detect my mouse...USB, or PS/2. Also, if I try to add support to the kernel for my sound card (ymfpci module), the system hangs at that point. I get past this my just keeping it as a module. Frustrating.

It sure would be nice to get this resolved...although I guess this is why it is still beta.

hkslacker 02-14-2003 08:36 AM

compile a custom kernel
 
Sounds like no matter what you do, you're still getting a kernel that has built in rivafb support. This was listed as experimental in the 2.4.18 kernel. Maybe it should have stayed that way. I take it then that all 2.4.19 kernels with Slackware have rivafb builtin instead of being compiled as a module or just plain being left out?

By the way, this I850 stuff. Is this the IO chipset on your board?
Must be a new one. Didn't see it in the 2.4.18 kernel. Maybe you'll have to download the 2.4.20 kernel source from www. kernel.org.

Anyway, if you compile your own kernel, leave out the agpgart support. Use the nv driver for X. If you want high performance (OPENGL), download the drivers from Nvidia's website. Their drivers have their own agpgart support. They work quite well.

So if rivafb is indeed the problem, you'll have to find a way to work around the problem. If you installed the whole ball of wax, then you should have the kernel-source-2.4.19 installed in the usr/src/kernel-source-2.4.18 directory. Build another kernel.

You can still get into the system without wiping it out by using a rescue diskette. This will give you a 2.4.18 kernel. I don't know how you have your system set up? You might have to mount your /usr , /var , /home directories ( mount /dev/hdxx /usr ....., etc) depending on if you created different partitions during the primary installation.

Copy the /usr/src/kernel-souce-2.4.19 directory to your /home directory (to avoid messing up your headers). Change to that directory. Do a <<make mrproper>> (Read the README file), <<make xconfig>>, <<make dep>> , <<make bzImage>>, <<make modules>>, <<make install>>. I think you'll have to rerun LILO. Read the README file. Read the README file in the /kernel-source-2.4.19 directory. Am I repeating myself?

On your system--as fast as it is-- I don't think it sould take more than 2 hours. I get the impression that you're hesitant to try building your own kernel. About the only mistake (hopefully) you could probably make is not running LILO. But you can still get back in with the rescue diskette (2.4.18 kernel!!!) and fix your problems. I.e. rerun LILO, edit your lilo.conf file, build another kernel.

Have fun,

hkslacker

P.S. build another kernel

hkslacker 02-14-2003 09:12 AM

If you can keep it running?
 
If you can keep Slackware-current up and running, copy the source tree for 2.4.18 onto your hard disk and make a custom kernel from it?

Or just copy over the kernel using the 2.4.18 setup from 8.1 (vmlinux or whatever) in the /boot directory and make sure the symlinks are correct in the / directory and that you have the lib/modules/2.4.18 copied over into the /lib/modules directory. Rerun LILO and see what happens.

KenHan 02-14-2003 01:14 PM

I really apreciate that you're spending time and effort helping me with this!! I will try to follow that compile path (although I am scared shitless to compile the kernel ... hehehe ) not the actual command typing thing. .but the endless options and shit which I do not have a clue on most of them ..

Can I find a "bare.i" somewhere such as the one sent with the -current but based on another version and select that using the install part ??? (last desperate try to squirm my way out of building custom kernel) ..
*smile*

have a good one ..

//KenHan

DaOne 02-14-2003 07:13 PM

Compiling a kernel isn't hard at all...just make sure to follow the steps exactly. It takes about 30 minutes total on my machine. I find that it's easier to follow the steps in the link below...this way you'll still have the old kernel in case things don't work out (I know the kernel you have doesn't do much good...but for the future it is nice).



http://www.p-two.net/modules.php?op=...=article&sid=5

sparks40 03-21-2003 07:21 PM

Gentlemen:
It was with great anticipation that I installed the new version 9.0 this afternoon. Unfortunately, I am experiencing the very same problem as described by KenHan. I am using a Gigabyte mother board with an onboard Intel 82845G/GL chip set.

While your suggestion to recompile under Salckware 8.1 seems reasonable, that version will not recognize my Intel PRO 100 VE Network adapter. While the latter has been fixed in 9.0, the former is still a major problem. I wonder how many other neubies out there are in the same position... wanting to use the power and stability of one of the oldest distros in existance and yet undable to do so.

If anyone has compiled such a kernel and has it working, making it available for download would be doing a great srvice to those of us who are currently not able to take advantage of Slackware.

PS: Seems strange that my system works fine under Red Hat 8.0.94, Mandrake 9.1 beta, Libranet 2.0, Morphix, Knoppix, JAMD .5, etc.

KenHan 03-22-2003 06:28 AM

Unfortunate
 
It's very unfortunate that things like that happends, cause that will only make people think slackware is too hard for a regular user.

I've tried to post about it in different corners of the Internet, and although people are friendly and suggest things, the solutions aren't always the simplest solutions (not for a linux apprentice).

There's one thing I do not grasp.

somewhere in some file there has to be a reference to that "i810_rng" module to load? Why can't I just put a remark on that to prevent it from loading?

I cannot find that occurence, and thus not make a remark on it ...
am I "driving in the wrong lane" here or what ?

Since I do not have such a chip, then the module doesn't load hence I cannot "unload" it or remove it using the regular commands for modules ...

Does anyone know where the "list" of modules resides that will attempt to be loaded during startup ?

I cannot find any reference in rc.modules, and not in modules.conf ..
and I do not know where to look for it ..

I found 2 references in /boot/config-ide.2.4.20
but I've got a feeling it could be dangerous tampering with that file without really knowing what I'm doing with it.. :)

Thanks in advance for any kind of help..

//KenHan

DaOne 03-22-2003 07:58 AM

Ha! I had the same problem some time ago...i810-tco...do lsmod and see if this is loaded...rmmod i810-tco to remove it. You'll need to be quick with this so the machine doesn't reboot before you remove it. This is support for Watchdog Timers. Also...i810_rng...Random Number Generator for the Intel i810 chip. i810_rng will just give you all of the errors...i810-tco will reboot the machine. Remove Watchdog Timer Support, and the Random Number Generator support (for the i810 chip) from your kernel and recompile.

DaOne 03-22-2003 08:07 AM

By the way...both of these options are located in the Character Devices section of your kernel config menu. Completely remove Watchdog Timer support...then underneath that you'll see the Intel i8x0 Random Number Generator support option...remove that as well. Just be sure to recompile. You'll know even before you change the configuration if this will work...after you rmmod i810-tco, if the machine does not reboot, then you know this will work. :)

Excalibur 03-22-2003 08:19 AM

The /boot/config... is the config file used to build the kernel. If the device was enabled to be builtin to the kernel then you cannot simply remark it out. There may be a kernel parameter that might disable the agp options. You may want to review kernel_source/Documentation/kernel-parameters.txt file.

You could try to use a Slack 8.1 kernel boot disk under 2.4.18 kernel. Use the rdev command to set the root partition for it to mount. You will probably get many errors because the modules will not load and stuff. But it should at least boot to allow you to build a new kernel and install it.

sparks40 03-22-2003 09:45 AM

DaOne:
Thanks for your concern and contribution. I am pleased to report that removal of the i810-tco module did in fact allow me to finally log in as root and to remain so for as long as I wanted to. Not having any knowlegdge of the 1810 I would appreciate knowing:
1.) will the removal of the Watchdog Timers have any impact on normal usage of the system?
2.) does this chip have anything to do with the logout procedure which just gives me a blank screen and does not show the shutdown messages of the machine (machine does not shut down automatically)?

Excalibur:
Thanks for your input as well. I will check the /boot/config file shortly. I was hoping to find a file with all the responses to the questions asked in the kernel compile process and to just eliminate the reference to i810 and compile from there. Can this be done?

Excalibur 03-22-2003 09:56 AM

Note that the /boot/config.... file is just a copy that can be put in proper place if desired. The actual config file used during a compile is located in the kernel source directory and is called ".config". Please note the period in front. It is a hidden file. Usually it is /usr/src/linux/.config. You can copy it into the tree overwriting the default and then run "make oldconfig". Proceed as normal to build new kernel.

If removing the i810 modules resolved the issue then they must be compiled as modules, there should be a kernel option to disable it all together. Then the module cannot load and neither will it be built.


All times are GMT -5. The time now is 07:13 AM.