LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 03-20-2007, 12:25 PM   #1
dulait
LQ Newbie
 
Registered: Apr 2005
Location: Zurich, Switzerland
Distribution: Slackware
Posts: 5

Rep: Reputation: 0
slackware current - java / xcb bug


Could anyone else report problems with java applications /applets (using AWT) after upgrading to -current?

See also: #http://lwjgl.org/forum/index.php/topic,2168.0.html

Thanks for your reply.
 
Old 03-21-2007, 05:40 AM   #2
simcox1
Member
 
Registered: Mar 2005
Location: UK
Distribution: Slackware
Posts: 794
Blog Entries: 2

Rep: Reputation: 30
The jre browser plugin doesn't work. I got an error similar to the one in that link.
 
Old 03-21-2007, 06:06 AM   #3
kiroff
LQ Newbie
 
Registered: Aug 2005
Location: Varna, Bulgaria
Distribution: Slackware Linux
Posts: 20

Rep: Reputation: 0
Angry

Anything using java crashes with:

Quote:
java: xcb_xlib.c:50: xcb_xlib_unlock: Assertion `c->xlib.lock' failed.
 
Old 03-21-2007, 10:03 PM   #4
cathectic
Member
 
Registered: Sep 2004
Location: UK, Europe
Distribution: Slackware64
Posts: 761

Rep: Reputation: 34
It's actually a bug in Java; but there is a workaround for libxcb, which has been submitted to Pat by others (so hopefully it will be fixed in Slackware -current soon).
 
Old 03-21-2007, 11:51 PM   #5
MS3FGX
Guru
 
Registered: Jan 2004
Location: NJ, USA
Distribution: Slackware, Debian
Posts: 5,852

Rep: Reputation: 351Reputation: 351Reputation: 351Reputation: 351
Yeah, I am getting that error with jre 1.6. Downgrading back to 1.5 didn't help either. This kind of sucks...
 
Old 03-22-2007, 03:40 AM   #6
patfins
LQ Newbie
 
Registered: Mar 2004
Posts: 21

Rep: Reputation: 15
Here's the patched libxcb-1.0 package:

http://iservice.ws/slackpkg/libxcb-1.0-i486-2pfi.tgz
 
Old 03-22-2007, 09:59 AM   #7
hitest
Senior Member
 
Registered: Mar 2004
Location: Prince Rupert, B.C., Canada
Distribution: Slackware, OpenBSD
Posts: 4,160

Rep: Reputation: 525Reputation: 525Reputation: 525Reputation: 525Reputation: 525Reputation: 525
Quote:
Originally Posted by patfins
Here's the patched libxcb-1.0 package:

http://iservice.ws/slackpkg/libxcb-1.0-i486-2pfi.tgz
Good to know. I absolutely need java to work for me, it is working well in slack 11. I use java on my slack box to log into my proprietary oracle company database.
I hope Pat resolves this in the next stable release.
 
Old 03-22-2007, 10:10 AM   #8
kiroff
LQ Newbie
 
Registered: Aug 2005
Location: Varna, Bulgaria
Distribution: Slackware Linux
Posts: 20

Rep: Reputation: 0
Thumbs up Thanks!

Quote:
Originally Posted by patfins
Here's the patched libxcb-1.0 package:

http://iservice.ws/slackpkg/libxcb-1.0-i486-2pfi.tgz
Working!!!
Just upgraded, got the java working again.

Thanks patfins!
 
Old 03-22-2007, 11:10 AM   #9
hitest
Senior Member
 
Registered: Mar 2004
Location: Prince Rupert, B.C., Canada
Distribution: Slackware, OpenBSD
Posts: 4,160

Rep: Reputation: 525Reputation: 525Reputation: 525Reputation: 525Reputation: 525Reputation: 525
Quote:
Originally Posted by kiroff
Working!!!
Just upgraded, got the java working again.

Thanks patfins!
Right on! Cool.
 
Old 03-22-2007, 11:27 AM   #10
MS3FGX
Guru
 
Registered: Jan 2004
Location: NJ, USA
Distribution: Slackware, Debian
Posts: 5,852

Rep: Reputation: 351Reputation: 351Reputation: 351Reputation: 351
Awesome, that got everything working for me too.

Thanks a lot.
 
Old 03-22-2007, 01:13 PM   #11
patfins
LQ Newbie
 
Registered: Mar 2004
Posts: 21

Rep: Reputation: 15
The libxcb patch has a side effect: Beryl is working fine now! (crashed all the time)
Here's my slackware-current with beryl video. ;-)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
slack-current (25 sep 06) kernel bug? slak05 Slackware 8 09-27-2006 02:10 PM
Is this a bug in current? slackware_newbie Slackware 3 09-19-2006 01:46 PM
bug in KDE 3.5.2 (slackware current) perfect_circle Slackware 3 04-19-2006 04:22 PM
Slackware-current Imagemagick bug fix wastelander42 Slackware 2 02-03-2006 10:11 AM
Java and Slackware-current AstainHellbring Slackware 4 10-23-2004 10:08 AM


All times are GMT -5. The time now is 11:44 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration