LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 11-05-2013, 05:49 PM   #1
Linux.tar.gz
Senior Member
 
Registered: Dec 2003
Location: Paris
Distribution: Slackware forever.
Posts: 2,227

Rep: Reputation: 86
Question Slackware -current installs with huge kernel, but boots on hugesmp


Hi !

So my non-pae machine does not boot after the installation.
I used latest Alien's synchro iso build.

I can fix that, but i really wonder if it's supposed to happen...
 
Old 11-05-2013, 11:14 PM   #2
bormant
Member
 
Registered: Jan 2008
Posts: 89

Rep: Reputation: 37
This is because:
1) lilo.conf uses /boot/vmlinuz as kernel image by default
2) /boot/vmlinuz is a symlink that kernel-* package's doinst.sh script sets to the kernel image from this package
3) packages are installed in alphabet order so kernel-huge-[0-9]* then kernel-huge-smp-[0-9]*
4) kernel-huge-smp-[0-9]* sets /boot/vmlinuz symlink to huge-smp kernel

To avoid problem:
- do not select a/kernel-huge-smp to install
or
- change /mnt/boot/vmlinuz symlink to huge-smp kernel before install lilo, for ex. from 2nd console (Alt+F2 to switch) do
# cd /mnt; var/log/scripts/kernel-huge-3*
or
- edit lilo.conf before install lilo

To resolve problem with boot:
- boot installed Slackware from CD/DVD with "huge.s root=/dev/sda2 rdinit= ro" (where sda2 is your root partition), reset /boot/vmlinuz symlink to huge kernel and reinstall lilo
# (cd /; var/log/scripts/kernel-huge-3*)
# lilo
or
- boot any LiveCD (include Slackware install disk) then (assume sda2 is root partition)
# mount /dev/sda2 /mnt
# for d in dev sys proc; do mount --bind /$d /mnt/$d; done
# chroot /mnt
# (cd /; var/log/scripts/kernel-huge-3*)
# lilo

Last edited by bormant; 11-06-2013 at 01:53 AM.
 
Old 11-06-2013, 05:46 AM   #3
Linux.tar.gz
Senior Member
 
Registered: Dec 2003
Location: Paris
Distribution: Slackware forever.
Posts: 2,227

Original Poster
Rep: Reputation: 86
Too bad there's no kernel selection anymore during the installation :/
 
Old 11-06-2013, 09:07 AM   #4
Linux.tar.gz
Senior Member
 
Registered: Dec 2003
Location: Paris
Distribution: Slackware forever.
Posts: 2,227

Original Poster
Rep: Reputation: 86
I'm doing a network install BTW.
 
Old 11-06-2013, 09:24 AM   #5
irgunII
Member
 
Registered: Jan 2012
Location: Directly above the center of the earth
Distribution: Slackware. There's something else?
Posts: 360

Rep: Reputation: 61
Quote:
Originally Posted by Linux.tar.gz View Post
Too bad there's no kernel selection anymore during the installation :/
Really? There's no kernel selection option anymore? Hmmmm...not sure if I'm gonna like that.
 
Old 11-06-2013, 10:39 AM   #6
willysr
Senior Member
 
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 2,493

Rep: Reputation: 403Reputation: 403Reputation: 403Reputation: 403Reputation: 403
you do have kernel selection, unless you pick FULL install
 
Old 11-06-2013, 11:06 AM   #7
Linux.tar.gz
Senior Member
 
Registered: Dec 2003
Location: Paris
Distribution: Slackware forever.
Posts: 2,227

Original Poster
Rep: Reputation: 86
Yeah, i did a full install, but i still don't see the point not to be able to select the default kernel.
 
Old 11-06-2013, 02:29 PM   #8
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware{,64}-14.1 on a Lenovo T61 6457-4XG
Posts: 3,950

Rep: Reputation: 930Reputation: 930Reputation: 930Reputation: 930Reputation: 930Reputation: 930Reputation: 930Reputation: 930
I think that's the text you see when pressing [F2] that could be misleading if you read it to fast. It says:
Code:
                 -+  Kernel Selection Help +-

You'll need one kernel to get Linux started on your system so that you can
install it.  The default kernel is hugesmp.s, which requires at least a
Pentium III processor.  If this kernel doesn't work for you, you may try
the regular "huge.s" kernel, which supports i486 and better single CPU
machines.  Both kernels now contain Speakup support.

***************************************************************************
* Tip:  If you have no idea which kernel to use, go with hugesmp.s!       *
***************************************************************************

To boot the chosen kernel put the name of the kernel and press enter.

boot: hugesmp.s  "For example, boot the 'hugesmp.s' kernel!"
boot: kmssmp.s   "To boot with kernel mode setting for graphics -- needed
                  with some machines."

To check your system memory with memtest86+, use 'memtest':
boot: memtest
If you read that to fast you see only the examples with hugesmp.s and kmssmp.s but, as stated above on the screen, huge.s is still available, so just type
boot: huge.s
and you are all set.

The text you type after 'boot:' is a label used by isolinux to choose the corresponding stanza in isolinux.conf:
Code:
default hugesmp.s
prompt 1
timeout 1200
display message.txt
F1 message.txt
F2 f2.txt
label huge.s
  kernel /kernels/huge.s/bzImage
  append initrd=initrd.img load_ramdisk=1 prompt_ramdisk=0 rw printk.time=0 nomodeset SLACK_KERNEL=huge.s
label hugesmp.s
  kernel /kernels/hugesmp.s/bzImage
  append initrd=initrd.img load_ramdisk=1 prompt_ramdisk=0 rw printk.time=0 nomodeset SLACK_KERNEL=hugesmp.s
label kms.s
  kernel /kernels/huge.s/bzImage
  append initrd=initrd.img load_ramdisk=1 prompt_ramdisk=0 rw printk.time=0 SLACK_KERNEL=huge.s
label kmssmp.s
  kernel /kernels/hugesmp.s/bzImage
  append initrd=initrd.img load_ramdisk=1 prompt_ramdisk=0 rw printk.time=0 SLACK_KERNEL=hugesmp.s
label speakup.s
  kernel /kernels/hugesmp.s/bzImage
  append initrd=initrd.img load_ramdisk=1 prompt_ramdisk=0 rw printk.time=0 SLACK_KERNEL=hugesmp.s
label memtest
  kernel /kernels/memtest/memtest
that in turn sets the variable SLACK_KERNEL that will be considered later (during configuration) by the installer to know which kernel to set as default among those just installed.

PS This stands for Slackware-current only as in Slackware64-current there is only one kernel (labeled huge.s but that is SMP able :-)

Last edited by Didier Spaier; 11-06-2013 at 02:32 PM.
 
1 members found this post helpful.
Old 11-06-2013, 07:00 PM   #9
Linux.tar.gz
Senior Member
 
Registered: Dec 2003
Location: Paris
Distribution: Slackware forever.
Posts: 2,227

Original Poster
Rep: Reputation: 86
Oh this is interesting !

Thanks !!!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] eee 1000h (almost) never boots first time running slackware-current trumpet_tom Slackware 6 03-22-2010 04:48 PM
NIC Stops Working With Current Huge Kernel Woodsman Slackware 20 06-29-2009 12:34 AM
Current Huge Kernel Will Not Boot With cx23885 Module Woodsman Slackware 7 05-29-2009 10:46 AM
Difference between the hugesmp.s and huge.s kernel C-Sniper Slackware 6 05-18-2008 09:19 PM
Huge.s V.S hugesmp.s Denisius Slackware 13 11-04-2007 01:41 PM


All times are GMT -5. The time now is 01:41 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration