LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Slackware -current installs with huge kernel, but boots on hugesmp (http://www.linuxquestions.org/questions/slackware-14/slackware-current-installs-with-huge-kernel-but-boots-on-hugesmp-4175483513/)

Linux.tar.gz 11-05-2013 06:49 PM

Slackware -current installs with huge kernel, but boots on hugesmp
 
Hi !

So my non-pae machine does not boot after the installation.
I used latest Alien's synchro iso build.

I can fix that, but i really wonder if it's supposed to happen...

bormant 11-06-2013 12:14 AM

This is because:
1) lilo.conf uses /boot/vmlinuz as kernel image by default
2) /boot/vmlinuz is a symlink that kernel-* package's doinst.sh script sets to the kernel image from this package
3) packages are installed in alphabet order so kernel-huge-[0-9]* then kernel-huge-smp-[0-9]*
4) kernel-huge-smp-[0-9]* sets /boot/vmlinuz symlink to huge-smp kernel

To avoid problem:
- do not select a/kernel-huge-smp to install
or
- change /mnt/boot/vmlinuz symlink to huge-smp kernel before install lilo, for ex. from 2nd console (Alt+F2 to switch) do
# cd /mnt; var/log/scripts/kernel-huge-3*
or
- edit lilo.conf before install lilo

To resolve problem with boot:
- boot installed Slackware from CD/DVD with "huge.s root=/dev/sda2 rdinit= ro" (where sda2 is your root partition), reset /boot/vmlinuz symlink to huge kernel and reinstall lilo
# (cd /; var/log/scripts/kernel-huge-3*)
# lilo
or
- boot any LiveCD (include Slackware install disk) then (assume sda2 is root partition)
# mount /dev/sda2 /mnt
# for d in dev sys proc; do mount --bind /$d /mnt/$d; done
# chroot /mnt
# (cd /; var/log/scripts/kernel-huge-3*)
# lilo

Linux.tar.gz 11-06-2013 06:46 AM

Too bad there's no kernel selection anymore during the installation :/

Linux.tar.gz 11-06-2013 10:07 AM

I'm doing a network install BTW.

irgunII 11-06-2013 10:24 AM

Quote:

Originally Posted by Linux.tar.gz (Post 5059286)
Too bad there's no kernel selection anymore during the installation :/

Really? There's no kernel selection option anymore? Hmmmm...not sure if I'm gonna like that.

willysr 11-06-2013 11:39 AM

you do have kernel selection, unless you pick FULL install :)

Linux.tar.gz 11-06-2013 12:06 PM

Yeah, i did a full install, but i still don't see the point not to be able to select the default kernel.

Didier Spaier 11-06-2013 03:29 PM

I think that's the text you see when pressing [F2] that could be misleading if you read it to fast. It says:
Code:

                -+  Kernel Selection Help +-

You'll need one kernel to get Linux started on your system so that you can
install it.  The default kernel is hugesmp.s, which requires at least a
Pentium III processor.  If this kernel doesn't work for you, you may try
the regular "huge.s" kernel, which supports i486 and better single CPU
machines.  Both kernels now contain Speakup support.

***************************************************************************
* Tip:  If you have no idea which kernel to use, go with hugesmp.s!      *
***************************************************************************

To boot the chosen kernel put the name of the kernel and press enter.

boot: hugesmp.s  "For example, boot the 'hugesmp.s' kernel!"
boot: kmssmp.s  "To boot with kernel mode setting for graphics -- needed
                  with some machines."

To check your system memory with memtest86+, use 'memtest':
boot: memtest

If you read that to fast you see only the examples with hugesmp.s and kmssmp.s but, as stated above on the screen, huge.s is still available, so just type
boot: huge.s
and you are all set.

The text you type after 'boot:' is a label used by isolinux to choose the corresponding stanza in isolinux.conf:
Code:

default hugesmp.s
prompt 1
timeout 1200
display message.txt
F1 message.txt
F2 f2.txt
label huge.s
  kernel /kernels/huge.s/bzImage
  append initrd=initrd.img load_ramdisk=1 prompt_ramdisk=0 rw printk.time=0 nomodeset SLACK_KERNEL=huge.s
label hugesmp.s
  kernel /kernels/hugesmp.s/bzImage
  append initrd=initrd.img load_ramdisk=1 prompt_ramdisk=0 rw printk.time=0 nomodeset SLACK_KERNEL=hugesmp.s
label kms.s
  kernel /kernels/huge.s/bzImage
  append initrd=initrd.img load_ramdisk=1 prompt_ramdisk=0 rw printk.time=0 SLACK_KERNEL=huge.s
label kmssmp.s
  kernel /kernels/hugesmp.s/bzImage
  append initrd=initrd.img load_ramdisk=1 prompt_ramdisk=0 rw printk.time=0 SLACK_KERNEL=hugesmp.s
label speakup.s
  kernel /kernels/hugesmp.s/bzImage
  append initrd=initrd.img load_ramdisk=1 prompt_ramdisk=0 rw printk.time=0 SLACK_KERNEL=hugesmp.s
label memtest
  kernel /kernels/memtest/memtest

that in turn sets the variable SLACK_KERNEL that will be considered later (during configuration) by the installer to know which kernel to set as default among those just installed.

PS This stands for Slackware-current only as in Slackware64-current there is only one kernel (labeled huge.s but that is SMP able :-)

Linux.tar.gz 11-06-2013 08:00 PM

Oh this is interesting !

Thanks !!!


All times are GMT -5. The time now is 10:26 PM.