LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Slackware current: Firefox 16.0 segmentation fault (http://www.linuxquestions.org/questions/slackware-14/slackware-current-firefox-16-0-segmentation-fault-4175431456/)

burdi01 10-10-2012 04:58 AM

Slackware current: Firefox 16.0 segmentation fault
 
On Slackware current (up to date) 32 bit the new Firefox 16 gives a segmentation fault. This happens on the restart after 1) "Help > Check new version", or 2) after downloading the tar.bz2 from the Firefox site, or 3) after slackpkg install or update.
Sending the problem report to Mozilla also fails.
The new Firefox 16 on Xubuntu 12.04 64 bit is OK.
The new Firefox 16 on PartedMagic 2012_10_09 is OK too.
:cry:

sorinm 10-10-2012 05:58 AM

No problem here. X64

willysr 10-10-2012 06:04 AM

No problem here x86

burdi01 10-10-2012 07:27 AM

So the problem is specific to my machines ...
Disabling all plugins did not help.
Moving /opt/firefox (I run the version from the firefox download page, so I can choose where to install) to /usr/lib did not help.
Slackpkg install firefox (so the Slackware version) did not help.
Upgrading and running the firefox download under TWM was successful.
Upgrading and running the firefox download under Xfce 4.10 was successful.
Upgrading and running the firefox download under Trinity 3.5.13 fails !!!

As Trinity is on its way out on my machines I can live with this outcome.
:D

willysr 10-10-2012 07:34 AM

I tested using firefox from mozilla and from slackware and both works fine

Didier Spaier 10-10-2012 08:06 AM

Quote:

Originally Posted by burdi01 (Post 4802083)
So the problem is specific to my machines ...
Disabling all plugins did not help.
Moving /opt/firefox (I run the version from the firefox download page, so I can choose where to install) to /usr/lib did not help.
Slackpkg install firefox (so the Slackware version) did not help.
Upgrading and running the firefox download under TWM was successful.
Upgrading and running the firefox download under Xfce 4.10 was successful.
Upgrading and running the firefox download under Trinity 3.5.13 fails !!!

As Trinity is on its way out on my machines I can live with this outcome.
:D

As the problem occurs only under Trinity and we don't know how you installed it it's hard to give you a spot-on advise.

onebuck 10-10-2012 08:13 AM

Member Response
 
Hi,

I just upgraded to 'FF 16.0' Slackware pkg on a x86_64 with no issues. Feels snappy or is it the caffeine. :)

sardinha 10-10-2012 10:03 AM

If you don't want upgrade package, download all source files from http://mirrors.slackware.com/slackwa...zilla-firefox/ and just modified mozilla-firefox.SlackBuild to your install preferences.


All times are GMT -5. The time now is 12:33 AM.