LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   slackware-current-boot fails with linux-3.10* (http://www.linuxquestions.org/questions/slackware-14/slackware-current-boot-fails-with-linux-3-10%2A-4175470944/)

mainam 07-25-2013 09:42 PM

slackware-current-boot fails with linux-3.10*
 
In slackware-current with linux-3.10 series boot comes to dead end with fsck.ext2:exec format error-emergency shell no help. Compiled 3.10* several times.Please help

ReaperX7 07-25-2013 09:58 PM

Did you compile the kernel with the EXT 2/3/4 file system loading driver built into the kernel itself or as separate modules?

parcox 07-25-2013 10:41 PM

I've this problem too recently. I first thought that this problem comes from e2fsprogs. Rebuilding e2fsprogs didn't solve the problem. You would check your kernel config, make sure CONFIG_BINFMT_SCRIPT is configured to Y (not M / N).

Code:

...
#
# Executable file formats / Emulations
#
CONFIG_BINFMT_ELF=y
CONFIG_COMPAT_BINFMT_ELF=y
CONFIG_ARCH_BINFMT_ELF_RANDOMIZE_PIE=y
# CONFIG_CORE_DUMP_DEFAULT_ELF_HEADERS is not set
CONFIG_BINFMT_SCRIPT=y
# CONFIG_HAVE_AOUT is not set
CONFIG_BINFMT_MISC=y
...

From kernel help menu:
Quote:

CONFIG_BINFMT_SCRIPT: │
│ │
│ Say Y here if you want to execute interpreted scripts starting with │
│ #! followed by the path to an interpreter. │
│ │
│ You can build this support as a module; however, until that module │
│ gets loaded, you cannot run scripts. Thus, if you want to load this │
│ module from an initramfs, the portion of the initramfs before loading │
│ this module must consist of compiled binaries only. │
│ │
│ Most systems will not boot if you say M or N here. If unsure, say Y.

mainam 07-26-2013 04:34 AM

Parcox your reply solved the problem.boots new compiled kernel.many thanks
 
Quote:

Originally Posted by parcox (Post 4996960)
I've this problem too recently. I first thought that this problem comes from e2fsprogs. Rebuilding e2fsprogs didn't solve the problem. You would check your kernel config, make sure CONFIG_BINFMT_SCRIPT is configured to Y (not M / N).

Code:

...
#
# Executable file formats / Emulations
#
CONFIG_BINFMT_ELF=y
CONFIG_COMPAT_BINFMT_ELF=y
CONFIG_ARCH_BINFMT_ELF_RANDOMIZE_PIE=y
# CONFIG_CORE_DUMP_DEFAULT_ELF_HEADERS is not set
CONFIG_BINFMT_SCRIPT=y
# CONFIG_HAVE_AOUT is not set
CONFIG_BINFMT_MISC=y
...

From kernel help menu:


Hullo Parcox,
You have solved the problem for me.Recompiled kernel with suggested changes and now boots normally. Many thanks

parcox 07-26-2013 07:39 AM

Don't forget to mark this thread as solved then :D

torimus 07-26-2013 03:27 PM

I do really recommend to use, at least as the initial point, configuration file offered directly by Slackware
Btw, it already has CONFIG_BINFMT_SCRIPT option set to yes.

mainam 07-27-2013 12:56 AM

Problem solved

TracyTiger 07-27-2013 01:25 AM

Quote:

Originally Posted by mainam (Post 4997696)
Problem solved

Marking a problem/post as SOLVED means using the "Thread Tools" menu at the top of the page and selecting the solved option.

The solved status will then appear next to the title in the list of threads.


All times are GMT -5. The time now is 01:18 PM.