LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 03-15-2011, 02:04 AM   #1
thach.trung.ngoc
Member
 
Registered: Mar 2009
Distribution: Slackware-Current
Posts: 46

Rep: Reputation: 0
slackware-current and vmware-player 3.1.3


Hi All,


Has anyone had an issue running vmware-player with kernel 2.6.37.3 (current)?


Installation was running ok, but when I ran vmware-player, an error came up. Issue is "Failed to compile module vmmon!"


any helps are welcome

Thanks
 
Old 03-15-2011, 02:32 AM   #2
disturbed1
Senior Member
 
Registered: Mar 2005
Location: USA
Distribution: Slackware
Posts: 1,133
Blog Entries: 6

Rep: Reputation: 223Reputation: 223Reputation: 223
vmmon needs to be patched. Forget exactly where I got it from, but Google should yield around 6,000 results when you search for Failed to compile module vmmon

---edit---

Try this -
https://wiki.archlinux.org/index.php..._VMware_Player

Last edited by disturbed1; 03-15-2011 at 02:34 AM.
 
Old 03-15-2011, 08:32 AM   #3
thach.trung.ngoc
Member
 
Registered: Mar 2009
Distribution: Slackware-Current
Posts: 46

Original Poster
Rep: Reputation: 0
Thanks disturbed1.

I downloaded the patch script, then ran it. It works like a charm
 
Old 03-16-2011, 08:33 PM   #4
chytraeus
Member
 
Registered: Dec 2008
Distribution: slackware64 openbsd
Posts: 75

Rep: Reputation: 2
Quote:
Originally Posted by thach.trung.ngoc View Post
Thanks disturbed1.

I downloaded the patch script, then ran it. It works like a charm
Could you give a little more details? Which script did you use? I'm trying to get vmware-player working too. Thanks.
 
Old 03-21-2011, 04:56 PM   #5
disturbed1
Senior Member
 
Registered: Mar 2005
Location: USA
Distribution: Slackware
Posts: 1,133
Blog Entries: 6

Rep: Reputation: 223Reputation: 223Reputation: 223
Quote:
Originally Posted by chytraeus View Post
Could you give a little more details? Which script did you use? I'm trying to get vmware-player working too. Thanks.
Did you get this working yet? If not, following that link I posted, there's a section under #6 that states -
Quote:
For 2.6.37 kernel and VMware 7.x.x (tested with 7.1.3), there's a script to patch the VMware sources (run as root):
That's what you need.

It's actually quite nice. As before I would manually untar the module(s), patch, tar, then run vmware to compile the modules. This script does it all in one shot
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
vmware player problem with slackware current(kernel 2.6.32.7) yuchankit Slackware 3 04-25-2010 10:17 PM
Slackware -current w/ 2.6.27.5 kernel + VMware-server 1.0.7 niels.horn Slackware 0 11-09-2008 10:09 AM
VMWare Player Install on Slackware 12.0 perry Slackware 23 11-04-2007 01:32 PM
Installing Slackware 12.0 on VMware player without burning CDs vidguy Linux - Newbie 6 08-26-2007 10:25 AM
VMWare on Slackware Current: massive display corruption senorsnor Slackware 4 02-24-2005 01:30 PM


All times are GMT -5. The time now is 10:29 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration