LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 04-05-2008, 12:30 PM   #1
prontxo
LQ Newbie
 
Registered: Mar 2008
Posts: 8

Rep: Reputation: 0
Slackware-current and mkinitrd-1.3.2


I upgraded to mkinitrd-1.3.2-i486-1, and I have the same problem than mkinitrd-1.3.1-i486-4.
When I upgraded, I typed mkinitrd whit arguments, and I get the same errors than mkinitrd-1.3.1-i486-4.Then, I reverted to mkinitrd-1.1.2-i486-3, typed mkinitrd with arguments, and It works fine. Then, upgraded to mkinitrd-1.3.2-i486-1, and typed mkinitrd whit no arguments, and It works fine.
I don't know what is the problem.
 
Old 04-05-2008, 03:03 PM   #2
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,313

Rep: Reputation: Disabled
It would help if you told us about the exact error messages you see, and what happens next.

Eric
 
Old 04-06-2008, 02:54 AM   #3
prontxo
LQ Newbie
 
Registered: Mar 2008
Posts: 8

Original Poster
Rep: Reputation: 0
In my previous thread "Slackware-current and mkinitrd-1.3.1, I wrote:

""I have a laptop with Slackware-current. It has a hard disk with two partitions; one ,hda1,unencrypted, for the /boot filesystem, ant another, hda2, with three LV encrypted whit cryptsetup/LUKS for the /, /home and swap filesystems. All make according to README_CRYPT.TXT and README_LVM.TXT documents.
All works fine, until I upgraded mkinitrd whit the mkinitrd-1.3.1 package.
After I upgrades the package, I rebooted the laptop and, behind initrd loads the modules, it stops and I get the next error messages:
Command failed: dm_task_set_name: Device /dev/mapper/cryptroot not found
mount: mounting /dev/mapper//dev/mapper/cryptroot on /mnt failed: No such file or directory.
ERROR: No /sbin/init found on rootdev (or not mounted). Trouble ahead.
Behind the prompt, I run exit, and I get a kernel panic.
I search for help on Google, but the only valid answer was in the URL
<http://alien.slackbook.org/dokuwiki/doku.php?id=slackware:setup>. It was one modification to the README_CRYPT.TXT document, above mentioned.
I followed the next steps for make the modification above mentioned. Behind I boot the laptop with the CD1 from Slackware Installation, I run the next commands:
vgchange -ay
cryptsetup luksOpen /dev/mivg/root cryptroot
cryptsetup luksOpen /dev/mivg/home /crypthome
mount -t ext3 /dev/mapper/cryptroot /mnt
mount -t ext3 /dev/mapper/crypthome /mnt/home
mount -t ext3 /dev/ha1 /mnt/boot
mount -o bind /proc /mnt/proc
mount -o bind /sys /mnt/sys
mount -o bind /dev /mnt/dev (this is the modification above mentioned. It gets error,and I run the next command)
cp -a /dev/mapper/ /mnt/dev
chroot /mnt
vgscan --mknodes
mkinitrd -c -k 2.6.23.16 -m ext3 -f ext3 -r cryptroot -C /dev/mivg/root -L
I reboot the laptop, and I get the same errors.
If, in the prompt after the boot, I make ls -la /dev/mapper, I get
control
mivg-home
mivg-root
mivg-swap
Don't appear the encrypted devices cryptroot and crypthome, why?

I have the makeinitrd-1.3.1-i486-4.tgz and I don't use lilo but grub

I reverted to mkinitrd-1.1.2-i486-3 (from CD1), and it works fine

When I reverted to mkinitrd-1.1.2-i486-3 and it worked fine, I upgraded to mkinitrd-1.3.1-i486-4 and typed mkinitrd with not arguments, and it worked fine.
Now, I upgraded kernel to kernel-2.4.24.4, and typed mkinitrd with arguments, and the problem return. I have the same error messages of the first post.

I reverted to mkinitrd-1.1.2-i486-3, and typed mkinitrd with arguments, it worked fine with the new kernel. Then upgraded to mkinitrd-1.3.1-i486-4, typed mkinitrd with no arguments, and it works fine with the new kernel.""

Now, I upgraded to mkinitrd-1.3.2-i486-1, typed mkinitrd with arguments, reboot the PC, and I see the same errors from above. If I revert to mkinitrd-1.1.2-i486-3, type mkinitrd with arguments, it works fine after reboot. I upgrade to mkinitrd-1.3.2-i486-1, type mkinitrd with no arguments, and it works fine after reboot.
 
Old 04-06-2008, 03:25 PM   #4
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,313

Rep: Reputation: Disabled
Everyone I have seen sofar with mkinitrd trouble is using grub.
Can you try installing lilo into the /dev/hda1 boot partition and adding a chainloader command to your grub menu that loads lilo in turn? Something like
Code:
title Slackware
rootnoverify (hd0,0)
grub> chainloader +1
Eric
 
Old 04-11-2008, 11:18 AM   #5
prontxo
LQ Newbie
 
Registered: Mar 2008
Posts: 8

Original Poster
Rep: Reputation: 0
Whit lilo, mkinitrd-1.3.2 works fine, with arguments and with no arguments.
Thanks a lot.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Slackware-current and mkinitrd-1.3.1 prontxo Slackware 8 03-30-2008 06:43 AM
Slackware 10 + SATA Promise + mkinitrd sammut Slackware 0 07-07-2004 01:55 AM
mkinitrd script with slackware deb75 Slackware 1 04-20-2004 10:56 AM


All times are GMT -5. The time now is 08:12 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration