LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 11-23-2005, 12:46 PM   #1
malodemickey
LQ Newbie
 
Registered: Sep 2003
Location: Mexico
Distribution: Slackware 10.2
Posts: 8

Rep: Reputation: 0
Slackware audio problem


Hi, I just erased everything and installed slackware 10.2. I have a problem with my audio, It works fine, but it seems that only one program can use the soundcard at one time. For example, if i'm using xmms, gaim doesn't make any sounds. And also, when I reboot, my volume settings (PCM, Master, etc) reset to 0. Any ideas? My soundcard is an integrated AC'97
Thanks in advance.
 
Old 11-23-2005, 01:01 PM   #2
Finlay
Senior Member
 
Registered: Mar 2003
Location: Seattle
Distribution: Slackware ?-14.1
Posts: 1,029

Rep: Reputation: 47
have you run
alsamixer
set the volumes, then run
alsactl store
 
Old 11-23-2005, 01:02 PM   #3
keefaz
Senior Member
 
Registered: Mar 2004
Distribution: Slackware
Posts: 4,617

Rep: Reputation: 136Reputation: 136
Create ~/.asoundrc with the content :
Code:
pcm.!default {
        type plug
        slave.pcm "swmixer"
}

pcm.swmixer {
        type dmix
        ipc_key 1234
        slave {
                pcm "hw:0,0"
                period_time 0
                period_size 1024
                buffer_size 4096
                rate 44100
        }
}
You could change rate to 48000 depending on your hardware
 
Old 11-23-2005, 01:05 PM   #4
Finlay
Senior Member
 
Registered: Mar 2003
Location: Seattle
Distribution: Slackware ?-14.1
Posts: 1,029

Rep: Reputation: 47
keefaz
what will that file do?
 
Old 11-23-2005, 02:25 PM   #5
malodemickey
LQ Newbie
 
Registered: Sep 2003
Location: Mexico
Distribution: Slackware 10.2
Posts: 8

Original Poster
Rep: Reputation: 0
Thanks, I'll try both suggestions tonight when I get home. But as keefaz said, it would be nice to know what that file does.
 
Old 11-23-2005, 02:30 PM   #6
npn
LQ Newbie
 
Registered: Nov 2005
Posts: 12

Rep: Reputation: 0
Additionally, artsd will interfere too. In KDE go to the (kcontrol) Control Center->Sound and Multimedia and find the control that says something like "disable artsd after so many seconds". The default is 60, set to 5.
Sorry I can't be more specific, I'm at work (no linux).
 
Old 11-23-2005, 02:32 PM   #7
Finlay
Senior Member
 
Registered: Mar 2003
Location: Seattle
Distribution: Slackware ?-14.1
Posts: 1,029

Rep: Reputation: 47
Scandalous, no linux at work....speechless!!
 
Old 11-23-2005, 02:40 PM   #8
malodemickey
LQ Newbie
 
Registered: Sep 2003
Location: Mexico
Distribution: Slackware 10.2
Posts: 8

Original Poster
Rep: Reputation: 0
I don't have kde installed, I installed dropline gnome. Is there another way to do that from the command line or within gnome? Perhaps I don't have arts installed (It comes with kde doesn't it?)
 
Old 11-23-2005, 02:59 PM   #9
keefaz
Senior Member
 
Registered: Mar 2004
Distribution: Slackware
Posts: 4,617

Rep: Reputation: 136Reputation: 136
Quote:
Originally posted by Finlay
keefaz
what will that file do?
This file enables some alsa settings for the sound card

Here it is supposed to enable the dmix plugin which is capable to
receive multiple audio flux sent by the applications and mix them
to the sound card

more infos :
http://alsa.opensrc.org/.asoundrc
http://linux.com.hk/PenguinWeb/manpa...undrc.template
http://www.linuxjournal.com/comment/reply/7391
 
Old 11-23-2005, 03:02 PM   #10
Finlay
Senior Member
 
Registered: Mar 2003
Location: Seattle
Distribution: Slackware ?-14.1
Posts: 1,029

Rep: Reputation: 47
interesting
how do i tell what rate my card runs at?
 
Old 11-23-2005, 03:05 PM   #11
keefaz
Senior Member
 
Registered: Mar 2004
Distribution: Slackware
Posts: 4,617

Rep: Reputation: 136Reputation: 136
Take a look at /proc/asound/card0/codec97#0/ac97#0-0
(or at least navigate into /proc/asound/card0 and try to grab some
infos from here)
 
Old 11-23-2005, 05:30 PM   #12
Finlay
Senior Member
 
Registered: Mar 2003
Location: Seattle
Distribution: Slackware ?-14.1
Posts: 1,029

Rep: Reputation: 47
ok mine says 48k
so would that be 48000 or 49152
 
Old 11-23-2005, 05:37 PM   #13
dive
Senior Member
 
Registered: Aug 2003
Location: UK
Distribution: Slackware
Posts: 3,211

Rep: Reputation: 293Reputation: 293Reputation: 293
48000 i believe

but thats probably the max it can go - i think most cards use 44100 as default(?)
 
Old 11-23-2005, 11:01 PM   #14
malodemickey
LQ Newbie
 
Registered: Sep 2003
Location: Mexico
Distribution: Slackware 10.2
Posts: 8

Original Poster
Rep: Reputation: 0
So I finally got home... alsamixer and alsactl store solved the first problem, thanks .
But I did what keefaz said, then rebooted and my soundcard still can't be accessed by more than one program.
 
Old 11-23-2005, 11:02 PM   #15
gbonvehi
Senior Member
 
Registered: Jun 2004
Location: Argentina (SR, LP)
Distribution: Slackware
Posts: 3,145

Rep: Reputation: 51
malodemickey, did you placed that file on the home of your current user (the one running the programs with sound)? Remember ~ means home folder, like /home/user.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Audio CD Doesn't Play - Slackware mijenks Slackware 9 07-22-2004 11:44 PM
Real Audio for Slackware JockVSJock Slackware 4 01-27-2004 11:27 PM
audio problem on slackware 9.1/i815 chipset asowani Linux - Newbie 2 12-25-2003 10:54 PM
Audio in Slackware XPediTioN Slackware 6 07-08-2003 12:36 AM
Slackware 8.1 and audio configuration undelete Linux - Hardware 6 10-21-2002 10:22 AM


All times are GMT -5. The time now is 08:46 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration