LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 08-24-2006, 12:18 PM   #1
Chikne
Member
 
Registered: Jul 2006
Distribution: Slackware 11
Posts: 140

Rep: Reputation: 15
slackware and rt2500


Hi guys,

I am using slackware 10.0 with 2.6.17.7 kernel.

I am trying to install an edimax wireless network card with a rt2500 chip on it, downloaded the drivers from the wiki site, but nothing seems to work... slackware doesn't detect the card.

Is there anything particular that needs to be compiled in the kernel or as a module???

When I do iwconfig i get:

lo no wireless extension

dummy0 no wireless extension


I've spent the last 3 days to try and work this out but no luck at all...

Thanks

Last edited by Chikne; 08-24-2006 at 12:31 PM.
 
Old 08-24-2006, 12:51 PM   #2
MS3FGX
Guru
 
Registered: Jan 2004
Location: NJ, USA
Distribution: Slackware, Debian
Posts: 5,852

Rep: Reputation: 351Reputation: 351Reputation: 351Reputation: 351
Were you able to compile the module? Does it insert properly?
 
Old 08-24-2006, 12:56 PM   #3
Chikne
Member
 
Registered: Jul 2006
Distribution: Slackware 11
Posts: 140

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by MS3FGX
Were you able to compile the module? Does it insert properly?
Hi, seems like the module compiles ok but when I do : modprobe rt2500

nothing seems to happend
 
Old 08-24-2006, 01:44 PM   #4
tobyl
Member
 
Registered: Apr 2003
Location: uk
Distribution: slackware current
Posts: 743

Rep: Reputation: 50
does it show up in lspci?

Its probably worth a search in this forum - there are several threads that may help

also Alien has built packages for this card

http://www.slackware.com/~alien/slackbuilds/rt2500/

tobyl
 
Old 08-24-2006, 01:50 PM   #5
ramram29
Member
 
Registered: Jul 2003
Location: Miami, Florida, USA
Distribution: Debian
Posts: 848
Blog Entries: 1

Rep: Reputation: 47
Run 'lsmod | grep rt2500' and make sure that the module is running.
 
Old 08-24-2006, 09:56 PM   #6
Chikne
Member
 
Registered: Jul 2006
Distribution: Slackware 11
Posts: 140

Original Poster
Rep: Reputation: 15
hi,

it does show in lspci which at least gives me a bit of hope

However when I do lsmod the module shows that it is loaded but there's a 0 on the line where it says if the module is being used or not. (sorry can't copy and paste from the console, can't figure out how to use gmp from fluxbox)

I also copied the RT2500STA.dat file to /etc/wireless/RT2500STA, and that doesn't make any difference ....

oH and I recompiled my kernel with some more wireless things in it after looking there: http://gentoo-wiki.com/HARDWARE_rt2500

but that didn't make any difference either


thanks

Last edited by Chikne; 08-24-2006 at 10:03 PM.
 
Old 08-25-2006, 03:04 AM   #7
-=Graz=-
Member
 
Registered: Jan 2006
Location: Australia
Distribution: Fedora, Slackware, RHEL, AIX, HP-UX
Posts: 356

Rep: Reputation: 31
I got the USB rt2570 driver to work in slackaware once.
i downloaded driver from http://rt2x00.serialmonkey.com/wiki/index.php/Downloads
unpacked the tarball and cd /modules (the modules dir that is created in the dir that you unpkaced the files into)
then #make and #make install
then had to add an alias into /etc/modprobe.conf from memory something like: alias rausb0 rt2500

if i did #lsmod |grep rt2500 i could see the module loaded.
*i think* i also had to do a #ifconfig rausb0 up
prior to beng able to see any wireless device registered with a #iwconfig
also, im not 100% about that part...

My card was rt2570 actually, im pretty sure i made a few posts to this forum about it

Last edited by -=Graz=-; 08-25-2006 at 03:06 AM.
 
Old 08-25-2006, 05:16 AM   #8
Interdictor
Member
 
Registered: Jul 2006
Location: Runcorn, England
Distribution: Ubuntu 6.06 & 6.1, Mandriva 2007, Knoppix
Posts: 72

Rep: Reputation: 15
I'm using a Belkin 7010 wireless card which uses the RT2500 chipset.

My setup was straight forward. I downloaded the driver from http://rt2x00.serialmonkey.com/wiki/index.php/Downloads and followed the instructions in the readme file within Modules

Build Instructions:
====================
For 2.4 or 2.6 series kernel:
a. $tar -xvzf rt2500-x.x.x.tar.gz
go to "./rt2500-x.x.x/Module" directory.

b. $make # compile driver source code

c. $make install # installs kernel module driver


I didn't bother with the raconfig utility.

The only other thing I had to do was add "/sbin/dhcpcd ra0" to /etc/rc/d/rc.local.

I didn't copy the RT2500STA.dat file to /etc/wireless/RT2500STA.

I was starting with a clean install of Slackware which had only had a wired connection via built in ethernet configured to download the driver from serialmonkey.


lspci

09:00.0 Network controller: RaLink Ralink RT2500 802.11 Cardbus Reference Card (rev 01)


iwconfig

ra0 RT2500 Wireless ESSID:"xxxxxxxx" Nickname:"Slack"
Mode:Managed Frequency=2.427 GHz Access Point: xx:xx:xx:xx:xx:xx
Bit Rate=54 Mb/s
RTS thrff Fragment thrff
Encryption keyff
Link Quality=84/100 Signal level=-59 dBm Noise level:-193 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0


ifconfig

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:49 errors:0 dropped:0 overruns:0 frame:0
TX packets:49 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:11124 (10.8 Kb) TX bytes:11124 (10.8 Kb)

ra0 Link encap:Ethernet HWaddr xx:xx:xx:xx:xx:xx
inet addr:xxx.xxx.xxx.xxx Bcast:xxx.xxx.xxx.xxx Mask:255.255.255.0
UP BROADCAST NOTRAILERS RUNNING MULTICAST MTU:1500 Metric:1
RX packets:1421 errors:0 dropped:0 overruns:0 frame:0
TX packets:1482 errors:0 dropped:0 overruns:0 carrier:0
collisions:26 txqueuelen:1000
RX bytes:1289281 (1.2 Mb) TX bytes:271700 (265.3 Kb)
Interrupt:10 Base address:0xf000

I'm using Slack 10.2 with the 2.4.31 kernel

HTH

Last edited by Interdictor; 08-25-2006 at 05:18 AM.
 
Old 08-25-2006, 10:40 AM   #9
Chikne
Member
 
Registered: Jul 2006
Distribution: Slackware 11
Posts: 140

Original Poster
Rep: Reputation: 15
thanks you but I did all this and that doesn't work for me.

I went into /lib/module/2.6.17.7/extra and removed rt2500.o, recompiled the driver and now I get this error message during the build: warning: "_mmx_ memcpy" [rt2500-1.1.0-bb4/Module/rt2500.ko] undefined!

And in /lib/module/2.6.17.7/extra I have a file named rt2500.ko as the one before was rt2500.o ... strange

The module won't load anymore it says: invalid module format!

Also tried the cvs driver but it does the same...

I think I'm gonna try compiling a default kernel and see what happends!

Anyone know how to turn on gpm for fluxbox or does it only work on KDE(sorry I know it's off topic but it's getting quite tiring to retape all this from the console

Last edited by Chikne; 08-25-2006 at 10:42 AM.
 
Old 08-26-2006, 09:28 AM   #10
tobyl
Member
 
Registered: Apr 2003
Location: uk
Distribution: slackware current
Posts: 743

Rep: Reputation: 50
gpm works for me in fluxbox

/etc/rc.d/rc.M should contain:

# Start the GPM mouse server:
if [ -x /etc/rc.d/rc.gpm ]; then
. /etc/rc.d/rc.gpm start
fi

/etc/rc.d/rc.gpm should be executable

------------------------------------------

.ko modules are in the 2.6 series of kernels
.o modules are in the 2.4 series of kernels

Have you got more than one kernel in /lib/modules? That not wrong, but there seems to be some confusion creeping in here...

I cant think what is happening, but if the above is true, you may want to check for any out-of-date symlinks in /usr/src.

tobyl
 
Old 08-26-2006, 09:55 AM   #11
-=Graz=-
Member
 
Registered: Jan 2006
Location: Australia
Distribution: Fedora, Slackware, RHEL, AIX, HP-UX
Posts: 356

Rep: Reputation: 31
Quote:
Originally Posted by tobyl

I cant think what is happening, but if the above is true, you may want to check for any out-of-date symlinks in /usr/src.

tobyl
Agreed - i think i had this very problem...
I would also check and make sure the symlink at /usr/src/linux is pointing to your current kernel..
Also, im quite sure i had to add something into /etc/modprobe.conf (or the other similar file that is in slackware) - sorry i am not in Slack at the moment.
Otherwise when doing the 'modprobe' i had to point it to the absolute path of the module.
I think when doing the make make install it put the alias in the wrong file for slackware..
 
Old 08-26-2006, 10:08 AM   #12
-=Graz=-
Member
 
Registered: Jan 2006
Location: Australia
Distribution: Fedora, Slackware, RHEL, AIX, HP-UX
Posts: 356

Rep: Reputation: 31
i just found my old thread and the below is what i did. hopfully it helps although i thin you have already done it - im sure i had to add a line to the modules.conf (not modprobe.conf lke i said before) before it would work - good luck!

After un-taring the files go into the /Module directory that it creates.
#make
#make install
add an alias into /etc/modules.conf - alias rausb0 rt2570
#modprobe rt2570
#ifconfig rausb0 up

of couse the rausb0 part will change for you as your card is pci...
 
Old 08-26-2006, 11:37 AM   #13
Chikne
Member
 
Registered: Jul 2006
Distribution: Slackware 11
Posts: 140

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by tobyl
gpm works for me in fluxbox

/etc/rc.d/rc.M should contain:

# Start the GPM mouse server:
if [ -x /etc/rc.d/rc.gpm ]; then
. /etc/rc.d/rc.gpm start
fi

/etc/rc.d/rc.gpm should be executable

tobyl
well all this is there and rc.gpm is x, but it still don't work.... thanks anyway!!


Ok as far as I can understand I must have changed the simlink /usr/src/linux after doing the first compile which is probably why I had a .o file in there...

Quote:
Originally Posted by -=Graz=-
i just found my old thread and the below is what i did. hopfully it helps although i thin you have already done it - im sure i had to add a line to the modules.conf (not modprobe.conf lke i said before) before it would work - good luck!

After un-taring the files go into the /Module directory that it creates.
#make
#make install
add an alias into /etc/modules.conf - alias rausb0 rt2570
#modprobe rt2570
#ifconfig rausb0 up

of couse the rausb0 part will change for you as your card is pci...

Thanks I saw the tread the other too and did the same thing, but I think I have to sort out this compile problem first

Last edited by Chikne; 08-26-2006 at 11:38 AM.
 
Old 08-26-2006, 09:00 PM   #14
Chikne
Member
 
Registered: Jul 2006
Distribution: Slackware 11
Posts: 140

Original Poster
Rep: Reputation: 15
Well,

I recompiled a kernel without iEEE 802.11 networking stack, just wireless drivers and wireless extensions and it's gone a bit better this time:

I am now able to compile and install the driver, however after doing a modprobe rt2500 nothing else happend the module loads though it shows in lsmod but doesn't seem to be used!!!

iwconfig doesn't give me anything either...

I also tried the driver from alien and ralink but those don't even compile!

Last edited by Chikne; 08-26-2006 at 09:09 PM.
 
Old 08-26-2006, 09:01 PM   #15
Chikne
Member
 
Registered: Jul 2006
Distribution: Slackware 11
Posts: 140

Original Poster
Rep: Reputation: 15
well after some reflection I just realised that I was back at my first problem
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
rt2500... whats next? Simdude90015 Linux - Hardware 9 01-04-2007 10:44 AM
rt2500 raghavendra Fedora 3 07-16-2006 07:44 AM
rt2500 package Michael_aust Debian 5 07-06-2006 02:04 PM
RT2500 USB Wireless & Slackware anyone.. -=Graz=- Slackware 8 03-31-2006 08:35 AM
HELP with RT2500 segapla Red Hat 2 08-14-2005 04:10 PM


All times are GMT -5. The time now is 09:38 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration