LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 02-10-2010, 05:11 AM   #1
neosix
LQ Newbie
 
Registered: Nov 2009
Distribution: Slackware
Posts: 7

Rep: Reputation: 0
Slackware and libnotify problem


Hello! I'm trying to use notify-send for my cron job, but there's a problem, notify-send doesn't work at all.

When I type:
Code:
notify-send Hello
nothing happens, no errors, nothing - just blank output.

Any idea?
 
Old 02-10-2010, 05:43 AM   #2
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,259

Rep: Reputation: Disabled
Since notify-send is a GUI program, it needs to know what display to use for the creation of its window.

Run your cron job like this:
Code:
DISPLAY=:0 notify-send Hello
Eric
 
Old 02-10-2010, 09:02 AM   #3
neosix
LQ Newbie
 
Registered: Nov 2009
Distribution: Slackware
Posts: 7

Original Poster
Rep: Reputation: 0
Alien_Bob thanks for replay.

Well I already tried that, but nothing. Then I tried the same thing with xmessage and everything works fine.

Really strange. Someting is wrong with libnotify, but what. I have no idea!
 
Old 02-10-2010, 09:44 AM   #4
DonnieP
Member
 
Registered: Jan 2008
Location: Richmond, VA USA
Distribution: Slackware
Posts: 144

Rep: Reputation: 29
Did you install notify-python?
 
Old 02-10-2010, 09:55 AM   #5
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 13,678

Rep: Reputation: 2546Reputation: 2546Reputation: 2546Reputation: 2546Reputation: 2546Reputation: 2546Reputation: 2546Reputation: 2546Reputation: 2546Reputation: 2546Reputation: 2546
http://www.slacky.eu/ has a notify-python package ..

http://repository.slacky.eu/slackwar...-python/0.1.1/

http://repository.slacky.eu/slackwar...1-i486-2as.txz
> notify-python-0.1.1-i486-2as.txz
.....
 
Old 02-10-2010, 10:01 AM   #6
DonnieP
Member
 
Registered: Jan 2008
Location: Richmond, VA USA
Distribution: Slackware
Posts: 144

Rep: Reputation: 29
Also slackbuilds.org which is where I got it.
 
Old 02-10-2010, 10:09 AM   #7
GazL
Senior Member
 
Registered: May 2008
Posts: 3,392

Rep: Reputation: 917Reputation: 917Reputation: 917Reputation: 917Reputation: 917Reputation: 917Reputation: 917Reputation: 917
I'm seeing the same issue on 64-current under kde4. knotify4 daemon is running, and notify-send is not throwing out any errors and exits rc=0
 
Old 02-10-2010, 01:39 PM   #8
neosix
LQ Newbie
 
Registered: Nov 2009
Distribution: Slackware
Posts: 7

Original Poster
Rep: Reputation: 0
OK, I installed python-notify but no change. I tried to cache some errors with strace, but nothing special. The only suspicios detail is this:

Code:
access("/etc/ld.so.preload", R_OK)      = -1 ENOENT (No such file or directory)
But ld.so.preload exist.
 
Old 02-10-2010, 04:47 PM   #9
DonnieP
Member
 
Registered: Jan 2008
Location: Richmond, VA USA
Distribution: Slackware
Posts: 144

Rep: Reputation: 29
What Desktop Environment are you using?
 
Old 02-11-2010, 08:07 AM   #10
neosix
LQ Newbie
 
Registered: Nov 2009
Distribution: Slackware
Posts: 7

Original Poster
Rep: Reputation: 0
Thanks everybody for replies. I can't solve this problem, but this morning mysteriously all my browsers stopped working. Once again I couldn't find a solution.

Currently I have no time for such problems, so... back to Ubuntu.

Thread closed!
 
  


Reply

Tags
slackware13


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Libnotify and notify-send problems J_Humphrey Slackware 8 07-27-2010 04:43 PM
LIBNOTIFY, no where to be found tqwillis Linux - Newbie 4 03-19-2009 10:13 AM
Slackware 12.0: boot problem & sudo / wifi-radar problem War_Ensemble Slackware 7 01-15-2008 09:49 AM


All times are GMT -5. The time now is 07:25 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration