LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 01-22-2003, 05:54 PM   #1
bobdobbs
LQ Newbie
 
Registered: Jan 2003
Posts: 3

Rep: Reputation: 0
slackware and cs4232/arts fight!!


ok, so i recently decided to finally fire windows (!!), and installed slack 8.1 (kernel 2.4.18) on my Dell Inspiron 3200. after reading thousands of man pages and countless HOWTO's and usr/docs and usr/src/linux/Documentation files, ive still come up with no answer. here it all is:

ive recompiled the kernel with OSS sound support and cs4232 both as modules. ive added the appropriate lines to BIOS and to /etc/rc.d/rc.modules:


insmod cs4232 io=0x530 irq=9 dma=1 dma2=0

now, it will boot correctly, the kernel identifies and loads the module, KDE boots properly, and Kmix shows my correct card, but when trying to play mp3s or wavs, it does this weird echo...1-2-3-4 would come out as 1-1-2-1-2-3-2-3-3-4-4 or something. no settings in the sound server configuration would change this.

the only way ive found it to play is if i _don't_ load the module at boot, start up KDE, (it gives an error of '/dev/dsp does not exist, loading to /dev/null instead' or something), open the terminal and then

insmod cs4232....etc

it, close out KDE and then restart it.

it seems as though loading the arts server needs to be done first, then the soundcard. is there any way of doing this? i tried putting

artsd
artsdsp

into etc/rc.d/rc.S, but to no avail. also tried
artsd -f (which forces it to run, even though no card)
but then it sticks on the 'dev/dsp' error message and won't continue booting. it also gives some errors about not being able to load some of it's correct modules anyway. ive also tried every possible irq value - and making them the same (and different!) in BIOS and /etc/rc.d/rc.modules

how can i remedy this?


 
Old 01-22-2003, 06:15 PM   #2
fskmh
Member
 
Registered: Jun 2002
Location: South Africa
Distribution: Slackware64-current multilib
Posts: 235

Rep: Reputation: 55
I've had a similar problem with an nvidia chipset. After starting up KDE, xmms would often hang, even though mpg321 worked. I figured that it had something to do with mmapped IO, so I just disabled aRts. Of course that means that I cannot play a divx with sound and an mp3 simultaneously but it doesn't bother me that much.
 
Old 01-22-2003, 08:08 PM   #3
Aussie
Senior Member
 
Registered: Sep 2001
Location: Brisvegas, Antipodes
Distribution: Slackware
Posts: 4,590

Rep: Reputation: 56
Why don't you try using "modprobe cs4232" instead of "insmod cs4232 io=0x530 irq=9 dma=1 dma2=0". Modprobe calls insmod and is designed to be a dynamic loader or modules, you then put any module options in /etc/modules.conf.
 
Old 01-22-2003, 08:36 PM   #4
Darin
Senior Member
 
Registered: Jan 2003
Location: Portland, OR USA
Distribution: Slackware, SLAX, Gentoo, RH/Fedora
Posts: 1,024

Rep: Reputation: 45
I have an old Intel Providence motherboard with onboard crystal sound and I never went through all that hoopla of putting settings in, all I did was uncomment this line from rc.modules:

# Crystal CS4232 based (PnP) cards:
#/sbin/modprobe cs4232

And I've never had any problems with it except the fact that it has NO amplification so if I don't use powered speakers I can barely hear it.
 
Old 01-22-2003, 11:08 PM   #5
bobdobbs
LQ Newbie
 
Registered: Jan 2003
Posts: 3

Original Poster
Rep: Reputation: 0
well, hate to disappoint all three of ya, but ive (1) tried modprobe, and it seems to create problems as well, besides there's no reason to edit yet another config file until i figure out what the settings i _actually_ need_, are. (2) simply uncommenting that line in rc.modules is the exact same thing, and (3) turning off arts..hmm. well, ive checked the box in the sound server config that says 'run arts server at KDE start' or something to that extent, but then the sound is still choppy/echoey. so i assumed that this meant that arts was just autoloading itself once i began to use the sound card. so either arts does autoload, and you know another way to turn it off (tell me please!), or it's as i assume and there's something weird and it really _does_ need to have it in this order:
arts loaded up,
insmod cs4232
KDE closed
KDE restarted

here's a good question: what happens with arts when KDE closes? maybe i just need to load the few modules (excuse me if my terminology is off, im still new to linux) that remain open when KDE closes..

oh and im pretty sure that its not simply disabling arts, since ive tried running xfce once ive done the insmod, and it gives me the same chop-chop sound...????? i dunno!!

thanks,
mic
 
Old 01-26-2003, 05:40 AM   #6
sidboyce
Member
 
Registered: Jan 2003
Location: Halesowen, West Midlands, UK
Distribution: SuSE 10.0/Mandriva 2006/gentoo
Posts: 86

Rep: Reputation: 15
I can't play sound from some apps unless I kill artsd. xine, xmovie etc. work fine with artsd running, but I have a problem with Windows media player under crossover-plugin and with the echolinux Hamradio program unless I kill artsd. I have a feeling that apps need to be arts aware for them to run. As previously understood, artsd is supposed to service sound to any app requiring it.
Regards
Sid.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
arts and alsa problem slackware 10.1 alamuru420123 Slackware 1 02-17-2005 11:08 PM
arts freezes! Sound only with mplayer + arts disabled metgorna Mandriva 0 09-18-2004 09:21 AM
Sound cs4232 Tunarle Slackware 2 01-08-2004 01:11 AM
aRts on Linux (Slackware) Tutorial chakantgm Linux - Newbie 0 08-01-2003 10:03 PM
Built In audio CS4232 help cronikus Linux - General 2 07-14-2003 10:46 AM


All times are GMT -5. The time now is 10:43 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration