LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 07-12-2003, 12:07 PM   #1
zerillos
LQ Newbie
 
Registered: Jul 2003
Posts: 1

Rep: Reputation: 0
Angry Slackware, AC97 onboard, VIA8233 - can't install ALSA - help please


here
I am getting really desperate with this sound. I have Slackware 8.0, kernel 2.2.19, sound system : AC97 onboard with VIA8233.
I have downloaded the ALSA stuff for sound but i can't get it installed. The configuration script runs well.

The problem is with make install...it gives some errore messages at the end, something about
make[2] : [ac97_codec.o] Error 1
....
[ compile ] Error 2

After this there is no snd_via82xx or any other module present.
modprobe snd_via82xx returns : can't find module snd_via82xx. I have edited modules.conf as they say in the documentation from ALSA.

I am desperate... I did everything thay say in the documentation and it is not working.
I am new to Slackware.Please help me!

 
Old 07-13-2003, 02:27 AM   #2
Henry
Member
 
Registered: Dec 2002
Location: USA
Distribution: Slackware9.0, some SuSe8.0
Posts: 179

Rep: Reputation: 30
if u compile the sound stuff like alsa-lib, alsa-tools,and alsa-utils before, then u don't need to do that again, just make, make install the alsa-driver... and chmod 755 /dev/mixer and /dev/dsp.
then in /etc/modules.conf, i dunno about urs, but mine is :

# ALSA portion
alias char-major-116 snd
alias snd-card-0 snd-cmipci

# OSS/Free portion
alias char-major-14 soundcore
alias sound-slot-0 snd-card-0

# card #1
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-12 snd-pcm-oss

#secondary
alias sound-service-1-0 snd-mixer-oss
alias sound-service-1-3 snd-pcm-oss
alias sound-service-1-12 snd-pcm-oss


so play around with that, then it should work...
 
Old 07-13-2003, 02:55 AM   #3
BittaBrotha
Member
 
Registered: Jan 2002
Location: Third Stone from the Sun
Distribution: Debian Sid, SourceMage 0.9.5, & To be Continued on a TP
Posts: 800

Rep: Reputation: 31
Did you follow this Alsa Link?

You also may need to make sure you have the VIA sound card module compiled into your kernel, and why are you using an old kernel?

The latest kernel is 2.4.21!
 
Old 07-13-2003, 06:13 AM   #4
Azmeen
Senior Member
 
Registered: May 2003
Location: Malaysia
Distribution: Slackware, LFS, CentOS
Posts: 1,307

Rep: Reputation: 46
Kernel 2.4.21 has built in support for VIA's on board AC97 sound... you might want to consider upgrading your kernel.
 
Old 07-14-2003, 10:23 PM   #5
dzhon
LQ Newbie
 
Registered: Oct 2002
Location: Denver, Colorado
Distribution: Slackware 9.0
Posts: 16

Rep: Reputation: 0
obtain Slackware 9.0. it will support the AC-97, has the 2.4.20 kernel and will even set the the right file permissions for you. I prefer to install just the ALSA libraries rather than the driver.
 
Old 07-15-2003, 07:16 AM   #6
cassidy
LQ Newbie
 
Registered: Jun 2003
Location: Athens, Greece
Distribution: slackware
Posts: 8

Rep: Reputation: 0
To compile the alsa drivers you need to have the kernel source installed and compiled from source (this does not come with the 1cd Slackware installation).

You'd be best advised to patch your kernel up to 2.4.21. It has support for the VT8233, whereas previous releases had not.

ps: the kernel modules perform better than the alsa ones, at least on my KUDOZ board
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ALSA, onboard sound and AC97 codec the_gumster Linux - Hardware 2 05-07-2004 09:58 PM
How to configure via8233 audio AC97 codec? svalovic Mandriva 3 03-05-2004 07:50 AM
via8233 onboard sound solved problem bibilit Linux - Software 0 02-01-2004 11:27 AM
Slackware sound (AC97 onboard) slacker001 Slackware 12 06-16-2003 01:51 AM
AC97 Onboard install on Debian elmetald00d Linux - General 0 05-05-2002 08:44 AM


All times are GMT -5. The time now is 08:07 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration